View Issue Details

IDProjectCategoryView StatusLast Update
0016010ScribusImport / Exportpublic2020-04-05 19:37
Reportermujeebcpy Assigned Tomapreri  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformgnulinuxOSkubuntuOS Version 19.10
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0016010: pdf import is distorting individual elements in pdf
Descriptionwhen some pdf (normally with graphic and text elements and in cmyk colorprofile) imported or opened in scribus. the pdf get distorted. im attaching the pdf here.
Steps To Reproducedownload the pdf from this thread
open that pdf in scribus or file ->import->get vector file
Additional Informationlibpoppler-utils version is 0.74
users with 0.71 not facing the issue. also 1.5.5 appimage also haven't this issue.
im attaching the pdf and the screenshot of actual pdf and how it appearing in scribus
TagsPDF, poppler
PatchNo

Activities

mujeebcpy

2019-12-16 15:49

reporter   ~0047273

due to internet issue the files weren't attached. attaching here

mujeebcpy

2019-12-16 16:00

reporter  

inscribus.png (169,129 bytes)
inscribus.png (169,129 bytes)

mujeebcpy

2019-12-16 16:36

reporter   ~0047274

the pdf file which makes the issue

mujeebcpy

2019-12-16 16:37

reporter  

WC AD 3.pdf (1,724,817 bytes)

ale

2019-12-16 17:27

manager   ~0047275

i can confirm that the pdf does not have issues with poppler 0.71

jghali

2019-12-16 17:52

administrator   ~0047277

I cannot reproduce this issue with poppler 0.83.

mujeebcpy

2019-12-16 18:04

reporter   ~0047278

could you able to open the above pdf without any issues?

PeterBenedek

2019-12-16 18:32

developer   ~0047281

Tested in Linux Mint 19.1; Scribus 1.5.6svn.appimage (fresh)

I see this...

inscribus.jpg (194,348 bytes)
inscribus.jpg (194,348 bytes)

mujeebcpy

2019-12-16 19:25

reporter   ~0047283

@peter it works on appimage. we have issue with ppa package, and personally i use fedora, its poppler version is 0.73. and im using own builded version of scribus. that too have the issue. i assume it related with poppler version.

mapreri

2020-01-14 12:12

developer   ~0047335

You wrote "Kubuntu 19.10", but that has poppler 0.80, not 0.74. Care to explain?

0.74 is in ubuntu disco (19.04) and in the PPA for bionic (18.04). I'm now going to update that copy to 0.80 as well for bionic, but I'd rather not do disco, since that's going to be unsupported in a couple of weeks.

mujeebcpy

2020-01-16 18:17

reporter   ~0047336

that was my mistake. it was 19.04. we didnt upgraded the systems, we plan to upgrade the systems to 20.04. till that we use 19.04. sorry for the mistake

mapreri

2020-01-16 22:31

developer   ~0047337

Alright, I uploaded a new poppler (basically, the same version currently in 20.04) to the PPA for 19.04, then re-uploaded scribus-ng to get it rebuilt against it.

Please check with version 1.5.5-0ubuntu19.04~ppa1 whether you can still see this bug.

mujeebcpy

2020-01-17 05:23

reporter   ~0047338

ok. will try. but we use scribus-trunk package. because in 1.5.5 hyphen in charecter style will crash the scribus. is this update comes to 1.5.6 ?

mapreri

2020-01-17 17:18

developer   ~0047339

yes, the scribus-trunk 1.5.6~svn packages are automatically built whenever there is a new commit in the trunk branch. When that will happen it will pick up the new poppler, so just wait for that to happen.

mapreri

2020-01-26 12:26

developer   ~0047346

AFAIK those packages have been rebuilt too now. Can you confirm whether this bug is fixed or not?

mujeebcpy

2020-01-27 05:16

reporter   ~0047347

yes. Fixed. Thank you

jghali

2020-01-27 12:28

administrator   ~0047349

@mapreri, thanks! Resolving then.

Issue History

Date Modified Username Field Change
2019-12-16 15:41 mujeebcpy New Issue
2019-12-16 15:41 mujeebcpy Tag Attached: PDF
2019-12-16 15:41 mujeebcpy Tag Attached: poppler
2019-12-16 15:49 mujeebcpy Note Added: 0047273
2019-12-16 16:00 mujeebcpy File Added: inscribus.png
2019-12-16 16:36 mujeebcpy Note Added: 0047274
2019-12-16 16:37 mujeebcpy File Added: WC AD 3.pdf
2019-12-16 17:27 ale Note Added: 0047275
2019-12-16 17:52 jghali Note Added: 0047277
2019-12-16 18:04 mujeebcpy Note Added: 0047278
2019-12-16 18:32 PeterBenedek File Added: inscribus.jpg
2019-12-16 18:32 PeterBenedek Note Added: 0047281
2019-12-16 19:25 mujeebcpy Note Added: 0047283
2020-01-14 12:12 mapreri Note Added: 0047335
2020-01-16 18:17 mujeebcpy Note Added: 0047336
2020-01-16 22:31 mapreri Note Added: 0047337
2020-01-17 05:23 mujeebcpy Note Added: 0047338
2020-01-17 17:18 mapreri Note Added: 0047339
2020-01-26 12:26 mapreri Note Added: 0047346
2020-01-27 05:16 mujeebcpy Note Added: 0047347
2020-01-27 12:28 jghali Assigned To => mapreri
2020-01-27 12:28 jghali Status new => resolved
2020-01-27 12:28 jghali Resolution open => fixed
2020-01-27 12:28 jghali Fixed in Version => 1.5.6.svn
2020-01-27 12:28 jghali Note Added: 0047349
2020-04-05 19:37 cbradney Status resolved => closed