View Issue Details

IDProjectCategoryView StatusLast Update
0016033ScribusColor Managementpublic2020-04-05 19:37
ReporterTraumflug Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.4.8 
Target VersionFixed in Version1.4.9.svn 
Summary0016033: SVG exports wrong colors
DescriptionSetting an object to a certain color and exporting that to SVG puts colors into the SVG not matching the color set in Scribus.
Steps To Reproduce1. Open the attached document.
2. Verify color management is turned off.
3. Verify color 'Admiral Blue' is set to RGB 17-52-110
4. Verify the box in the document uses this color.
5. Export the only page in this document to SVG.
6. Open this SVG in a text editor to view the color actually exported.

Expected outcome: color in SVG set to #11346e (17 = 0x11, 52 = 0x34, 110 = 0x6e)

Actual outcome: SVG containing this:
    <path style="fill:#10346e; fill-rule:eveno...
TagsNo tags attached.
PatchNo

Activities

Traumflug

2020-01-11 21:32

reporter  

Colorexport.sla (10,401 bytes)
Colorexport-Seite001.svg (364 bytes)

jghali

2020-01-11 23:00

administrator   ~0047331

Last edited: 2020-01-11 23:04

View 2 revisions

This issue is caused by a round-trip error between two Qt functions. It is already fixed in our 1.5.x development branch. I will however push a small workaround to 1.4.9.svn.

Traumflug

2020-01-13 13:24

reporter   ~0047334

Wow, this is a quick resolution! Thank you very much.

Issue History

Date Modified Username Field Change
2020-01-11 21:32 Traumflug New Issue
2020-01-11 21:32 Traumflug File Added: Bildschirmfoto vom 2020-01-11 22-15-33.png
2020-01-11 21:32 Traumflug File Added: Colorexport.sla
2020-01-11 21:32 Traumflug File Added: Colorexport-Seite001.svg
2020-01-11 23:00 jghali Note Added: 0047331
2020-01-11 23:04 jghali Note Edited: 0047331 View Revisions
2020-01-11 23:05 jghali Assigned To => jghali
2020-01-11 23:05 jghali Status new => resolved
2020-01-11 23:05 jghali Resolution open => fixed
2020-01-11 23:05 jghali Fixed in Version => 1.4.9.svn
2020-01-13 13:24 Traumflug Note Added: 0047334
2020-04-05 19:37 cbradney Status resolved => closed