View Issue Details

IDProjectCategoryView StatusLast Update
0016072ScribusPDFpublic2020-03-28 14:01
Reporterr.brunet Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformWindowsOSWIN64OS VersionWin7
Product Version1.5.5 
Target VersionFixed in Version 
Summary0016072: Black is not black for graylevel images in pdf export
DescriptionHello and thanks in advance,
I build La Revue russe now for 8 n° (4 years).
We send a big pdf file in 600 dpi with gray level pictures inside.
I found pictures "a little gray" after printing by Imprimerie Paillard in France. When Scribus opened the pdf file I looks a little gray only for the pictures. I got a screen sensor to calibrate my screen Samsung.
I was not sure, now I am.
I will send pdf test files with Acrobat 4, 5 and 6 and the Scribus one.

After months It seems that the problem is coming from File Compatibility> PDF 1.3 (Acrobat 4).

Many thanks and best regards,
Richard
Steps To ReproduceOpen RR53 test images.sla try to export in pdf, 600dppi no compression ... take care with Profil actuel : PDF 1.3 according to file option Compatibility PDF 1.3 (Acrobat 4).
Test with 1.4 (Acrobat 4) and 1.5 (Acrobat 6)




 
Additional InformationLook at my file RR53 test images Ac4 is good.
Ac5 and Ac6 are bad.

Files are here :
https://fromsmash.com/ys-fik7-qV-ct
Tagsblack, color management, gray, pdf export
PatchNo

Activities

jghali

2020-03-26 00:09

administrator   ~0047455

The .sla document does not embed images. Please provide images used by your sample document.

r.brunet

2020-03-26 10:57

reporter   ~0047464

Hello,
Nice to read you once more,

At the end I test pdf black level in GIMP :
In "barre de controle" out of page on the left I find : 35 (in all Ac4, 5 or 6)
In the Scribus one made by hand "0".

Lien du new Smash
https://fromsmash.com/t1Mv.bs7gT-ct

Trofimov - page 1
Trofifimov.tif - page 2 up
Trofifimov.bmp - page 2 down
Trofifimov.png - page 3

and a sla with images incorporated (never done before)

Thanks,
Richard

jghali

2020-03-26 11:31

administrator   ~0047465

I already had a look at the RR53 test_image_Ac4/Ac5/Ac6.pdf fields you provided. For your information, the data for the exported images in the three PDFs are strictly identical. Adobe Reader does not show any difference either when displaying the three PDFs on screen.

jghali

2020-03-26 13:38

administrator   ~0047469

I did several tests by making a sample test file with entirely black images and exported this file to PDF 1.3/1.4/1.5 using grayscale. The exported value for the image black was in all cases and as expected 0. So if you see 35 in GIMP, that means GIMP has probably applied some kind of color management when importing the PDF. As I have already said it plenty of time, GIMP is not a valid tool to inspect PDFs.

One thing to know: when printing in grayscale on press, the black ink alone does not allow to produce blacks as black as what CMYK can produce when using all 4 inks. In fact if you print a large square using K ink only with standard ink density values, it will look as a dark grey and not really black. That's why high end B&W photography books are regularly printed with more than just black ink. I've seen such books printed with Black + Pantone and even full CMYK.

r.brunet

2020-03-26 14:51

reporter   ~0047471

I use Adobe Reader 9 ver 9.3.4.218

I send Sreencapture with pdf AC4 left and Ac6 right opened in Adobe reader on my screen. Hope you see a difference.

Ac4-Ac6.png (887,324 bytes)
Ac4-Ac6.png (887,324 bytes)

r.brunet

2020-03-26 15:00

reporter   ~0047472

GIMP is not a valid tool to inspect PDFs.

Please tell me a valid one ?

jghali

2020-03-26 15:32

administrator   ~0047473

I see a difference in your screenshot. It looks like you have the transparency blending space defined as CMYK in Adobe Reader display preferences. This has following consequence:
- PDF 1.3 does not support transparency, so in PDF 1.3 files, this setting will make no differences and grayscale images will continue to be displayed as if they were RGB unless you activate also overprint preview
- PDF >= 1.4 support transparency, so for these files, setting the transparency blending space to CMYK will also have the effect to display grayscale images as if they would be printed using black ink only.

If you force overprint preview in Adobe Reader preferences, both Ac4.pdf and Ac6.pdf will look as what you observe on the right part of your screenshot. When overprint preview is enabled, Adobe Acrobat/Reader will perform a CMYK on screen simulation and will display grayscale images as if they would be printed using black ink only. When overprint preview is disabled (and transparency blending space set to RGB for PDF >= 1.4), grayscale images are displayed by Adobe Reader as if they were RGB images. They look more vibrant, but this will not match the print result.

So no bug in Scribus, just a matter of display preferences in Adobe Reader.

jghali

2020-03-26 15:32

administrator   ~0047474

>> Please tell me a valid one ?

Adobe Acrobat with Enfocus Pitstop.

jghali

2020-03-26 15:33

administrator   ~0047475

Or for PDF hackers podofobrowser or a simple text editor.

Issue History

Date Modified Username Field Change
2020-03-25 19:15 r.brunet New Issue
2020-03-25 19:15 r.brunet Tag Attached: black
2020-03-25 19:15 r.brunet Tag Attached: color management
2020-03-25 19:15 r.brunet Tag Attached: gray
2020-03-25 19:15 r.brunet Tag Attached: pdf export
2020-03-26 00:09 jghali Note Added: 0047455
2020-03-26 10:57 r.brunet Note Added: 0047464
2020-03-26 11:31 jghali Note Added: 0047465
2020-03-26 13:38 jghali Note Added: 0047469
2020-03-26 14:51 r.brunet File Added: Ac4-Ac6.png
2020-03-26 14:51 r.brunet Note Added: 0047471
2020-03-26 15:00 r.brunet Note Added: 0047472
2020-03-26 15:32 jghali Note Added: 0047473
2020-03-26 15:32 jghali Note Added: 0047474
2020-03-26 15:33 jghali Note Added: 0047475
2020-03-28 14:01 jghali Assigned To => jghali
2020-03-28 14:01 jghali Status new => resolved
2020-03-28 14:01 jghali Resolution open => no change required
2020-03-28 14:01 jghali Status resolved => closed