View Issue Details

IDProjectCategoryView StatusLast Update
0016131ScribusPlug-inspublic2020-07-03 17:16
Reporterutnik Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSmacOS Version10.14.6
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0016131: scribus can't load 'libscriptplugin'
Descriptionwhen i launch scribus 1.5.6.svn-r23848 a dialog tells me that there is a problem loading 'libscriptplugin.so' – cleaning everything scribus related in 'library/application support' and 'library/preferences' didn't solve the issue.
so far i had no problems. but i don't know what this plug-in does…
TagsNo tags attached.
PatchNo

Activities

utnik

2020-06-04 17:44

updater  

ale

2020-06-05 06:42

manager   ~0047675

hi utnik

it's for the scripter.

as far as i know, there is an issue with macOs and python3 ... this might be related.

utnik

2020-06-06 06:56

updater   ~0047676

was there a python3 related change in the last two month? r23576 didn't show this dialog.

ale

2020-06-06 11:59

manager   ~0047677

afaik scribus is now python3 only, except for macos... where the python2 scripter is kept around until craig solves the issues with python3...
to me the most likely cause of the issue, is that craig has forgotten the switch when creating a dmg. or that there is a mismatch in the 32/64 bits part.

i have no idea what the issue with python3, since python3 works perfectly on macos and, personally, i would wish that scribus would simply provide a copy of python3 or expect the user to install python3 before running the scribus script.
the first is the case on windows, the second linux.

jghali

2020-06-06 14:44

administrator   ~0047679

Last edited: 2020-06-06 14:45

View 2 revisions

>> i have no idea what the issue with python3

Well afaik MacOS ships python 2, not python3. So for the current scripter to work on MacOS, Craig has to bundle python3 with scribus. And apparently bundling python 3 with scribus is a bit problematic on MacOS. On Windows, scribus has been bundling python for a long time, and now it also bundles python 3 in Windows 1.5.6.svn snapshots.

cbradney

2020-06-25 10:18

administrator   ~0047726

I found this is a code issue, not packaging. I'll republish a new package once its fixed in code.

cbradney

2020-06-25 15:31

administrator   ~0047727

r23903 dmg uploaded to sourceforge

utnik

2020-06-25 20:38

updater   ~0047730

just tested – it works.
thanks!

Issue History

Date Modified Username Field Change
2020-06-04 17:44 utnik New Issue
2020-06-04 17:44 utnik File Added: Bildschirmfoto 2020-05-30 um 21.27.32.png
2020-06-05 06:42 ale Note Added: 0047675
2020-06-06 06:56 utnik Note Added: 0047676
2020-06-06 11:59 ale Note Added: 0047677
2020-06-06 14:44 jghali Note Added: 0047679
2020-06-06 14:45 jghali Note Edited: 0047679 View Revisions
2020-06-25 10:18 cbradney Note Added: 0047726
2020-06-25 15:31 cbradney Assigned To => cbradney
2020-06-25 15:31 cbradney Status new => resolved
2020-06-25 15:31 cbradney Resolution open => fixed
2020-06-25 15:31 cbradney Fixed in Version => 1.5.6.svn
2020-06-25 15:31 cbradney Note Added: 0047727
2020-06-25 20:38 utnik Note Added: 0047730
2020-07-03 17:16 cbradney Status resolved => closed