View Issue Details

IDProjectCategoryView StatusLast Update
0016228ScribusUsabilitypublic2020-09-02 12:26
ReporterAndreasDavour Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.5.6.svn 
Target VersionFixed in Version 
Summary0016228: Importing another sla file does not create linked frames when adding pages
DescriptionI have one project where I create one file per chapter, and then import them all into one document to get the page numbering correct.
When I select Page->Import, select another sla file, Import Pages *, and check the "Create Page(s)" checkbox I get a combined document with the two documents, except that after the first page of the document is blank!

I figured out that the little symbol down in the corner indicated a text box overflow, and the document had been imported, and the pages created, but the text frames had not been linked, so you had to do that manually. When you have 200 pages, that is just not doable, also, the behaviour is quite intuitive. I'm also pretty sure, even though I have no ability to test, that in version 1.4.x the text frames where linked automatically.

I would consider this a bug, and a quite severe one.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0008056 assignedale [WIP PATCH] Import pages with linked text frames breaks the links 

Activities

JLuc

2020-09-02 12:04

developer   ~0048018

I've never managed to achieve what you intend to do, due to various Scribus 1.4 and 1.5 issues relating to import, linked text frame and styles conflicts.
Instead of doing so i produce separate PDF and merge them.
I created a set of script to automate this and other various operation on the set of chapters : https://github.com/JLuc/scribus-project-manager

jghali

2020-09-02 12:25

administrator   ~0048019

Duplicate of issue 0008056

Issue History

Date Modified Username Field Change
2020-09-02 09:13 AndreasDavour New Issue
2020-09-02 12:04 JLuc Note Added: 0048018
2020-09-02 12:25 jghali Assigned To => jghali
2020-09-02 12:25 jghali Status new => resolved
2020-09-02 12:25 jghali Resolution open => duplicate
2020-09-02 12:25 jghali Note Added: 0048019
2020-09-02 12:25 jghali Relationship added duplicate of 0008056
2020-09-02 12:26 jghali Status resolved => closed