View Issue Details
|ID||Project||Category||View Status||Date Submitted||Last Update|
|0016239||Scribus||Scripter||public||2020-09-14 08:16||2020-09-14 13:42|
|Target Version||Fixed in Version|
|Summary||0016239: add setPosition() to the scripter|
|Description||currently, there is only a moveObject.|
|Tags||No tags attached.|
||You can already modify an object position by calling setProperty with "xPos" and "yPos" properties.|
||It seems also that the documented moveObjectAbs already accomplish what setPosition would do.|
ok, i've overseen moveObjectAbs, sorry.
but, imo, it's rather a bad name for this function.
we have a getPosition() which is probably one of the most used functions of the scripter API.
it feels natural to have a setPosition(x, y) or setPosition((x, y)).
i would dare to say that even movePosition(dx, dy) would feel better than moveObject().
i suggest to:
- add setPosition()
- deprecate movePositionAbs()
- think of renaming moveObject() to fit the set/get naming (i'm not 100% sure movePosition() is good enough)
setProperty() with the position can stay, but i fear nobody uses it.