View Issue Details

IDProjectCategoryView StatusLast Update
0016304ScribusGeneralpublic2020-11-07 20:11
ReporterLuna Nightshade Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMint 20OSLinuxOS VersionLinux Mint 20
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0016304: Line selection hitboxes extend "above" the line after loading a document
DescriptionThis is a quirky one. I have a few documents where I used simple lines as ornamental objects.
If I open these documents in the latest versions, I have a hard time editing some objects, because I will always select a line, even though I do not even click anywhere close to it.

This doesn't happen, when the line is first created. But if the document is saved, closed and then loaded again, click above a horizontal line, or left/right of a vertical line (depending on the angle the line is set at), you will select the line, even though you shouldn't. This can even be pages upwards.

[I hope I haven't thrown vertical and horizontal under the bus and mixed them up afterwards]
Steps To ReproduceCreate a line somwhere on the document - preferrably the middle.
SAVE the document.
CLOSE the document.
OPEN the document.
The line will behave as written above.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0016089 closedPeterBenedek If you change direction of Line, area of line is increased 

Activities

Luna Nightshade

2020-11-02 17:38

reporter  

test.sla (14,882 bytes)

jghali

2020-11-02 17:57

administrator   ~0048294

Unable to reproduce, works as expected here.

Luna Nightshade

2020-11-02 18:43

reporter   ~0048298

I have high-dpi (double, 192). Could that be an issue?

Just changed the dpi value in the font rendering details - and the place where I can click to select the line shifts with it.

jghali

2020-11-02 20:26

administrator   ~0048299

>> I have high-dpi (double, 192). Could that be an issue?

Maybe. Unfortunately I don't have any high-dpi screen at hand, so I won't be able to test or help on that matter.

ale

2020-11-03 07:27

manager   ~0048300

iirc, the same complain (with less details) has also been filled, so luna nightshade might not be the only one affected...

@luna nightshade, can you confirm that you are running a current 1.5.6svn?

ale

2020-11-03 07:29

manager   ~0048301

here is the other report: https://github.com/flathub/net.scribus.Scribus/issues/25

ale

2020-11-03 07:31

manager   ~0048302

ok, i can reproduce.
i also have a high dpi monitor, iirc with 1.5x

ale

2020-11-03 07:35

manager   ~0048303

Last edited: 2020-11-03 07:35

View 2 revisions

funny, rotating the line shows the active clickable area of the line.

to be clear: if i click inside of the blue area, the line gets selected.



line-rotate.gif (105,154 bytes)
line-rotate.gif (105,154 bytes)

Luna Nightshade

2020-11-03 09:17

reporter   ~0048305

I am using the latest version available via the PPA.
And on another machine, also running linux MINT 20 (64 bit), using the MATE desktop, the default is 96 dpi, and the "hitbox" extends below the line (exactly the opposite in comparison to the higher dpi on my primary machine).

Maybe I can get out an older machine later and see, if that problem doesn't exist on windows.

ale

2020-11-03 09:46

manager   ~0048306

an interesting information from the ticket on flathub: the 1.5.5 appimage does not show the issue.

i could test with:

- the current appimage and it shows the issue but on the other side (with the same file)
- the 1.5.5 appimage does not show the problem (and does not detect the hdpi monitor). but the active area for the line seems to be a bit too large.

utnik

2020-11-03 11:29

updater   ~0048311

i can confirm the issue on macOS 10.14.6 with scribus1.5.6-r24102 (with the file from luna nightshade and with own files ofter rotating the lines…)

Luna Nightshade

2020-11-03 17:32

reporter   ~0048314

I just downloaded the latest version from SourceForge on Windows. That installation seems unaffected - at least in regards of clicking on a line. This holds true, even if I increase the UI scaling from 100% to 150%.

If the appimage doesn't show the problem ... then maybe the error can be traced to some dependency?

ale

2020-11-03 18:37

manager   ~0048317

from the information collected, it's likely that the bug comes with the support of hidpi screens which came after 1.5.5 was released.

jghali

2020-11-03 20:27

administrator   ~0048319

Hmmm, I'm now unsure about the role of HiDPI screens. I did a test in a Linux virtual machine on my laptop, which for sure has no HiDPI screen, and on Linux I see the issue.

jghali

2020-11-04 00:12

administrator   ~0048321

I've found the cause of the issue and it explains also the behavior difference on Windows and Linux as the fix involves a case of undefined behavior. The fix has been committed as r24168.

Issue History

Date Modified Username Field Change
2020-11-02 17:38 Luna Nightshade New Issue
2020-11-02 17:38 Luna Nightshade File Added: test.sla
2020-11-02 17:57 jghali Note Added: 0048294
2020-11-02 18:43 Luna Nightshade Note Added: 0048298
2020-11-02 20:26 jghali Note Added: 0048299
2020-11-03 07:27 ale Note Added: 0048300
2020-11-03 07:29 ale Note Added: 0048301
2020-11-03 07:31 ale Note Added: 0048302
2020-11-03 07:35 ale File Added: line-rotate.gif
2020-11-03 07:35 ale Note Added: 0048303
2020-11-03 07:35 ale Note Edited: 0048303 View Revisions
2020-11-03 09:17 Luna Nightshade Note Added: 0048305
2020-11-03 09:46 ale Note Added: 0048306
2020-11-03 11:29 utnik Note Added: 0048311
2020-11-03 17:32 Luna Nightshade Note Added: 0048314
2020-11-03 18:37 ale Note Added: 0048317
2020-11-03 20:27 jghali Note Added: 0048319
2020-11-03 20:35 jghali Summary Line Selection Hitboxes extend "above" the line after loading a document => Line selection hitboxes extend "above" the line after loading a document
2020-11-04 00:12 jghali Note Added: 0048321
2020-11-04 00:12 jghali Assigned To => jghali
2020-11-04 00:12 jghali Status new => resolved
2020-11-04 00:12 jghali Resolution open => fixed
2020-11-04 00:12 jghali Fixed in Version => 1.5.6.svn
2020-11-07 14:52 cbradney Status resolved => closed
2020-11-07 20:11 PeterBenedek Relationship added duplicate of 0016089