View Issue Details

IDProjectCategoryView StatusLast Update
0016621ScribusGeneralpublic2021-08-24 00:41
Reporterluzpaz Assigned Tojghali  
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.5.8.svn 
Fixed in Version1.5.8.svn 
Summary0016621: Typo fixes in source code + source comments
DescriptionPatch with source code changes. Please review carefully. Thanks.
TagsNo tags attached.
PatchYes

Activities

luzpaz

2021-08-21 03:17

reporter  

scribus-source-typos.patch (13,898 bytes)   
From d4f0f77d06e14092e330d7715353f783cc396dea Mon Sep 17 00:00:00 2001
From: luz paz <luzpaz@users.noreply.github.com>
Date: Fri, 20 Aug 2021 23:04:59 -0400
Subject: [PATCH 1/5] Fix source typo titel->title

---
 scribus/ui/newtemp.cpp | 4 ++--
 scribus/ui/newtemp.h   | 2 +-
 scribus/ui/query.cpp   | 4 ++--
 scribus/ui/query.h     | 2 +-
 4 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/scribus/ui/newtemp.cpp b/scribus/ui/newtemp.cpp
index 07f83a456e..b5a5c44415 100644
--- a/scribus/ui/newtemp.cpp
+++ b/scribus/ui/newtemp.cpp
@@ -21,11 +21,11 @@ for which a new license (GPL+exception) is in place.
 #include "scpage.h"
 #include "scribusdoc.h"
 
-NewTm::NewTm( QWidget* parent, const QString& text, const QString& titel, ScribusDoc *doc, const QString& answerText)
+NewTm::NewTm( QWidget* parent, const QString& text, const QString& title, ScribusDoc *doc, const QString& answerText)
 		: QDialog( parent )
 {
 	setModal(true);
-	setWindowTitle(titel);
+	setWindowTitle(title);
 	setWindowIcon(IconManager::instance().loadIcon("AppIcon.png"));
 	QueryLayout = new QVBoxLayout( this );
 	QueryLayout->setSpacing(6);
diff --git a/scribus/ui/newtemp.h b/scribus/ui/newtemp.h
index ed9a8d2924..cc6aa8b670 100644
--- a/scribus/ui/newtemp.h
+++ b/scribus/ui/newtemp.h
@@ -23,7 +23,7 @@ class SCRIBUS_API NewTm : public QDialog
 	Q_OBJECT
 
 public:
-	NewTm(QWidget* parent, const QString& text, const QString& titel, ScribusDoc *doc, const QString& answerText=QString() );
+	NewTm(QWidget* parent, const QString& text, const QString& title, ScribusDoc *doc, const QString& answerText=QString() );
 	~NewTm() {};
 
 	QPushButton* PushButton1;
diff --git a/scribus/ui/query.cpp b/scribus/ui/query.cpp
index ab03e95cb6..ecf97a46f1 100644
--- a/scribus/ui/query.cpp
+++ b/scribus/ui/query.cpp
@@ -17,9 +17,9 @@ for which a new license (GPL+exception) is in place.
 #include "ui/scmessagebox.h"
 #include "iconmanager.h"
 
-Query::Query( QWidget* parent,  const char* name, bool modal, const QString& text, const QString& titel ) : QDialog( parent )
+Query::Query( QWidget* parent,  const char* name, bool modal, const QString& text, const QString& title ) : QDialog( parent )
 {
-	setWindowTitle( titel );
+	setWindowTitle( title );
 	setWindowIcon(IconManager::instance().loadIcon("AppIcon.png"));
 	setModal(modal);
 	queryLayout = new QVBoxLayout( this );
diff --git a/scribus/ui/query.h b/scribus/ui/query.h
index 89e5e6307f..873bb544cc 100644
--- a/scribus/ui/query.h
+++ b/scribus/ui/query.h
@@ -23,7 +23,7 @@ class SCRIBUS_API Query : public QDialog
 	Q_OBJECT
 
 public:
-	Query(QWidget* parent=nullptr, const char* name=nullptr, bool modal = false, const QString& text=0, const QString& titel=0 );
+	Query(QWidget* parent=nullptr, const char* name=nullptr, bool modal = false, const QString& text=0, const QString& title=0 );
 	~Query() {};
 
 	QString getEditText() const;
-- 
2.32.0


From 683d714b62e4e13a328e77b2ad127006aaff2064 Mon Sep 17 00:00:00 2001
From: luz paz <luzpaz@users.noreply.github.com>
Date: Fri, 20 Aug 2021 23:06:11 -0400
Subject: [PATCH 2/5] Fix source typo vaild->valid

---
 scribus/ui/query.cpp | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/scribus/ui/query.cpp b/scribus/ui/query.cpp
index ecf97a46f1..20a42fd3fa 100644
--- a/scribus/ui/query.cpp
+++ b/scribus/ui/query.cpp
@@ -129,6 +129,6 @@ void Query::setCheckMode(bool mode)
 
 void Query::setValidator(const QRegExp& rx)
 {
-	QValidator* vaild = new QRegExpValidator( rx, this );
-	answerEdit->setValidator(vaild);
+	QValidator* valid = new QRegExpValidator( rx, this );
+	answerEdit->setValidator(valid);
 }
-- 
2.32.0


From ad11264cac6fbf36c359891c8b8efa9a870915b2 Mon Sep 17 00:00:00 2001
From: luz paz <luzpaz@users.noreply.github.com>
Date: Fri, 20 Aug 2021 23:07:01 -0400
Subject: [PATCH 3/5] Fix source typo completition->completion

---
 scribus/plugins/scripter/python/sceditor/assist.py | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/scribus/plugins/scripter/python/sceditor/assist.py b/scribus/plugins/scripter/python/sceditor/assist.py
index 33734802f4..c6825345b0 100644
--- a/scribus/plugins/scripter/python/sceditor/assist.py
+++ b/scribus/plugins/scripter/python/sceditor/assist.py
@@ -95,19 +95,19 @@ class AutoComplete(PopupWidget):
 
 
     def insert(self):
-        completition = self.items[self.list.currentRow()].value
+        completion = self.items[self.list.currentRow()].value
         cursor = self.textedit.textCursor()
         col = cursor.columnNumber()
         line = unicode(cursor.block().text())
         i = self.cursor_start_col
         while i > 0:
             #print `line[i:col]`
-            if completition.startswith(line[i:col]):
+            if completion.startswith(line[i:col]):
                 #print "break"
                 break
             i -= 1
         #print col,i
-        cursor.insertText(completition[col-i:])
+        cursor.insertText(completion[col-i:])
         self.hide()
 
 
-- 
2.32.0


From c0b32cf312a4e648e0be4cdb4f349e5b1e98814b Mon Sep 17 00:00:00 2001
From: luz paz <luzpaz@users.noreply.github.com>
Date: Fri, 20 Aug 2021 23:07:20 -0400
Subject: [PATCH 4/5] Fix source typo defaut->default

---
 scribus/colormgmt/sclcmscolormgmtengineimpl.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/scribus/colormgmt/sclcmscolormgmtengineimpl.h b/scribus/colormgmt/sclcmscolormgmtengineimpl.h
index 3351688b93..46ebc445bb 100644
--- a/scribus/colormgmt/sclcmscolormgmtengineimpl.h
+++ b/scribus/colormgmt/sclcmscolormgmtengineimpl.h
@@ -57,7 +57,7 @@ protected:
 
 	static DWORD translateFlagsToLcmsFlags(long flags);
 	static DWORD translateFormatToLcmsFormat(eColorFormat format);
-	static int translateIntentToLcmsIntent(eRenderIntent intent, eRenderIntent defaut = Intent_Relative_Colorimetric);
+	static int translateIntentToLcmsIntent(eRenderIntent intent, eRenderIntent default = Intent_Relative_Colorimetric);
 	static eColorSpaceType translateLcmsColorSpaceType(icColorSpaceSignature);
 	static eProfileClass   translateLcmsProfileClass(icProfileClassSignature);
 
-- 
2.32.0


From 03dea592a26597e3cdfac6fb97b91c34c6490947 Mon Sep 17 00:00:00 2001
From: luz paz <luzpaz@users.noreply.github.com>
Date: Fri, 20 Aug 2021 23:07:52 -0400
Subject: [PATCH 5/5] Fix source comment typos + refinements

---
 scribus/desaxe/simple_actions.h                  | 2 +-
 scribus/pageitem.h                               | 2 +-
 scribus/pdflib_core.cpp                          | 2 +-
 scribus/plugins/gettext/xtgim/xtgscanner.cpp     | 2 +-
 scribus/plugins/scripter/doc/TUTORIAL            | 2 +-
 scribus/plugins/scriptplugin/objpdffile.cpp      | 4 ++--
 scribus/plugins/scriptplugin_py2x/objpdffile.cpp | 4 ++--
 scribus/ui/smtextstyles.cpp                      | 4 ++--
 8 files changed, 11 insertions(+), 11 deletions(-)

diff --git a/scribus/desaxe/simple_actions.h b/scribus/desaxe/simple_actions.h
index d267984904..30c007f108 100644
--- a/scribus/desaxe/simple_actions.h
+++ b/scribus/desaxe/simple_actions.h
@@ -113,7 +113,7 @@ struct  FactoryWithArgs : public MakeGenerator<FactoryWithArgs_body<Type>, Type,
 
 /**
  *   Pushes a new object of type Obj_Type onto the stack which is initialized with the tag name.
- *   If no create method is given, Obj_Type needs a constructor which taks a Xml_string argument
+ *   If no create method is given, Obj_Type needs a constructor which takes a Xml_string argument
  */
 template<class Obj_Type>
 class FactoryWithName_body : public Generator_body<Obj_Type>
diff --git a/scribus/pageitem.h b/scribus/pageitem.h
index 932bb6ca0c..1f22ed5135 100644
--- a/scribus/pageitem.h
+++ b/scribus/pageitem.h
@@ -1853,7 +1853,7 @@ protected: // Start protected variables
 	double m_height {0.0}; ///<  Height of the item
 	double m_rotation {0.0}; ///< Rotation of the item
 	bool   m_isSelected {false}; ///< Is the item selected?
-	bool   m_imageVisible {true}; ///< Darstellungsart Bild/Titel
+	bool   m_imageVisible {true}; ///< Is the image/title visible?
 	double m_imageXScale {1.0}; ///< Scaling X Factor for images
 	double m_imageYScale {1.0}; ///< Scaling Y Factor for images
 	double m_imageXOffset {0.0}; ///< Image X Offset to frame
diff --git a/scribus/pdflib_core.cpp b/scribus/pdflib_core.cpp
index 29746a07a2..91d7f13937 100644
--- a/scribus/pdflib_core.cpp
+++ b/scribus/pdflib_core.cpp
@@ -679,7 +679,7 @@ bool PDFLibCore::doExport(const QString& fn, const std::vector<int> & pageNs, co
 				progressDialog->setOverallProgress(pc_exportmasterpages+pc_exportpages);
 			}
 		}
-		ret = true;//Even when aborting we return true. Don't want that "couldnt write msg"
+		ret = true;//Even when aborting we return true. Don't want that "couldn't write msg"
 		if (!abortExport)
 		{
 			if (PDF_IsPDFX(Options.Version))
diff --git a/scribus/plugins/gettext/xtgim/xtgscanner.cpp b/scribus/plugins/gettext/xtgim/xtgscanner.cpp
index 103e9108c1..fa9e9a8947 100755
--- a/scribus/plugins/gettext/xtgim/xtgscanner.cpp
+++ b/scribus/plugins/gettext/xtgim/xtgscanner.cpp
@@ -1303,7 +1303,7 @@ QString XtgScanner::getToken()
 			/**
 			An escape sequence is occurred, hence we will just append 
 			the next character in buffer to the text. This will automatically
-			deal the occurrance of '\@' or '\:' or any other relevant escapes
+			deal the occurrence of '\@' or '\:' or any other relevant escapes
 			*/
 			m_textIndex = m_textIndex+1;
 			m_textToAppend.append( nextSymbol() );
diff --git a/scribus/plugins/scripter/doc/TUTORIAL b/scribus/plugins/scripter/doc/TUTORIAL
index 9c4356b932..0033813052 100644
--- a/scribus/plugins/scripter/doc/TUTORIAL
+++ b/scribus/plugins/scripter/doc/TUTORIAL
@@ -107,7 +107,7 @@ For both languages there is a great amount of documentation and
 free articles on the internet available, e.g.:
   * http://www.diveintopython.org/toc/index.html
   * http://www.unix.com.ua/orelly/web/jscript/
-For a C/C++ or PHP programmer the syntax of QtScript might be more appealling 
+For a C/C++ or PHP programmer the syntax of QtScript might be more appealing 
 because it's nearly the same. Python is suitable for beginners as well as computer
 scientists. 
 Additionally Python provides powerful third-party libraries (database 
diff --git a/scribus/plugins/scriptplugin/objpdffile.cpp b/scribus/plugins/scriptplugin/objpdffile.cpp
index 3ee7bf8e90..5ff583d6a5 100644
--- a/scribus/plugins/scriptplugin/objpdffile.cpp
+++ b/scribus/plugins/scriptplugin/objpdffile.cpp
@@ -1327,7 +1327,7 @@ static int PDFfile_setopenAction(PDFfile *self, PyObject *value, void * /*closur
 
 static char *effval_doc = const_cast<char*>(
 "List of effection values for each saved page.\n"
-"It is list of list of six integers. Those int has followin meaning:\n\t"
+"It is a list of a list of six integers. Those int have the following meaning:\n\t"
 "- Length of time the page is shown before the presentation\n\tstarts on the selected page. (1-3600)\n\t"
 "- Length of time the effect runs. (1 - 3600)\n\t\tA shorter time will speed up the effect,\n\t\ta longer one will slow it down\n\t"
 "- Type of the display effect\n\t\t0 - No Effect\n\t\t1 - Blinds\n\t\t2 - Box\n\t\t3 - Dissolve\n\t\t4 - Glitter\n\t\t5 - Split\n\t\t6 - Wipe\n\t"
@@ -1337,7 +1337,7 @@ static char *effval_doc = const_cast<char*>(
 
 static char *lpival_doc = const_cast<char*>(
 "Rendering Settings for individual colors.\n\n"
-"This is list of values for each color\n"
+"This is a list of values for each color\n"
 "Color values have structure [siii] which stand for:\n\t"
 "s - Color name ('Black', 'Cyan', 'Magenta', 'Yellow')\n\t"
 "i - Frequency (10 to 1000)\n\t"
diff --git a/scribus/plugins/scriptplugin_py2x/objpdffile.cpp b/scribus/plugins/scriptplugin_py2x/objpdffile.cpp
index 4eb3737568..59f7394f3c 100644
--- a/scribus/plugins/scriptplugin_py2x/objpdffile.cpp
+++ b/scribus/plugins/scriptplugin_py2x/objpdffile.cpp
@@ -1327,7 +1327,7 @@ static int PDFfile_setopenAction(PDFfile *self, PyObject *value, void * /*closur
 
 static char *effval_doc = const_cast<char*>(
 "List of effection values for each saved page.\n"
-"It is list of list of six integers. Those int has followin meaning:\n\t"
+"It is a list of a list of six integers. Those int has the following meaning:\n\t"
 "- Length of time the page is shown before the presentation\n\tstarts on the selected page. (1-3600)\n\t"
 "- Length of time the effect runs. (1 - 3600)\n\t\tA shorter time will speed up the effect,\n\t\ta longer one will slow it down\n\t"
 "- Type of the display effect\n\t\t0 - No Effect\n\t\t1 - Blinds\n\t\t2 - Box\n\t\t3 - Dissolve\n\t\t4 - Glitter\n\t\t5 - Split\n\t\t6 - Wipe\n\t"
@@ -1337,7 +1337,7 @@ static char *effval_doc = const_cast<char*>(
 
 static char *lpival_doc = const_cast<char*>(
 "Rendering Settings for individual colors.\n\n"
-"This is list of values for each color\n"
+"This is a list of values for each color\n"
 "Color values have structure [siii] which stand for:\n\t"
 "s - Color name ('Black', 'Cyan', 'Magenta', 'Yellow')\n\t"
 "i - Frequency (10 to 1000)\n\t"
diff --git a/scribus/ui/smtextstyles.cpp b/scribus/ui/smtextstyles.cpp
index 238fd69673..983506b1eb 100644
--- a/scribus/ui/smtextstyles.cpp
+++ b/scribus/ui/smtextstyles.cpp
@@ -184,7 +184,7 @@ QString SMParagraphStyle::fromSelection() const
 
 	for (int i = 0; i < m_doc->m_Selection->count(); ++i)
 	{
-		// wth is going on here
+		// FIXME: wth is going on here
 		PageItem *item = m_doc->m_Selection->itemAt(i);
 
 		QString tmpName = item->itemText.defaultStyle().parent();
@@ -1978,7 +1978,7 @@ QString SMCharacterStyle::fromSelection() const
 
 	for (int i = 0; i < m_doc->m_Selection->count(); ++i)
 	{
-		// wth is going on here
+		// FIXME: wth is going on here
 		PageItem *item = m_doc->m_Selection->itemAt(i);
 
 		QString tmpName = item->itemText.defaultStyle().charStyle().parent();
-- 
2.32.0

scribus-source-typos.patch (13,898 bytes)   

jghali

2021-08-24 00:41

administrator   ~0049227

Committed, thanks

Issue History

Date Modified Username Field Change
2021-08-21 03:17 luzpaz New Issue
2021-08-21 03:17 luzpaz File Added: scribus-source-typos.patch
2021-08-24 00:41 jghali Assigned To => jghali
2021-08-24 00:41 jghali Status new => resolved
2021-08-24 00:41 jghali Resolution open => fixed
2021-08-24 00:41 jghali Fixed in Version => 1.5.8.svn
2021-08-24 00:41 jghali Note Added: 0049227