View Issue Details

IDProjectCategoryView StatusLast Update
0016754ScribusUser Interfacepublic2022-02-18 15:52
Reporterfredzannarbor Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSMonterey 
Product Version1.5.8.svn 
Fixed in Version1.5.9.svn 
Summary0016754: Keyboard shortcuts always load "iCalamusTM" and modifications cannot be saved.
DescriptionKeyboard shortcuts always load "iCalamusTM" and modifications cannot be saved.

Also, what is "iCalamus" and why should Scribus users care?
Steps To ReproduceOpen Preferences > Keyboard Shortcuts
TagsNo tags attached.
PatchNo

Activities

fredzannarbor

2022-02-16 00:58

reporter  

JLuc

2022-02-16 09:49

developer   ~0049551

IE : the default SELECT display should show the actualy active shortcuts set (which defaults to Scribus set).
As for now, it doesnt care the active set and default displays the alphabeticaly first option.

jghali

2022-02-16 20:03

administrator   ~0049552

Last edited: 2022-02-16 20:04

>> Keyboard shortcuts always load "iCalamus (TM)"

If I select "PagePlus X3 (TM)" and click load, the shortcuts clearly changes, so... cannot reproduce.

>> and modifications cannot be saved.

This is exactly what the "Export..." button does.

JLuc

2022-02-16 22:00

developer   ~0049553

I think it's just a matter of display.

cbradney

2022-02-18 15:52

administrator   ~0049557

I have forced the current version of Scribus set to the top of the list, however the list there does not represent what is in use, however what is available to be loaded. This, for reference, is so that people transitioning from another application could use the same shortcuts where they may be applicable.

Issue History

Date Modified Username Field Change
2022-02-16 00:58 fredzannarbor New Issue
2022-02-16 00:58 fredzannarbor File Added: Screen Shot 2022-02-15 at 7.55.19 PM.png
2022-02-16 09:49 JLuc Note Added: 0049551
2022-02-16 20:03 jghali Note Added: 0049552
2022-02-16 20:04 jghali Note Edited: 0049552
2022-02-16 22:00 JLuc Note Added: 0049553
2022-02-18 15:52 cbradney Assigned To => cbradney
2022-02-18 15:52 cbradney Status new => resolved
2022-02-18 15:52 cbradney Resolution open => fixed
2022-02-18 15:52 cbradney Fixed in Version => 1.5.9.svn
2022-02-18 15:52 cbradney Note Added: 0049557