View Issue Details

IDProjectCategoryView StatusLast Update
0016811ScribusImport / Exportpublic2022-08-09 20:53
ReporterJLuc Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version22.04
Product Version1.5.8 
Fixed in Version1.5.9.svn 
Summary0016811: Some issues with PDF import
DescriptionImporting the attached PDF graph produces some inaccuracies :

- the 3 circles on the right are lightgrey instead of being lightblue as their left counterparts
- none of the circles or rectangle's shadows have been imported
- the imported images are "not displayed". I have to togle each image visibility with the right click menu.

EDIT : AMOF the shadows are here, but they are here as images instead of rectangles, and theyr are also "not displayed" as the other images.
Steps To ReproduceFile > Open > Choose PDF
TagsNo tags attached.
PatchNo

Activities

JLuc

2022-06-17 16:18

developer  

jghali

2022-06-17 17:56

administrator   ~0049702

Last edited: 2022-06-17 18:04

>> - none of the circles or rectangle's shadows have been imported
>> - the imported images are "not displayed". I have to togle each image visibility with the right click menu.

Unable to reproduce these two.

Small note: the AppImage uses older versions of scribus dependencies to maximize compatibility with distros. If you care about PDF import, you should really compile scribus yourself as this will allow scribus to use newer versions of its dependencies, especially poppler.

JLuc

2022-06-18 10:32

developer   ~0049707

(Maybe i misunderdstood but i thought it was complex to compile scribus now)
Is it not any more complex to compile scribus now as it was a few years ago ?

cbradney

2022-06-21 18:48

administrator   ~0049713

Scribus has never been that complex to compile. Its easier now I suppose.

jghali

2022-06-21 19:18

administrator   ~0049715

On Ubuntu 22.04, after enabling source code repositories, a few command lines are enough to retrieve dependencies and compile scribus 1.5.x branch:
sudo apt-get build-dep scribus
sudo apt-get install cmake subversion
mkdir scribus-1.5.x
cd scribus-1.5.x
svn co svn://scribus.net/branches/Version15x/Scribus
mkdir build
cd build
cmake ../Scribus -DCMAKE_INSTALL_PREFIX=../install -DWANT_SVNVERSION=1 -DWANT_CPP17=1
make install

jghali

2022-08-09 20:51

administrator   ~0049736

>> EDIT : AMOF the shadows are here, but they are here as images instead of rectangles

PDF specifications does not support anything such as blur effect on vector elements. So blurred shadows have to be exported by rendering them as images.

jghali

2022-08-09 20:53

administrator   ~0049737

Works for me on Ubuntu 22.04 as of r25120.

Issue History

Date Modified Username Field Change
2022-06-17 16:18 JLuc New Issue
2022-06-17 16:18 JLuc File Added: 2022 05 06 decision consentement HQ.pdf
2022-06-17 16:29 JLuc Description Updated
2022-06-17 17:56 jghali Note Added: 0049702
2022-06-17 18:04 jghali Note Edited: 0049702
2022-06-18 10:32 JLuc Note Added: 0049707
2022-06-21 18:48 cbradney Note Added: 0049713
2022-06-21 19:18 jghali Note Added: 0049715
2022-08-09 20:51 jghali Note Added: 0049736
2022-08-09 20:53 jghali Assigned To => jghali
2022-08-09 20:53 jghali Status new => resolved
2022-08-09 20:53 jghali Resolution open => fixed
2022-08-09 20:53 jghali Fixed in Version => 1.5.9.svn
2022-08-09 20:53 jghali Note Added: 0049737