View Issue Details

IDProjectCategoryView StatusLast Update
0016812ScribusTypographypublic2022-06-17 21:36
ReporterperroTuerto Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSArch Linux 
Product Version1.5.8 
Summary0016812: Broken links for hyphenation ES dic
DescriptionHi, I have been trying to download the hyphenation ES dic and from the console I get this error:

Failed: Error transferring https://cgit.freedesktop.org/libreoffice/dictionaries/plain/es/hyph_es_ANY.dic - server replied: Not found
Failed: Error transferring https://cgit.freedesktop.org/libreoffice/dictionaries/plain/es/README_hyph_es_ANY.txt - server replied: Not found
Failed: Error transferring https://cgit.freedesktop.org/libreoffice/dictionaries/plain/es/hyph_es_ANY.dic - server replied: Not found
Failed: Error transferring https://cgit.freedesktop.org/libreoffice/dictionaries/plain/es/README_hyph_es_ANY.txt - server replied: Not found

I digged in the domain and I found there is not such es_ANY.dic but es.dic

This is because the dic was renamed a while a go from es_ANY to es: https://github.com/sbosio/rla-es/commit/98eada1e7cf9f5a3394208747bb075a4f6db1c69

So I tried to do a little hack by manually downloading and renamed it. But the code is still es and not es_ES as Scribus would speck in order to work

Plus, it seems there is also an issue between es_ANY and es_ES. While the license in Scribus says its es_ANY, the expected dictionary is es_ES and the only available for hyphenation is es.
Steps To Reproduce1. Go to resources
2. Try to download es_ES hyphenation dic (only availabl for Spanish)
3. File not found
4. Download es.dic manually from libreoffice domain
5. Save the file where Scribus save other hyphenation dics
6. Rename file to es_ES.dic (code that Scribus expects)
7. Scribus recognize it as 'es' an not 'es_ES'.
Additional InformationFor me right now is good enough to know how Scribus can recognize the dictionary code as it expect. I thought it was only by rename it the file but it wasnt the case.
Tagsdictionary, hyphenation, spanish
PatchNo

Activities

perroTuerto

2022-06-17 19:04

reporter  

cbradney

2022-06-17 21:36

administrator   ~0049705

Uploaded new services file. Tested and fixed

Issue History

Date Modified Username Field Change
2022-06-17 19:04 perroTuerto New Issue
2022-06-17 19:04 perroTuerto Tag Attached: dictionary
2022-06-17 19:04 perroTuerto Tag Attached: hyphenation
2022-06-17 19:04 perroTuerto Tag Attached: spanish
2022-06-17 19:04 perroTuerto File Added: Captura de pantalla de 2022-06-17 14-03-43.png
2022-06-17 21:36 cbradney Assigned To => cbradney
2022-06-17 21:36 cbradney Status new => resolved
2022-06-17 21:36 cbradney Resolution open => fixed
2022-06-17 21:36 cbradney Note Added: 0049705