View Issue Details

IDProjectCategoryView StatusLast Update
0016835ScribusScripterpublic2022-08-21 08:07
ReporterJLuc Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS Version22.04
Product Version1.5.8 
Summary0016835: Bad filename and module in scripter error message
DescriptionExecuting [zinezine script](https://github.com/aoloe/scribus-script-repository/pull/38/files#diff-3a47d437de345a9bf0eb02708a223beb330cfd174fa2052c822116ee039df6e2) produces error message where filename and module string place holder appear instead of their actual value :

```
Traceback (most recent call last):
  File "<string>", line 11, in <module>
  File "<string>", line 8, in <module>
ModuleNotFoundError: No module named 'PyPDF2'
```

- notice the correct line number, but the "<string>" and "<module>" string instead of their values
- exact line numbers might vary because I added a comment line as a 4th line so as to source these scripts, but nevermind : this issue is about scribus, not about this script
Additional InformationOn scribus 1.5.8 appimage build on 22th january of 2022
TagsNo tags attached.
PatchNo

Activities

jghali

2022-08-19 21:43

administrator   ~0049746

This script uses a non-default Python module (PyPDF2), so you won't be able to execute that script with an AppImage unless the AppImage embeds that third-party module. To sum it up: if you need Python third-party modules, don't use AppImages.

JLuc

2022-08-20 21:21

developer   ~0049748

Last edited: 2022-08-20 21:22

The issue i meant to report is not about this script not running,
but about scribus error message displaying variable names
instead of displaying actual <file> name and <module> name
(which seems possible since line number is correctly displayed)

jghali

2022-08-20 21:55

administrator   ~0049749

>> scribus error message displaying variable names

This is not a scribus error message but a Python error message. So there is nothing we can change here. Also scribus cannot know if a script use a third party module or not. In such case it is up to the script to generate proper error message when an error occurs in a third party module.

ale

2022-08-21 08:07

manager   ~0049750

https://stackoverflow.com/questions/27193586/file-string-in-python-traceback

it seems to be related to the way scribus loads the script.

and, yes, there is probably not much that can be done here.

Issue History

Date Modified Username Field Change
2022-08-18 08:52 JLuc New Issue
2022-08-18 08:53 JLuc Additional Information Updated
2022-08-18 08:59 JLuc Description Updated
2022-08-19 21:43 jghali Assigned To => jghali
2022-08-19 21:43 jghali Status new => resolved
2022-08-19 21:43 jghali Resolution open => no change required
2022-08-19 21:43 jghali Note Added: 0049746
2022-08-19 21:44 jghali Status resolved => closed
2022-08-20 21:21 JLuc Status closed => feedback
2022-08-20 21:21 JLuc Resolution no change required => reopened
2022-08-20 21:21 JLuc Note Added: 0049748
2022-08-20 21:22 JLuc Note Edited: 0049748
2022-08-20 21:55 jghali Status feedback => resolved
2022-08-20 21:55 jghali Resolution reopened => no change required
2022-08-20 21:55 jghali Note Added: 0049749
2022-08-20 21:56 jghali Status resolved => closed
2022-08-21 08:07 ale Note Added: 0049750