View Issue Details

IDProjectCategoryView StatusLast Update
0016841ScribusUsabilitypublic2022-09-26 20:53
ReporterJon_J Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.8 
Fixed in Version1.5.9.svn 
Summary0016841: Scribus silently upgrades your file to the new format
DescriptionWhen you save a file in Scribus 1.5.8, it does not warn you that it is converting the file to a format that cannot be opened with 1.4.8. This was a problem for me because I bumped into some usability issues in the story editor (see bug 0016840) which required me to go back to 1.4.8 to resolve. Fortunately, my autosave file was still version 1.4.8, but this was dumb luck.

The ideal behavior would be for it to warn you, so you have a chance to save the last 1.4.8-compatible version before crossing the Rubicon into 1.5.8
TagsNo tags attached.
PatchNo

Activities

cbradney

2022-09-26 20:53

administrator   ~0049770

Thank you, fixed in 1.5.x and 1.7.x

Issue History

Date Modified Username Field Change
2022-09-12 13:52 Jon_J New Issue
2022-09-26 20:53 cbradney Assigned To => cbradney
2022-09-26 20:53 cbradney Status new => resolved
2022-09-26 20:53 cbradney Resolution open => fixed
2022-09-26 20:53 cbradney Fixed in Version => 1.5.9.svn
2022-09-26 20:53 cbradney Note Added: 0049770