View Issue Details

IDProjectCategoryView StatusLast Update
0016896ScribusScripterpublic2023-03-14 22:32
Reporterale Assigned To 
Status newResolutionopen 
Product Version1.7.0.svn 
Summary0016896: running a script, does not add it to the "Recent Scripts" list
Descriptionwhen i run a script, it does not get added to the "Script > Recent Scripts" list in the menu.
TagsNo tags attached.



2023-01-14 18:10

manager   ~0049920

after a restart of scribus, the script is in the list of recent scripts.


2023-01-14 18:20

administrator   ~0049921

Cannot reproduce here.


2023-01-14 19:57

manager   ~0049924

now it adds the script here, too.

i wonder if it only happens when the list of previous scripts is empty.

l've run the script many times before restarting scribus and the sub menu did remain empty.
the script did show up in the list after the restart , before running it again.


2023-01-16 10:16

manager   ~0049937

Last edited: 2023-01-16 11:09

i can confirm my supposition:

- i have deleted the scribus configs
- started scribus and the recent scripts list is (correctly) empty
- run a script
- the recent scripts list stays empty (here is the bug)
- restarted scribus
- the script i've run is now in the recent scripts list
- from this point on, the scripts get added to the the recent scripts list.


2023-03-05 16:17

administrator   ~0050012

I tried to reproduce this issue with a clean scribus config (ie no scribus config at all). Cannot reproduce it in 1.5.x or 1.7.x: scripts get added as expected to recent scripts list without any restart needed.


2023-03-05 17:34

administrator   ~0050013

Hmm.. I just tried it.. I ran the A4 3 column script from the source samples directory via the Execute script menu. It was immediately in the recent scripts menu.
I think I have seen this issue before but right now, I cannot reproduce.
What OS are you using Ale? Ubuntu? What version and how did you install Scribus? Direct from SVN or an app image etc?


2023-03-06 12:11

manager   ~0050015

hi, i just tested it and it still happens here with the latest code.

self compiled on debian testing.


2023-03-06 21:30

administrator   ~0050016

I did a test in Ubuntu 22.10 with current trunk code: no issue here.


2023-03-06 21:43

administrator   ~0050017

What version of Qt, Ale? Maybe thats the source and why Jean and I can no longer see the issue


2023-03-06 21:45

administrator   ~0050018

No issue in Manjaro either.


2023-03-07 08:35

manager   ~0050021

qt 6.4.2-1


2023-03-07 19:45

administrator   ~0050022

Manjaro has Qt 6.4.2 too but no issue there.


2023-03-09 22:14

administrator   ~0050024

I can reproduce this on Ubuntu with Qt 6.3.1 and current 1.7.0.svn.


2023-03-14 21:10

administrator   ~0050030

Tried again with Qt 6.4.2 on the same ubuntu with the exact same code, same issue. Updated to current svn, same issue.
Checked with Current SVN on Mac OS with Qt 6.4.2, works fine.
I'm guessing its a platform issue.


2023-03-14 22:32

administrator   ~0050031

Fine on Tumbleweed too

Issue History

Date Modified Username Field Change
2023-01-14 17:58 ale New Issue
2023-01-14 18:10 ale Note Added: 0049920
2023-01-14 18:20 jghali Note Added: 0049921
2023-01-14 19:57 ale Note Added: 0049924
2023-01-16 10:16 ale Note Added: 0049937
2023-01-16 11:09 ale Note Edited: 0049937
2023-03-05 16:17 jghali Note Added: 0050012
2023-03-05 17:34 cbradney Note Added: 0050013
2023-03-06 12:11 ale Note Added: 0050015
2023-03-06 21:30 jghali Note Added: 0050016
2023-03-06 21:43 cbradney Note Added: 0050017
2023-03-06 21:45 jghali Note Added: 0050018
2023-03-07 08:35 ale Note Added: 0050021
2023-03-07 19:45 jghali Note Added: 0050022
2023-03-09 22:14 cbradney Note Added: 0050024
2023-03-14 21:10 cbradney Note Added: 0050030
2023-03-14 22:32 cbradney Note Added: 0050031