View Issue Details

IDProjectCategoryView StatusLast Update
0001921ScribusScripterpublic2005-09-07 21:26
Reportertedroche Assigned Toringerc 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformApple iMac 1.25 GHz G4, 768 MbOSOS XOS Version10.3.9
Product Version1.2.1 
Target VersionFixed in Version 
Summary0001921: Script | Scribus Script | Font Sample fails on default Mac install: missing TKinter
DescriptionInstalled via fink along with msttfonts, x-ghostscriptfonts, apple systemfonts folowing:

http://docs.scribus.net/index.php?lang=en&sm=crossplatform&page=machints1

Started Apple's X11, added Scribus to the Applications menu, started.

Traceback (most recent call last):
  File "<string>", line 4, in ?
  File "/sw/share/scribus/scripts/FontSample.py", line 40, in ?
    from Tkinter import *
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/lib-tk/Tkinter.py", line 38, in ?
    import _tkinter # If this fails your Python may not be configured for Tk
ImportError: No module named _tkinter
Steps To ReproduceStart Scribus
From the menus select: Script, Scribus Script, Font Sample
TagsNo tags attached.
Patch

Activities

ringerc

2005-04-26 14:15

reporter   ~0004423

My (probably rather poor) understanding is that TKinter on MacOS/X is a bit ... er ... interesting, due to the way MacOS/X has (at least) two different GUI layers. The X11 port of Scribus will probably need to use a version of Tkinter from fink that also works with X11, and a version of Python from fink that's compiled to use the X11 version of Tkinter.

It looks like Scribus is trying to use the system Python shipped by Apple, which if I recall correctly lacks Tkinter support entirely - tkinter has to be added on, and works with Aqua not X11.

I realise that's complex and probably doesn't really help you. I'll see if I can look at what's going on, but I'm somewhat lacking in time right now. I'll CC Martin Costabel, the Fink Scribus maintainer, in case he has any comments on this.

ringerc

2005-04-26 14:21

reporter   ~0004425

Reminder sent to: costabel

Hi Martin

This bug look familiar to you? Just need to install the fink python and tkinter dev packages then rebuild, or is there more to it?

Comments appreciated... I don't currently have access to a box to look at this and won't for a few weeks.

ringerc

2005-07-05 14:41

reporter   ~0005396

Reminder sent to: avox

Any ideas?

avox

2005-07-05 15:50

administrator   ~0005399

Last edited: 2005-07-05 16:03

Installation of tkinter tested on Panther:

Install TclTkAqua (not standalone) 8.4 (http://tcltkaqua.sourceforge.net/)

Install MacPython 2.3 addons for Panther (http://homepages.cwi.nl/~jack/macpython/download.html)

Run /Applications/MacPython2.3/PackageManager:
Ignore the error message
Select File->Open URL, enter:
         http://www.python.org/packman/version-0.3/darwin-7.0.0-Power_Macintosh.plist
(see also http://www.python.org/packman/)
Install tkinter

Now fontsample.py should run in Scribus/Aqua. Someone else want to test with Scribus/X11?

Andreas

ringerc

2005-07-10 02:41

reporter   ~0005479

Since it seems to work fine when Tkinter is installed (and sounds like you might not even need to do that on 10.4 with some of the Python builds the OS uses), I'm resolving this. It's really an issue with the Python install, not Scribus, anyway.

Issue History

Date Modified Username Field Change
2005-04-26 13:51 tedroche New Issue
2005-04-26 14:04 ringerc Status new => assigned
2005-04-26 14:04 ringerc Assigned To => ringerc
2005-04-26 14:15 ringerc Note Added: 0004423
2005-04-26 14:21 ringerc Note Added: 0004425
2005-07-05 14:41 ringerc Note Added: 0005396
2005-07-05 15:50 avox Note Added: 0005399
2005-07-05 16:01 avox Note Edited: 0005399
2005-07-05 16:03 avox Note Edited: 0005399
2005-07-10 02:41 ringerc Status assigned => resolved
2005-07-10 02:41 ringerc Resolution open => no change required
2005-07-10 02:41 ringerc Note Added: 0005479
2005-09-07 21:26 cbradney Status resolved => closed