View Issue Details

IDProjectCategoryView StatusLast Update
0002052ScribusImport / Exportpublic2005-07-06 19:36
ReporterAReichel Assigned Toplinnell 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Platformx86OSgentoo linuxOS Version2005.2
Product Version1.2.2cvs 
Target VersionFixed in Version 
Summary0002052: SVG break colors and characters in PDF
DescriptionThe colors and the characters of a PDF are broken, when the scribus file contains imported SVG-files. Although the printouts are fine (both color and characters), the files look strange, when opened with acrobat reader 7.0 in linux. Color management does'nt help! I've activated adobes icc-profiles. Without colormanagement it looks even more strange!

i've attached testfiles to reproduce the testcase.
Steps To Reproduce1) Create a new document.
2) Insert a seagreen filled rectangle.
3) Insert some text.
4) Export as PDF for printer with colormanagement (gives test_without_svg.pdf).
5) Insert a SVG graphic now.
6) Export as PDF for printer with colormanagement (gives test_with_svg.pdf).
7) Open both PDF files with acrobat 7.0 in linux tiled horizontally.
8) Compare the color of the rectangle --> for test_with_svg.pdf the seagreen now looks like neon poisson green, bit for test_without_svg.pdf everything looks great.
9) Compare the characters --> for test_with_svg.pdf the characers don't look sharp, but aliased while the characters in test_without_svg.pdf look great again.
TagsNo tags attached.
Patch

Relationships

related to 0002931 acknowledged Metabug: SVG 

Activities

2005-06-05 05:51

 

test_without_svg.sla (38,526 bytes)

2005-06-05 05:53

 

test_with_svg.sla (113,741 bytes)

2005-06-05 05:53

 

gnome-fs-executable.svg (15,784 bytes)

2005-06-05 05:54

 

test_without_svg.pdf (7,828 bytes)

2005-06-05 05:54

 

test_with_svg.pdf (15,832 bytes)

plinnell

2005-06-05 09:10

viewer   ~0004897

Last edited: 2005-06-05 09:12

This a bug in Reader 7 on Linux, which we know about and have reported.

Tested with acroread 5.0.10, acro 7 on windows an d acro reader 5.1 on wine. These display correctly.

The issue is when a PDF has transparency, it makes certain colors display wrong.

plinnell

2005-06-05 09:10

viewer   ~0004898

Thanks for the good test case. It does help.

AReichel

2005-06-08 06:55

reporter   ~0004958

Last edited: 2005-06-08 07:00

I've tested my files on windows also now, and althouhg it looks slightly better, the testfile with the svg looks still wrongly. Especially the seagreen looks much darker. But the characters are looking aliased too (i've examples, where in it's mutch worse, but a can't publish these slides).

Tested with Acrobat 6.0 on Windows XP.

Are you sure, it is only Acrobats problem really? Why the characters are borked then?

plinnell

2005-07-06 11:14

viewer   ~0005404

Itested this again and with Acro 5 and 6 as well as opening it in Photoshop.

1) I do not see text issues anywhere.

2) The shades of green export perfectly from what i can tell here with mulitple viewers.

3) The flourescent green in Acro 7 is no question an Acro bug, which I posted recently about.

Thanks again for a clear test case thought.

Issue History

Date Modified Username Field Change
2005-06-05 05:51 AReichel New Issue
2005-06-05 05:51 AReichel File Added: test_without_svg.sla
2005-06-05 05:53 AReichel File Added: test_with_svg.sla
2005-06-05 05:53 AReichel File Added: gnome-fs-executable.svg
2005-06-05 05:54 AReichel File Added: test_without_svg.pdf
2005-06-05 05:54 AReichel File Added: test_with_svg.pdf
2005-06-05 09:10 plinnell Note Added: 0004897
2005-06-05 09:10 plinnell Status new => resolved
2005-06-05 09:10 plinnell Resolution open => no change required
2005-06-05 09:10 plinnell Note Added: 0004898
2005-06-05 09:12 plinnell Note Edited: 0004897
2005-06-05 20:18 plinnell Status resolved => closed
2005-06-08 06:55 AReichel Status closed => feedback
2005-06-08 06:55 AReichel Resolution no change required => reopened
2005-06-08 06:55 AReichel Note Added: 0004958
2005-06-08 07:00 AReichel Note Edited: 0004958
2005-07-06 11:14 plinnell Note Added: 0005404
2005-07-06 11:14 plinnell Status feedback => resolved
2005-07-06 11:14 plinnell Resolution reopened => no change required
2005-07-06 14:52 ringerc Status resolved => assigned
2005-07-06 14:52 ringerc Assigned To => plinnell
2005-07-06 14:53 ringerc Status assigned => resolved
2005-07-06 19:36 plinnell Status resolved => closed
2006-05-17 19:21 christoph_s Relationship added related to 0002931