View Issue Details

IDProjectCategoryView StatusLast Update
0002076ScribusStory Editor / Text Framespublic2005-06-24 18:42
Reportermalex Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSLinuxOS Version2.6
Product Version1.2.2cvs 
Target VersionFixed in Version1.3.0cvs 
Summary0002076: Hard (non-breaking) space does not work after a dash "-".
DescriptionPlease take a look at the original bug report in Debian BTS at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=297164.

In short a short dash "-" breaks the functioning of the non-breaking space introduced by "ctrl+space".
Steps To ReproduceCreate a text frame.
Type in several words spaced with a non-breaking space. Put in a couple of dashes - one after a word and another as a separate word.
Open the properties palette.
Slowly decrease the text frame width and watch how the words get broken up and moved into the next line character by character until a word located after a hard space located after a dash is encountered. That entire word is moved to the next line instead of being moved character by character.
Yell "bug!".
Done.
TagsNo tags attached.
Patch

Relationships

related to 0003828 acknowledged Metabug: Hyphenation 

Activities

fschmid

2005-06-08 19:04

administrator   ~0004977

Hmm, very difficult, as the dash "-" is recognized as a place where a hyphenation is possible. So if you write (_ replaces the hard space) "Test-_case" the textrender thinks you want to hyphenate after the word Test. A possible fix would be to introduce a "Do not hyphenate" flag for the character. Not sure how to implement this yet.

malex

2005-06-08 19:26

administrator   ~0004979

Franz,

I might be really off here, but I thought that the whole idea of a non-breaking (hard) space was to say "Don't hyphenate here!". People don't usually introduce non-breaking spaces after a hyphen unless the want it not breaking. What problems do you think it would create if you introduced a conditional check into your line breaking code that would use a non-breaking space as a flag to override hyphenation?

cbradney

2005-06-08 19:29

administrator   ~0004980

This is really starting to push the boundaries of the current file format and starting to require the new one and new renderer code.

malex

2005-06-08 19:36

administrator   ~0004981

I don't think hard spaces have anything to do with the file format. The change would have to be in the text frame rendering code, nowhere else as I see it.

fschmid

2005-06-08 19:38

administrator   ~0004982

Its difficult because typing "-" Dash and then a non-breaking space is a bit crazy as they introduce contrary commands. Q** handles this situation by placing a smart hyphen before the word you want not to be hyphenated. Quite crude solution in my thinking.

cbradney

2005-06-08 19:47

administrator   ~0004983

I think the format should use ߫ which is a hyphenation point char for formatting only, and then the hyphenator puts in the correct char if it needs on.. which would be &#00AD; I think.

fschmid

2005-06-09 19:24

administrator   ~0004992

Fixed by implementing a Non-breakable Dash.

Issue History

Date Modified Username Field Change
2005-06-08 15:48 malex New Issue
2005-06-08 19:04 fschmid Note Added: 0004977
2005-06-08 19:26 malex Note Added: 0004979
2005-06-08 19:29 cbradney Note Added: 0004980
2005-06-08 19:36 malex Note Added: 0004981
2005-06-08 19:38 fschmid Note Added: 0004982
2005-06-08 19:47 cbradney Note Added: 0004983
2005-06-09 19:24 fschmid Status assigned => resolved
2005-06-09 19:24 fschmid Fixed in Version => 1.3.0cvs
2005-06-09 19:24 fschmid Resolution open => fixed
2005-06-09 19:24 fschmid Note Added: 0004992
2005-06-24 18:42 cbradney Status resolved => closed
2006-05-16 22:11 christoph_s Relationship added related to 0003828
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames