View Issue Details

IDProjectCategoryView StatusLast Update
0002322ScribusInternalpublic2005-09-22 22:56
ReporterringercAssigned Tofschmid  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Platformx86 LinuxOSFedora CoreOS Version3
Product Version 
Target VersionFixed in Version1.3.1cvs 
Summary0002322: Rename CMYKColor to ScColor
DescriptionThe attached patch renames CMYKColor to ScColor, to reduce confusion. Objections?

It also converts files over to use sccolor.h . That currently just pulls in cmykcolor.h but when we can move files around properly cmykcolor.{h,cpp} should be renamed to sccolor.{h,cpp}.
Additional Information

Once this is done I think we need to make colors in prefs clearer. I'd like to move them over to the new prefs API and do away with the

<COLOR RGB='xxxx' CMYK='xxxx' NAME='xxxx'>

stuff in favour of storing:
   - Color name
   - name/number to use in spot colour in ps/pdf (if blank, defaults to color name)
   - colour co-ordinate scheme <= {CMYK, RGB, RGBA, CMY, hexachrome, L*A*B, ... }
   - colour co-ordinates as a scheme-specific string.

so we might have something like (pseudo-code; would actually be prefs-api XML):

<color>
   <name>Cyan</name>
   <spotname>CYAN001</spotname>
   <scheme>CMYK</scheme>
   <coords>0xFF000000</coords>
</color>

We might also want to store a profile indicating what colour space the colour is defined in relation to? I'm not sure. Do we currently assume doc RGB colours are in the monitor colourspace? In sRGB? What? What about the case where we don't support colour management?

CMYK is even harder, since we don't even have any standard profile like sRGB that we can treat colours as being in.

[I'll move this to the wiki later]
TagsNo tags attached.
Patch

Relationships

related to 0002167 closedfschmid Spot colours 

Activities

2005-07-28 16:59

 

sccolor.diff.gz (7,830 bytes)

2005-07-28 16:59

 

sccolor.h (1,308 bytes)

jghali

2005-07-28 17:36

administrator   ~0005769

>>We might also want to store a profile indicating what colour space the colour is defined in relation to? I'm not sure.

If color profile is known, L*A*B* is also known, so storing concurrently L*A*B* value is maybe more interesting.. Thoughts?

fschmid

2005-07-28 19:11

administrator   ~0005771

Adjusted the Makefile.am too and copied the cmykcolor.cpp/.h files to sccolor.cpp/.h to avoid confusion having both versions. I don't like include files that just include another file.

cbradney

2005-07-28 19:41

administrator   ~0005772

The problem is we have now lost these files history. We should be using the workarounds and migrating to SVN ASAP and then renaming and moving files around.

fschmid

2005-07-28 21:42

administrator   ~0005773

These files should have gone into the Attic directory of the CVS-Repository, cervisia doesn't show this dir, but the history of the files should be kept there.

cbradney

2005-07-28 21:54

administrator   ~0005774

Yes, but renaming in SVN would keep all the history together with the file, even after renaming, or moving to a new dir even.

Issue History

Date Modified Username Field Change
2005-07-28 16:59 ringerc New Issue
2005-07-28 16:59 ringerc File Added: sccolor.diff.gz
2005-07-28 16:59 ringerc File Added: sccolor.h
2005-07-28 17:36 jghali Note Added: 0005769
2005-07-28 19:11 fschmid Status new => resolved
2005-07-28 19:11 fschmid Fixed in Version => 1.3.1cvs
2005-07-28 19:11 fschmid Resolution open => fixed
2005-07-28 19:11 fschmid Assigned To => fschmid
2005-07-28 19:11 fschmid Note Added: 0005771
2005-07-28 19:41 cbradney Note Added: 0005772
2005-07-28 21:42 fschmid Note Added: 0005773
2005-07-28 21:54 cbradney Note Added: 0005774
2005-09-17 07:30 ringerc Relationship added related to 0002167
2005-09-22 22:56 cbradney Status resolved => closed