View Issue Details

IDProjectCategoryView StatusLast Update
0002392ScribusImport / Exportpublic2014-07-27 18:36
Reportermalcolm Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformIntelOSFedora CoreOS Version4
Product Version1.3 
Target VersionFixed in Version 
Summary0002392: Import SVG messes up position of text frame and loses font style
DescriptionText frames within SVG documents are located in the wrong position.

The also lose the style information that was applied to them.
Steps To Reproduceimport an SVG that contains paths and text frames using File->Import->Import SVG
Additional InformationI've posted a description of the problem at <http://www.notyourhomework.net/inkscape.html>. That document describes the problem and has links to the SVG graphic and a Scribus document which contains the imported graphic.
TagsNo tags attached.
Patch

Relationships

child of 0002931 acknowledged Metabug: SVG 

Activities

plinnell

2005-09-04 21:24

viewer   ~0006404

bumping to post 1.2.3 pile

plinnell

2005-11-11 21:32

viewer   ~0007403

Text import via SVG is not recommended in 1.2.x and we will re-write the SVG importer in 1.3.x. The re-write needs features in the 1.3.x drawing we cannot backport.

jghali

2006-10-19 21:39

administrator   ~0013032

Have just committed patch in 1.3.3.5cvs so that SVG text elements imports better

Kunda

2014-07-23 23:59

manager   ~0032938

Cannot test graphics due to URL resolving as 404. jghali in 0002392:0013032 says that a patch was committed. Resolving for now. When this issue is patrolled to be closed one can ascertain if to re-open or close.

Issue History

Date Modified Username Field Change
2005-08-05 03:38 malcolm New Issue
2005-09-04 21:24 plinnell Note Added: 0006404
2005-09-04 21:24 plinnell Status new => acknowledged
2005-09-04 21:24 plinnell Product Version 1.2.2.1cvs => 1.2.4cvs
2005-11-11 21:32 plinnell Note Added: 0007403
2005-11-11 21:32 plinnell Product Version 1.2.4cvs => 1.3
2006-01-30 12:19 lace Note Added: 0008494
2006-01-30 13:12 plinnell Relationship added child of 0002391
2006-01-30 13:12 plinnell Relationship deleted child of 0002391
2006-01-30 13:14 plinnell Relationship added child of 0002931
2006-10-19 21:39 jghali Note Added: 0013032
2014-07-23 23:59 Kunda Note Added: 0032938
2014-07-23 23:59 Kunda Status acknowledged => resolved
2014-07-23 23:59 Kunda Resolution open => unable to reproduce
2014-07-23 23:59 Kunda Assigned To => jghali
2014-07-27 18:36 cbradney Status resolved => closed