View Issue Details

IDProjectCategoryView StatusLast Update
0002406ScribusUser Interfacepublic2005-09-10 10:04
Reporterdrekka Assigned Tocbradney  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSGentooOS Version2004.3
Product Version1.3.0 
Fixed in Version1.3.1cvs 
Summary0002406: Deleting Layer #1 causes Signal 11 crash
DescriptionI have a document with multiple layers and an currently attempting to determine why it is signal 6 crashing when I export to PDF. As part of this I decided to see what the effect would be of having just a single layer with the offending PNG on it. This layer is layer 0.

I clicked layer 1 and the delete button. Scribus asked me if I wanted to delete all object and I said yes. It then crahsed qith a Signal 11 segmentation fault. It does this every time in this document.

Prior to this I had started by deleting layer 3 - which worked fine, layer 2 w- which also worked fine. When I got to layer 1, it promoted me as for layer's 2 & 3, but did not delete it no matter how many times I attempted to do so.

I created a new document and had no problems with any of this.
TagsNo tags attached.
Patch

Relationships

related to 0002365 closedcbradney Crash when you delete a Layer 
child of 0003838 acknowledged Metabug: Scribus layers 

Activities

ringerc

2005-08-09 15:28

reporter   ~0005977

drekka, please attach the document. Without it for testing, or other instructions to reproduce the problem, nothing can be done.

Craig, I lobbed this your way on the theory you're the one doing most of the work with that code, even though this is 1.3.0 not 1.3.1cvs .

2005-08-10 13:18

 

Calendar.sla (186,958 bytes)

drekka

2005-08-10 13:20

reporter   ~0006024

Should I grab 1.3.1cvs and try that ? I've attached the document. Hope this helps. I tried to reproduce it in a sample document, but it appeared to work fine.

drekka

2005-08-21 12:21

reporter   ~0006175

I just tried to delete layer 2 "Sponsors and logos" form the document. I cleared all objects from it and then attempted to delete that layer. It completely ignored the delete request. I closed and re-opened scribus and tried again. Same result. Layer 2 refuised to be deleted.

plinnell

2005-08-22 09:46

viewer   ~0006194

1) Yes, please try current CVS some re-writes were done to the layer code.

2) I noticed in the export PDF dialog you are re-sampling to 600 dpi. Don't do that unless you have heaps of memory and swap with this large a document. This is an area which needs improvement we know, but that was function was mean more for downsampling images for web pdfs.

3. I suspect this doc might be corrupted from your crashes, but cannot confirm - yet. I would try and copy the more complicated bits from the doc into a scrapbook and then re-create a new doc with current CVS.

plinnell

2005-09-07 20:24

viewer   ~0006459

ping ?

cbradney

2005-09-09 21:43

administrator   ~0006497

1.3.1cvs does not crash when deleting any layer here. Maybe my layer rewrite fixed the issue.

plinnell

2005-09-10 10:04

viewer   ~0006501

no crashes with new or existing docs here

Issue History

Date Modified Username Field Change
2005-08-09 14:53 drekka New Issue
2005-08-09 15:24 ringerc Status new => assigned
2005-08-09 15:24 ringerc Assigned To => cbradney
2005-08-09 15:28 ringerc Note Added: 0005977
2005-08-10 13:18 drekka File Added: Calendar.sla
2005-08-10 13:20 drekka Note Added: 0006024
2005-08-21 12:21 drekka Note Added: 0006175
2005-08-22 09:25 plinnell Relationship added related to 0002365
2005-08-22 09:46 plinnell Note Added: 0006194
2005-09-07 20:24 plinnell Note Added: 0006459
2005-09-09 21:43 cbradney Status assigned => resolved
2005-09-09 21:43 cbradney Fixed in Version => 1.3.1cvs
2005-09-09 21:43 cbradney Resolution open => fixed
2005-09-09 21:43 cbradney Note Added: 0006497
2005-09-10 10:04 plinnell Status resolved => closed
2005-09-10 10:04 plinnell Note Added: 0006501
2006-05-18 23:05 christoph_s Relationship added child of 0003838