View Issue Details

IDProjectCategoryView StatusLast Update
0002526ScribusImport / Exportpublic2005-11-29 17:44
Reporteravox Assigned Toavox  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacintoshOSOSXOS Version10.3.8
Product Version1.3.1cvs 
Target VersionFixed in Version1.3.2cvs 
Summary0002526: SVG import fails if document is open
DescriptionSVG import fails silently.
avox remembers seeing this behaviour for PS import, also.
Steps To ReproduceOpen document in Scribus/Aqua
Import SVG
->
Nothing shows up.

Same SVG imports if no doc is open
Additional Information<bolsh> avox: I have this funky thing when I import an SVG - it doesn't appear on the page
[14:45] <bolsh> But sometimes I get glimses of the bounding box.
[14:46] <avox> All SVG or just a certain one?
[14:46] <bolsh> All
[14:46] <bolsh> It happens when there's an existing document.
[14:46] <avox> Which version? Scribus/Aqua or fink?
[14:46] <bolsh> Aqua
[14:47] <avox> Work if no doc is open?
[14:47] <bolsh> And it also sets the page size for the current document to the size of the SVG
[14:48] <bolsh> The document I see is A4, but the next time I open File->Document Setup, the page shrinks to the size of the SVG
[14:48] <bolsh> Yeah, Works fine with no doc
[14:48] <bolsh> And sometimes with a doc open too
[14:52] <avox> Can you work around that by importing with no doc and then copy/paste it to the doc you want?
[14:53] <avox> I'm afraid I don't have time to fix that bug right away
[14:58] <bolsh> That's what I'm doing
[14:58] <bolsh> I also have other problems... general stability issues
[14:59] <bolsh> I've had trouble getting anything actually done - I've spent all morning just working on templates, when it's the content that's important :)
[14:59] <avox> Well, it's still alpha I'm afraid
[14:59] <bolsh> As we speak, I just got a Sig11
TagsNo tags attached.
Patch

Relationships

related to 0002196 closedavox PS import doesn't work if doc open 
child of 0002015 closedavox This issue lists all known regressions of the Aqua port compared with the 13 Linux version 
child of 0002867 closedavox Drag doesn't work on Scribus/Aqua 
child of 0002931 acknowledged Metabug: SVG 

Activities

fschmid

2005-09-09 19:07

administrator   ~0006490

No issue under Linux here.

jwatte

2005-09-17 21:18

reporter   ~0006633

Could this be a user error, caused by unclear documentation? You have to first do the Import, and then place the SVG on the actual page -- and the Place cursor will only show up on the currently active page (last clicked page).

avox

2005-11-29 17:43

administrator   ~0007577

pending better solution, see 0002867

Issue History

Date Modified Username Field Change
2005-09-03 17:20 avox New Issue
2005-09-09 19:06 fschmid Status new => assigned
2005-09-09 19:06 fschmid Assigned To => avox
2005-09-09 19:07 fschmid Note Added: 0006490
2005-09-17 21:18 jwatte Note Added: 0006633
2005-10-01 10:40 avox Relationship added related to 0002196
2005-10-01 10:41 avox Relationship added child of 0002015
2005-11-26 11:47 avox Relationship added child of 0002867
2005-11-29 17:43 avox Status assigned => resolved
2005-11-29 17:43 avox Fixed in Version => 1.3.2cvs
2005-11-29 17:43 avox Resolution open => fixed
2005-11-29 17:43 avox Note Added: 0007577
2005-11-29 17:43 avox Status resolved => closed
2006-05-17 19:11 christoph_s Relationship added child of 0002931