View Issue Details

IDProjectCategoryView StatusLast Update
0002565ScribusImport / Exportpublic2005-09-23 15:07
ReporterplinnellAssigned Tofschmid  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.3 
Fixed in Version1.2.4cvs 
Summary0002565: Content in page templates causes PDF exported which has grave errors in Acrobat 5 and 7
DescriptionSee the attached file and export a PDF from 1.2.3 or 1.2.4cvs.

Copying the content from the page templates into another doc will also trigger problem PDF. I spent a bit of time testing and eliminated the images as an issue.

Exporting to EPS results in broken EPS which Photoshop cannot part and results in a blank display in GSview.

Print Preview also shows no content.

TagsNo tags attached.
Patch

Relationships

related to 0002561 closedfschmid Crash when trying to Print Preview Font Sampler Output 
related to 0003837 acknowledged Metabug: Master pages/Page templates 

Activities

2005-09-15 17:46

 

Manual.tar.gz (40,889 bytes)

cbradney

2005-09-15 18:32

administrator   ~0006577

Removing the ()s from the page template names (via a text editor or duplicating the templaes) seems to make it work ok here.

plinnell

2005-09-15 18:35

viewer   ~0006578

Last edited: 2005-09-15 18:45

Some digging finds the issue is caused by the use of ( ) in the names of page templates. Removing them solves the issue.

avox

2005-09-15 19:01

administrator   ~0006580

The attached PS snippet causes the error. The string "/02-Directio\(lzq\)6" should be a valid PS command name but isn't.

/02-Directorio\(Izq\)6
{
gs
1 sw
0 setlinecap
0 setlinejoin
[] 0 setdash
0.00283465 763.654 tr
0 0 m
0 0 184.252 0 184.252 0 curveto
...
gr
} bind def

saaib

2005-09-15 19:58

reporter   ~0006581

OK, removing () for this particular problem fixed it.

Is there a subset of valid template name chars ? should we use the valid expected values used on PS ?

avox

2005-09-15 20:00

administrator   ~0006582

I think PSLib::PSEncode should be rewritten.

From PS Refman:

Any token that consists entirely of regular characters and cannot be interpreted as
a number is treated as a name object (more precisely, an executable name). All
characters except delimiters and white-space characters can appear in names, including
characters ordinarily considered to be punctuation.
The following are examples of valid names:
abc Offset $$ 23A 13-456 a.b $MyDict @pattern
Use care when choosing names that begin with digits. For example, while 23A is a
valid name, 23E1 is a real number, and 23#1 is a radix number token that represents
an integer.

AND

The characters (, ), <, >, [, ], {, }, /, and % are special. They delimit syntactic entities
such as strings, procedure bodies, name literals, and comments. Any of these
characters terminates the entity preceding it and is not included in the entity.
All characters besides the white-space characters and delimiters are referred to as
regular characters. These include nonprinting characters that are outside the recommended
PostScript ASCII character set.

Issue History

Date Modified Username Field Change
2005-09-15 17:46 plinnell New Issue
2005-09-15 17:46 plinnell File Added: Manual.tar.gz
2005-09-15 18:32 cbradney Note Added: 0006577
2005-09-15 18:35 plinnell Note Added: 0006578
2005-09-15 18:44 plinnell Relationship added related to 0002561
2005-09-15 18:45 plinnell Note Edited: 0006578
2005-09-15 19:01 avox Note Added: 0006580
2005-09-15 19:58 saaib Note Added: 0006581
2005-09-15 20:00 avox Note Added: 0006582
2005-09-15 21:41 fschmid Status new => resolved
2005-09-15 21:41 fschmid Fixed in Version => 1.2.4cvs
2005-09-15 21:41 fschmid Resolution open => fixed
2005-09-15 21:41 fschmid Assigned To => fschmid
2005-09-23 15:07 cbradney Status resolved => closed
2006-05-18 19:03 christoph_s Relationship added related to 0003837