View Issue Details

IDProjectCategoryView StatusLast Update
0002708ScribusGeneralpublic2012-06-23 15:07
ReporterDavid Goodenough Assigned Tocezaryece  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.3cvs 
Target VersionFixed in Version1.5.0svn 
Summary0002708: Autosizing of frames
DescriptionHaving set the border size of a frame it would be useful to have a script or
function key which reduced the vertical height of the frame so that it exactly fitted the content. Otherwise you can be left with frames with uneven borders.
 
I guess a horizontal equivalent would also be useful.
TagsNo tags attached.
Patch

Relationships

related to 0001405 acknowledged Support frame fit adjustment for text 
related to 0001406 confirmed Add text metrics to scripter 
related to 0002058 assignedavox Text and font metrics 
related to 0010772 assignedcezaryece "Adjust frame height to text" should also grow the frame if it the text is overflowing 

Activities

ringerc

2005-10-11 13:30

reporter   ~0007040

I think this is much the same as 0001405; resolving as a duplicate.

David Goodenough

2005-10-11 15:41

reporter   ~0007044

No, this is not a duplicate.

What I want to be able to do is to put some text in a box, set its width, and then automatically set its height to be exactly right so that the bottom margin is only that margin, not something greater than or equal to the bottom margin.

Think if this as a column in a newspaper. It I put each story into its own frame I want to pack the text and frames as tightly as possible - well I may spread it later, but this way I know how much I can fit in. If the stories were simply paragraphs then it would happen automatically, but not for separate frames. I can do this manually by entering the text and then sizing down the frames until it overflows, but I want an automated mechanism. It could be a script, but then needs hooks to find the required size (I think bounding box is the term) of the text, and then the borders and then calculating the proper frame size.

Sorry if I did not explain this properly at first.

cbradney

2005-10-11 15:55

administrator   ~0007046

Making the bottom fit is not possible right now as the frame demands the extra space for the full height of the descenders in the font, rather than those used.

David Goodenough

2005-10-11 16:09

reporter   ~0007048

Thats fine, I am happy for it to fit to the lowest descender in the font rather than the lowest descender used in the last line.

pygmee

2012-06-21 09:28

developer   ~0028242

i guess there is already a python script that does it.

Issue History

Date Modified Username Field Change
2005-10-11 10:39 David Goodenough New Issue
2005-10-11 13:30 ringerc Relationship added duplicate of 0001405
2005-10-11 13:30 ringerc Duplicate ID 0 => 1405
2005-10-11 13:30 ringerc Status new => resolved
2005-10-11 13:30 ringerc Resolution open => duplicate
2005-10-11 13:30 ringerc Assigned To => ringerc
2005-10-11 13:30 ringerc Note Added: 0007040
2005-10-11 15:26 cbradney Status resolved => closed
2005-10-11 15:41 David Goodenough Status closed => feedback
2005-10-11 15:41 David Goodenough Resolution duplicate => reopened
2005-10-11 15:41 David Goodenough Note Added: 0007044
2005-10-11 15:55 cbradney Note Added: 0007046
2005-10-11 16:09 David Goodenough Note Added: 0007048
2005-10-11 16:32 ringerc Relationship added related to 0001406
2005-10-11 16:33 ringerc Relationship added related to 0002058
2005-10-11 16:33 ringerc Relationship replaced related to 0001405
2005-10-11 16:33 ringerc Status feedback => acknowledged
2005-10-11 16:33 ringerc Resolution reopened => open
2005-10-11 16:33 ringerc Product Version 1.2.1 => 1.3.2cvs
2005-10-11 16:34 ringerc Assigned To ringerc =>
2006-02-06 18:06 jo-hannes Product Version 1.3.2cvs => 1.3.3cvs
2007-05-16 01:56 christoph_s Status acknowledged => assigned
2007-05-16 01:56 christoph_s Assigned To => avox
2012-06-20 19:54 ale Relationship added related to 0010772
2012-06-20 19:58 ale Status assigned => resolved
2012-06-20 19:58 ale Fixed in Version => 1.5.0svn
2012-06-20 19:58 ale Resolution open => fixed
2012-06-20 19:58 ale Assigned To avox => cezaryece
2012-06-21 09:28 pygmee Note Added: 0028242
2012-06-23 15:07 cbradney Status resolved => closed