View Issue Details

IDProjectCategoryView StatusLast Update
0002821ScribusStory Editor / Text Framespublic2012-01-15 20:50
Reporterjo-hannes Assigned Tocbradney  
PrioritylowSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.2cvs 
Target VersionFixed in Version1.4.0svn 
Summary0002821: Text color not updated if changed for the first letter in a text frame
Descriptionif you change the color of the first letter in SE, close and open again, text color says black although you changed it.
solution: move cursor or activate another window and click back, so its an refresh issue.
TagsNo tags attached.
Patch

Relationships

related to 0003157 acknowledged Metabug: Cursor placement fixes 

Activities

jo-hannes

2005-12-10 01:00

developer   ~0007687

possibly related with this thing:
create a text frame, open story editor, write some words. update. change some characters to another font face. update again. everything is correc.t but if you point the cursor in the story editor to the characters that were not changed, they dont display the right font

ringerc

2005-12-11 01:55

reporter   ~0007697

It looks like the SE isn't updating it's UI when the selection changes / cursor moves (in CVS of a few days ago; still need to update).

jo-hannes

2005-12-11 09:06

developer   ~0007707

the text color is updated, but not the font, as i see it.

avox

2006-07-23 13:44

administrator   ~0011974

when opening SE it obviously doesn't show the values corresponding to the first char in the toolbar. Moving the cursor fore and back gives the correct values.

I don't think it's worth fixing since we want to rewrite SE anyway.

christoph_s

2006-07-28 14:43

administrator   ~0012021

I'm just working with the latest 1.3.3.3cvs. Neither SE nor the PP display anything but the default values. This is a serious bug, because it's impossible to find out the colour value, font or size of a character.
Moreover, changing the default font for text frames in the Document Preferences is completely ignored by the SE. It uses the last font applied there instead.

And another funny issue: If the default font for text frames has been changed, the Properties Palette continues to display the previous default font in frames that had been created before the change.

Issue History

Date Modified Username Field Change
2005-11-12 23:17 jo-hannes New Issue
2005-12-10 01:00 jo-hannes Note Added: 0007687
2005-12-11 01:52 ringerc Relationship added related to 0002909
2005-12-11 01:55 ringerc Note Added: 0007697
2005-12-11 01:55 ringerc Relationship deleted related to 0002909
2005-12-11 01:56 ringerc Status new => confirmed
2005-12-11 09:06 jo-hannes Note Added: 0007707
2006-07-04 21:39 cbradney Relationship added child of 0003964
2006-07-23 13:44 avox Note Added: 0011974
2006-07-23 13:44 avox Priority normal => low
2006-07-23 13:44 avox Severity minor => trivial
2006-07-28 14:43 christoph_s Note Added: 0012021
2006-12-16 21:52 avox Relationship deleted child of 0003964
2007-05-23 21:17 christoph_s Relationship added related to 0003157
2012-01-04 20:51 cbradney Status confirmed => resolved
2012-01-04 20:51 cbradney Fixed in Version => 1.4.0svn
2012-01-04 20:51 cbradney Resolution open => fixed
2012-01-04 20:51 cbradney Assigned To => cbradney
2012-01-15 20:50 cbradney Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames