View Issue Details

IDProjectCategoryView StatusLast Update
0002897ScribusStory Editor / Text Framespublic2006-04-15 20:06
Reporterkavs0007 Assigned Tomhanski  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
PlatformLinuxOSUbuntuOS Version5.10
Product Version1.3 
Target VersionFixed in Version 
Summary0002897: Italian hyphenation not working right
DescriptionItalian hyphenation doesn't work right, both not working in some lines, and dividing words in a wrong way
Steps To ReproduceAlways, just try...
Additional InformationTake a look at the attacched Pdf...
TagsNo tags attached.
Patch

Relationships

related to 0001475 acknowledged hyphenation: use soft hyphen character (U+00AD) instead signed by ITEXT CSTYLE 8th bit attribute 
child of 0003828 acknowledged Metabug: Hyphenation 

Activities

2005-12-05 13:02

 

Example.pdf (1,628,469 bytes)

cbradney

2005-12-05 13:43

administrator   ~0007636

Compare to openoffice.org. Maybe we need a new file from there.

cbradney

2006-01-14 13:39

administrator   ~0008077

Did you compare to oo.org?

ale

2006-01-14 14:38

manager   ~0008082

Last edited: 2006-01-14 14:50

i had a look at the pdf and found two incorrect hyphenations:

- in the tracy chapman box about in the middle:"revolutio-n"
- in "never out--gunned" (why two hyphen? were they inserted by scribus?)

hey, that are english words and you told scribus that you were writing in italian!

sorry, those can't be corrected *now*... but as soon as the new text engine is ready, you will have the chance to define the language for every word... so, keep on waiting :-)

there is also a "not that nice" hyphenation:

- "all'o-pera": should be spelled "alla \n opera".

i don't know if the OpenOffice engine (which is used by scribus) can handle this. this bug should be tested in OO.org and, if it happens also there with the newest version (which i don't have here to test), it should be submitted to them as a bug (or as a feature request).


kavs0007, did i spot the errors you were reporting? if not, could you please give some more details on where which problem arises?


ps.: the result from latex on a file full of "all'operazione" is not much better :-(

cbradney

2006-01-14 21:51

administrator   ~0008088

I would think it would, the program would have to know the language as well as the hyph rules.

2006-01-22 17:59

 

new example.sla (323,337 bytes)

kavs0007

2006-01-22 18:01

reporter   ~0008250

Last edited: 2006-01-22 18:06

See the new example.sla in the text right in the bottom, the one intitled "E Roma a maggio ospiterà Williams". For exemple, "vengono divise per niente" should be "vengono divise per nien- te" with the last "te" in a new line. But the whole word "niente" is put in the new line.

ale

2006-01-24 09:06

manager   ~0008309

i can confirm that the word could be hyphenated but is not...

it's not wrong hyphenated... it's just not hyphenated but you would wish it would be...

i have two remarks:

- you can manually hyphenate the word with a soft-hyphen

- i don't know anything about the OO.org hyphenator, but i know that the latex algorithme, does look at the whole page before choosing to hyphenate or not a word. the one from OO is certainly not as good as the one from the tex world (it can't: latex doesn't hyphenate in a wysiwyg way, so it has all the time to make its calculations!) but i can imagine that it's checking the density of hyphenated lines, and you already many of them!


personaly, i don't see any error on the scribus side. but you're right that your frame could be better hyphenated. since scribus just uses the engine from OO.org, i think it would be better if you contact the italian maintainer of the italian hyphenation for OO.org! (but it could be that they're not really interested in improving this: they mainly target A4 pages, not small columns!)


and yes, it would be nice if scribus had a very good hyphenation engine! but i guess that a change wont happen in the near feature: we have a working one, and there are so many thing to get to work. also a enhancer is already built-in: you can add your own soft-hyphens!

spero di non averti eccessivamente deluso :-)

a.l.e


ps.: please in the future, don't just upload a .sla: if i haven't the same fonts as you have, i won't see the problem (i hadn't the same ones, but i saw (i think) the problem)

pps.: if you want to further discuss the problem, please come to the irc chanel.. or post to the mailing list. there you will found peple to discuss the issue with and, maybe, find a way to improve the hyphenation in scribus!

mhanski

2006-04-15 17:57

developer   ~0010012

closing this, as this has got nothing to do with Scribus, but with the hyphenation file from OpenOffice.org.

kavs0007, if you know of a better, freely distributable Italian hyphenation file for OpenOffice.org, please test it and inform the Scribus team about it. More information on Italian OpenOffice Localisation:

http://it.openoffice.org/

Issue History

Date Modified Username Field Change
2005-12-05 13:02 kavs0007 New Issue
2005-12-05 13:02 kavs0007 File Added: Example.pdf
2005-12-05 13:43 cbradney Note Added: 0007636
2006-01-14 13:39 cbradney Note Added: 0008077
2006-01-14 14:38 ale Note Added: 0008082
2006-01-14 14:47 ale Note Edited: 0008082
2006-01-14 14:50 ale Note Edited: 0008082
2006-01-14 21:51 cbradney Note Added: 0008088
2006-01-22 17:59 kavs0007 File Added: new example.sla
2006-01-22 18:01 kavs0007 Note Added: 0008250
2006-01-22 18:06 kavs0007 Note Edited: 0008250
2006-01-24 09:06 ale Note Added: 0008309
2006-02-05 20:34 jo-hannes Product Version 1.3.2cvs => 1.3
2006-02-05 20:34 jo-hannes Relationship added related to 0001475
2006-04-15 17:57 mhanski Status new => resolved
2006-04-15 17:57 mhanski Resolution open => won't fix
2006-04-15 17:57 mhanski Assigned To => mhanski
2006-04-15 17:57 mhanski Note Added: 0010012
2006-04-15 20:06 mhanski Status resolved => closed
2006-05-16 21:47 christoph_s Relationship added child of 0003828
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames