View Issue Details

IDProjectCategoryView StatusLast Update
0003051ScribusStory Editor / Text Framespublic2016-04-14 14:07
Reportermkoren Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status feedbackResolutionopen 
PlatformLinux x86OSDebianOS VersionSarge
Product Version1.3.3.1 
Target Version1.4.7Fixed in Version1.3.3cvs 
Summary0003051: mis-/nondisplay of overflow text near end of frame and in following linked frames
DescriptionIf the vertical size of a text frame is too close to the threshold between where a line of text at the bottom would jump from being displayed in that frame to being hidden or bumped to the next linked frame,
     a) only the first character or so of the line is displayed or similar
     b) if no following frame, the corner overflow indicator is not shown, or
     c) any following linked frames are displayed as empty, though correct statistics seem to be reported in the contect menu.
The threshold is small (see below), but unfortunately my document (imported from 1.2.1) happens to have been at it since October or so when I switched to cvs, leading me to think erroneously until now that 1.3 generally misdisplayed linked frames, which was rather inconvenient.
Hmm: I just discovered that it actually only seems to occur, or persist on resize, if the preserve aspect ratio button in properties is unselected.
Steps To ReproduceClose and reopen Scribus if necessary (maybe not necessary, but resets aspect ratio button). Create a document (so far could only verify with automatic text frames). Fill first page with text to overflow frame. Adjust height of frame carefully (may need to enter in properties box; see below for precision) until last currently displayed line barely no longer fits. Listed symptoms will occur. (See attached file for premade example.) If a second frame is linked to the first, the extra text will not spill over into it, but should appear as linked in context menu (though hard to see because of bug 3050).
I'm not quite sure the relationship of the aspect ratio button here; try opening the attached doc and immediately going to properties and deselecting it, then playing with the height if you can't reproduce the problem.)
Additional InformationFor me the tolerance of the vertical size to obtain the bug seems to be one pt at a font size of 18 (see document), ranging from .5 pt +/- some center value (645.5-646.49 pt in the attached document).

Sometimes an alternate visual artifact when playing with it is the overlay of another page worth of text over the first frame--possibly what should go to the next frame; I can't tell.

Incidentally I find it annoying that the aspect ratio button doesn't preserve its state over restart/reload or something, but I'll file a separate request.
Tags#please_test, #tobeclosed
PatchNo

Relationships

related to 0013652 feedback Single character layed out twice while word cut between 2 linked text frames 
related to 0008461 new Column/Frame Breaks involving Inline Frames Handled Incorrectly 

Activities

2006-01-22 04:42

 

Test.sla (55,010 bytes)

cbradney

2006-01-22 10:11

administrator   ~0008231

Shows T at 646.49 and then the full line at 646.50

plinnell

2006-03-05 22:25

viewer   ~0009077

some other fixes in 1.3.3cvs ahve resolved it. Seems fine now.

mkoren

2006-03-11 21:24

reporter   ~0009191

This isn't fixed here as of the latest deb released March 9. Open the document I attached previously and it still fails to display the second page.

christoph_s

2006-03-11 21:55

administrator   ~0009192

I can confirm mkoren's observation under SuSE 9.3. It doesn't seem to be fixed.

cbradney

2006-03-11 22:11

administrator   ~0009194

Yes.. resave it when it does fit.. works ok here.

mkoren

2006-03-13 18:08

reporter   ~0009234

Hmm...at first I was getting the same result, but actually apparently it only happens if the width remains exactly 648.00 pt, and with the preserve-aspect-ratio button checked, changing the height slightly changed the width as well. This explains the dependence on that button being unchecked that I noted before (and provides support for my request in bug 3052--I completely forgot to uncheck it initially :).
If you uncheck the button and change the height alone, the same thing still happens, even if you save a working state and then manually adjust both width and height back to the affected parameters.
There doesn't seem to be any similar behavior for any other width; I don't know why. I haven't tried recreating this from scratch; maybe the original problem is fixed and it only affects old frames somehow, but then this might ought to be added to bug 3380 as a file problem.

Magnes

2006-10-28 09:11

reporter   ~0013150

Last edited: 2006-10-28 09:11

My document was fine, but when I used "break words" on the text frames I had the same problem as described above. My paragraph style: 9pt Georgia Regular.
I atached screen. On the end of the left page there is only one letter (or sth wich looks like several letters in one place), the right page (linked to tle left) is empty. I use 1.3.3.4 version for Ubuntu.

2006-10-28 09:12

 

brokenpages.jpg (176,471 bytes)
brokenpages.jpg (176,471 bytes)

plinnell

2006-10-28 11:10

viewer   ~0013151

Still an issue here with 1335cvs

2006-11-08 01:20

 

bogus.sla (80,677 bytes)

mkoren

2006-11-08 01:22

reporter   ~0013324

I seem to have created another case of this in a new 1.3.3.4 file. See upper right text frame in attached file.

Magnes

2007-03-18 13:03

reporter   ~0015556

I had the same today in Scribus 1.3.3.8.

Kunda

2016-01-18 14:34

manager   ~0038248

Can someone reproduce?

Kunda

2016-04-13 13:37

manager   ~0040117

I wasn't able to reproduce the issue importing Test.sla
But I think I was able to reproduce it in the bogus.sla example. (see the upper right text frame in that file)

Kunda

2016-04-13 13:39

manager   ~0040118

Though on 2nd thought.. i don't think I can reproduce it. Not sure. Need more eyes on this to see if it's obsolete or not.

Laser

2016-04-13 14:06

reporter   ~0040126

Can reproduce with 1.4.6 - see attached.
Not able to reproduce with 1.5.2.

Laser

2016-04-13 14:07

reporter  

Kunda

2016-04-13 14:16

manager   ~0040129

Oh, Ok. Thanks laser.
assigning to 1.4.7 to see if the devs want to backport this.

Laser

2016-04-14 13:13

reporter   ~0040164

Have to correct!
With a letter that goes under the baseline, I get the attached result with 1.5.2...

Laser

2016-04-14 13:13

reporter  

Kunda

2016-04-14 13:56

manager   ~0040165

This is a duplicate bug I think of something that I've seen before...

Kunda

2016-04-14 14:07

manager   ~0040167

related: 0013652 ?

Issue History

Date Modified Username Field Change
2006-01-22 04:42 mkoren New Issue
2006-01-22 04:42 mkoren File Added: Test.sla
2006-01-22 10:11 cbradney Status new => assigned
2006-01-22 10:11 cbradney Assigned To => fschmid
2006-01-22 10:11 cbradney Note Added: 0008231
2006-03-05 22:25 plinnell Status assigned => resolved
2006-03-05 22:25 plinnell Fixed in Version => 1.3.3cvs
2006-03-05 22:25 plinnell Resolution open => fixed
2006-03-05 22:25 plinnell Note Added: 0009077
2006-03-11 21:24 mkoren Status resolved => feedback
2006-03-11 21:24 mkoren Resolution fixed => reopened
2006-03-11 21:24 mkoren Note Added: 0009191
2006-03-11 21:55 christoph_s Note Added: 0009192
2006-03-11 22:11 cbradney Note Added: 0009194
2006-03-13 18:08 mkoren Note Added: 0009234
2006-04-26 12:26 mhanski Product Version 1.3.2cvs => 1.3.3.1
2006-10-28 09:11 Magnes Note Added: 0013150
2006-10-28 09:11 Magnes Note Edited: 0013150
2006-10-28 09:12 Magnes File Added: brokenpages.jpg
2006-10-28 11:10 plinnell Note Added: 0013151
2006-10-28 11:10 plinnell Status feedback => assigned
2006-10-28 11:10 plinnell Resolution reopened => open
2006-11-08 01:20 mkoren File Added: bogus.sla
2006-11-08 01:22 mkoren Note Added: 0013324
2007-03-18 13:03 Magnes Note Added: 0015556
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2015-12-16 21:00 Kunda Tag Attached: #please_test
2016-01-18 14:34 Kunda Note Added: 0038248
2016-04-13 13:37 Kunda Note Added: 0040117
2016-04-13 13:39 Kunda Note Added: 0040118
2016-04-13 13:40 Kunda Tag Attached: #tobeclosed
2016-04-13 14:06 Laser Note Added: 0040126
2016-04-13 14:07 Laser File Added: Bildschirmfoto_2016-04-13_15-59-36.png
2016-04-13 14:16 Kunda Patch => No
2016-04-13 14:16 Kunda Note Added: 0040129
2016-04-13 14:16 Kunda Target Version => 1.4.7
2016-04-13 14:17 Kunda Status assigned => feedback
2016-04-14 13:13 Laser Note Added: 0040164
2016-04-14 13:13 Laser File Added: Bildschirmfoto_2016-04-14_15-11-21.png
2016-04-14 13:54 Kunda Relationship added related to 0008461
2016-04-14 13:56 Kunda Note Added: 0040165
2016-04-14 14:07 Kunda Note Added: 0040167
2016-04-14 14:07 Kunda Relationship added related to 0013652