View Issue Details

IDProjectCategoryView StatusLast Update
0003118ScribusOS-PPCOSXpublic2008-01-28 20:04
Reporterzehnkatzen Assigned Toavox  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacintoshOSOS XOS Version10.3.9
Product Version1.3.3.1 
Target Version1.3.5Fixed in Version1.3.5svn 
Summary0003118: Aqua interface does not accept or respond to keyboard input
DescriptionWhen the application is in the Macintosh(Aqua) interface theme, the GUI does not respond to or accept text input from the keyboard. It is most noticeable with text frames: when selected with the Edit Contents of Frame tool, the I-beam displays when the cursor is over the frame and can be placed, and text can be highlighted, but the interface refuses to place typed text. None shows up. It works in all other interfaces, and in the Aqua interface all dialog boxes (and the Story Editor) accept typed input, but this will not work in the layout display in the text frame.
TagsNo tags attached.
Patch

Relationships

related to 0002015 closedavox This issue lists all known regressions of the Aqua port compared with the 13 Linux version 
has duplicate 0003549 closedmhanski Can not edit text frames directly 

Activities

mhanski

2006-04-08 17:58

developer   ~0009712

could you try a newer version from http://aqua.scribus.net/ and see, it the issue persists?

zehnkatzen

2006-04-20 08:07

reporter   ~0010163

Last edited: 2006-04-20 08:09

I just tried the newest version (1.3.3.1 "Printemps"), which was apparently billed as the lastest snapshot. It was dated 27 March 2006, but still had the same build ID as beofre (C-C-T-F-A Mac/Aqua). The symptom persists.

I did not replace any of the frameworks. It is not clear if that is necessary.

jo-hannes

2006-04-20 08:23

developer   ~0010165

its a known issue, see 2015 or aqua.scribus.net

jimkillock

2006-05-19 17:19

reporter   ~0011379

I also have this bug. Two possible things might be contributing to it, I could suggest: one is a vast number of installed fonts and the other is use of a Wacom tablet. Just a thought.

avox

2006-05-19 18:46

administrator   ~0011380

No, this is a known issue caused by the properties palette getting the focus all the time.

As a workaround, enable textframe editing with the corresponding tool button or click
on Scribus' titlebar. This transfers the focus to the correct widget.

This is an issue with the QT/Mac <-> Scribus interplay and it comes and goes as development
processes. Current 1.3.4cvs works correctly at the moment.

/Andreas

Issue History

Date Modified Username Field Change
2006-01-26 07:42 zehnkatzen New Issue
2006-04-08 17:58 mhanski Note Added: 0009712
2006-04-20 08:07 zehnkatzen Note Added: 0010163
2006-04-20 08:07 zehnkatzen Note Edited: 0010163
2006-04-20 08:09 zehnkatzen Note Edited: 0010163
2006-04-20 08:16 mhanski Note Added: 0010164
2006-04-20 08:16 mhanski Product Version 1.3.2cvs => 1.3.3.1
2006-04-20 08:18 jo-hannes Category Story Editor / Text Frames => PPCOSX
2006-04-20 08:23 jo-hannes Note Added: 0010165
2006-04-20 08:23 jo-hannes Status new => confirmed
2006-04-20 08:23 jo-hannes Status confirmed => assigned
2006-04-20 08:23 jo-hannes Assigned To => avox
2006-04-20 08:23 jo-hannes Relationship added related to 0002015
2006-04-20 20:28 mhanski Relationship added has duplicate 0003549
2006-05-19 17:19 jimkillock Note Added: 0011379
2006-05-19 18:46 avox Note Added: 0011380
2008-01-26 22:25 cbradney Status assigned => resolved
2008-01-26 22:25 cbradney Fixed in Version => 1.3.5svn
2008-01-26 22:25 cbradney Resolution open => fixed
2008-01-26 22:26 cbradney Target Version => 1.3.5
2008-01-28 20:04 cbradney Status resolved => closed
2014-10-08 18:38 Kunda Category PPCOSX => OS-PPCOSX