View Issue Details

IDProjectCategoryView StatusLast Update
0003408ScribusImport / Exportpublic2010-12-04 04:32
ReporterPeturrr Assigned Tochristoph_s  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionnot fixable 
PlatformLinux x86OSUbuntuOS Version6.04
Product Version1.3.3cvs 
Target VersionFixed in Version 
Summary0003408: Chordpro import and chordsetting
DescriptionI am trying to create a songbook from chordpro files.

Chordpro format is this: [E]Lala lala [B]this is a [A]songline
The [E] and other bracketed letters are chords. The chordpro notation makes you notate these chords in the exact position where they need to be placed.
Correctly rendered, the song will be displayed as:

E B A
Lala lala this is a songline

Since I am dedicated to legal software use and I really love to contribute to Scribus I am really wanting to see Scribus becoming capable of ChordPro typesetting. I now there is a very sophisticated Perl script that produce html/assci/latex output of chordpro. I think it's possible to use the source of that one to make this work for scribus.

Please checkout this link for this great script: http://mujweb.cz/www/danielpolansky/chordpack/

Since I need this functionality in Scribus I am willing to learn a little Perl,python or Qt. I do need some direction/suggestions in how this can be easily done and what the best way is to get it working. I think that a python script is the easy way, but I hope that it's possible to create a special import filter for chordpro. Please enlighten me for the way to go.
TagsNo tags attached.
Patch

Activities

Peturrr

2006-03-14 09:28

reporter   ~0009253

This should offcourse be a feature request. Please change

Peturrr

2006-03-14 09:47

reporter   ~0009254

:) I see that mantis doesn't display the chords correctly above the songline.
'[E]Lala lala [B]this is a [A]songline' means that the E will be placed above the first letter of Lala. The B will be displayed above 'this' etc.

subik

2006-03-14 15:03

manager   ~0009260

Peturrr: some of developers plays guitar too. E.g. me can read this files ;)

chordpack script is real mess. it is not usable for scribus. Of course you can use it to create postscript file with it (via LaTeX) for import.

There should be one big problem with it if we decide to write Scribus importer - and you can see it in Mantis too - it is easy to implement only using the typewritter fonts. In the case you use variable kerning you have to play with font metrics to fit chord positions. And it is not easy.

Peturrr

2006-03-14 17:34

reporter   ~0009261

Hmm. I really do need some kind of this functionality.I know of an closed source app that I sometimes use that does display these things correctly using non-typewriter fonts. see: http://www.tenbyten.com/software/songsgen/index.php
It must be possible to work something out like this. It would be a great option for Scribus and above all, I need it ;).

Subik, are you willing to join me in this effort? I unfortunately only have some php coding ability, but that's a long time ago. :)

Peturrr

2006-03-14 17:36

reporter   ~0009262

Last edited: 2006-03-14 17:41

Oh.. I see that is also an opensource project, written in C++. I am really convinced it must be able to do. But I am afraid this will take a lot of time.

Peturrr

2006-07-22 19:55

reporter   ~0011961

I have been programming in ruby for a few months now and have been able to create a script that takes a chordpro song and converts it into a nice looking html page using tables. The html page gets converted to pdf, so I can do the things I want.

When a little more advanced table support has been implemented, I will take some time to study how Scribus works. I guess that will take a lot of months, since that has been scheduled for 1.3.8.

I hope by then I will be able to create an import script. Hopefully this can be done in a higher level scripting level like Python or even Ruby. If it needs QT, than it will be probably not something I will do, since at this moment I don't have the time to start learning another complete language :), but who knows.

You guys will hear from me some day, I hope!

subik

2007-02-05 10:06

manager   ~0015101

very interesting one: http://www.chordshop.com/

christoph_s

2009-09-05 23:47

administrator   ~0022467

I will create a configuration file for Render Frames, so that Scribus can render chordii's PS output on a page.

2009-10-03 00:06

 

600_guitartex.xml (926 bytes)

christoph_s

2009-10-03 00:13

administrator   ~0022602

OK, this works on Linux and Unix, including OS X:

Download and install GuitarTeX from Sourceforge: http://guitartex.sourceforge.net/

Go to File > Preferences > External Tools and load the XML file I uploaded via "Add" into the Render Frame configuration. You can then copy and paste the content of Chordpro files into the editor and render them.

christoph_s

2010-12-04 04:31

administrator   ~0024976

I'm closing this bug. There's obviously no library or CLI tool available that works across our supported platforms.

Peturrr, since this bug has already caught some dust, I hope you have found another solution. Sorry.

Issue History

Date Modified Username Field Change
2006-03-14 09:15 Peturrr New Issue
2006-03-14 09:28 Peturrr Note Added: 0009253
2006-03-14 09:42 plinnell Severity minor => feature
2006-03-14 09:42 plinnell Status new => acknowledged
2006-03-14 09:47 Peturrr Note Added: 0009254
2006-03-14 15:03 subik Note Added: 0009260
2006-03-14 17:34 Peturrr Note Added: 0009261
2006-03-14 17:36 Peturrr Note Added: 0009262
2006-03-14 17:41 Peturrr Note Edited: 0009262
2006-07-22 19:55 Peturrr Note Added: 0011961
2007-02-05 10:06 subik Note Added: 0015101
2009-09-05 23:46 christoph_s Status acknowledged => assigned
2009-09-05 23:46 christoph_s Assigned To => christoph_s
2009-09-05 23:47 christoph_s Note Added: 0022467
2009-10-03 00:06 christoph_s File Added: 600_guitartex.xml
2009-10-03 00:13 christoph_s Note Added: 0022602
2010-12-04 04:31 christoph_s Note Added: 0024976
2010-12-04 04:31 christoph_s Status assigned => resolved
2010-12-04 04:31 christoph_s Resolution open => not fixable
2010-12-04 04:32 christoph_s Status resolved => closed