View Issue Details

IDProjectCategoryView StatusLast Update
0003441ScribusGraphics / Image Framespublic2006-05-01 21:46
Reporterthoth Assigned Tocbradney  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
PlatformanyOSanyOS Versionany
Product Version1.3 
Target VersionFixed in Version 
Summary0003441: request ability to reference external SVGs as images without importing
DescriptionI would like the ability to construct a scribus document which references external SVGs. If the SVG changes, I should be able to print/export-to-PDF the scribus document and get the new version of the .SVG without having to re-import or re-reference the SVG files.

  In this case the .SVG should be treated much the same way as a PNG or JPG is within the editor (as an atomic unit).
TagsNo tags attached.
Patch

Relationships

duplicate of 0000393 acknowledged SVG inside a picture frame 
related to 0003863 assignedfschmid Xara Extreme import/export filter 
child of 0002931 acknowledged Metabug: SVG 

Activities

mhanski

2006-04-29 21:04

developer   ~0010644

Reminder sent to: avox

avox: what do you think, is it technically doable?

avox

2006-04-29 21:13

administrator   ~0010649

Sure, we already have that for images.
I'd even propose to enable this for text content also.

mhanski

2006-04-29 21:26

developer   ~0010653

avox: sounds cool, what do you think about extending the summary of this RFE to "ability to reference external SVG, EPS, and text files"?

avox

2006-04-29 21:47

administrator   ~0010657

No, EPS is already handled like TIF, at least in imageframes.

And I don't think it would be useful to have external auto-imported EPS files.

For text we should put that in an extra issue, if there isn't one already.

avox

2006-04-29 21:50

administrator   ~0010658

Hm, I'm having seconds thought about importing SVG automatically from external files.
What should Scribus do if the drawing was edited in Scribus??

I'd rather add an option to imageframes to load SVG, and make sure that SVG, EPS and PDF
are *not* rastered when Scribubs creates PS or PDF. AFAIK this only works for EPS and printing
at the moment.

christoph_s

2006-04-29 22:26

administrator   ~0010662

See http://bugs.scribus.net/view.php?id=393

mhanski

2006-04-30 11:10

developer   ~0010694

<quote>What should Scribus do if the drawing was edited in Scribus??</quote>

I think the whole idea of this request is that it shouldn't be edited in Scribus, just referenced. I can imagine, the request author would like to edit his SVG's in an vector drawing application which offers superior editing capabilities which are not available in Scribus. Scribus should only produce a placeholding preview and launch his external editor, if he wants to edit it (just the way it works with gimp-remote -- yet another setting in Preferences would be needed). Furtherly, it probably means, SVG's in image frames shouldn't be handled as Scribus native objects, contrarily to the imported SVG's, which should be available as well.

<quoting>I'd rather add an option to imageframes to load SVG, and make sure that SVG, EPS and PDF are *not* rastered when Scribubs creates PS or PDF. AFAIK this only works for EPS and printing at the moment.</quoting>

This doesn't contradict having the SVG's as external, referenced files in image frames. The abovementioned steps would be performed while printing/exporting to PDF/PS and are more than necessary anyway, imho.

PLucAuclair

2006-04-30 16:16

reporter   ~0010702

Same goes for EPS, we really need to be able to have vector illustrations as images, and that includes text.

Issue History

Date Modified Username Field Change
2006-03-15 23:01 thoth New Issue
2006-04-17 22:11 mhanski OS gentoo => any
2006-04-17 22:11 mhanski OS Version 2005.1 => any
2006-04-17 22:11 mhanski Platform linux => any
2006-04-17 22:11 mhanski Product Version 1.2.4.1 => 1.3
2006-04-29 21:04 mhanski Note Added: 0010644
2006-04-29 21:04 mhanski Status new => feedback
2006-04-29 21:13 avox Note Added: 0010649
2006-04-29 21:26 mhanski Note Added: 0010653
2006-04-29 21:47 avox Note Added: 0010657
2006-04-29 21:50 avox Note Added: 0010658
2006-04-29 22:26 christoph_s Note Added: 0010662
2006-04-29 22:29 mhanski Relationship added related to 0000393
2006-04-30 11:10 mhanski Note Added: 0010694
2006-04-30 16:16 PLucAuclair Note Added: 0010702
2006-04-30 18:54 cbradney Relationship replaced duplicate of 0000393
2006-04-30 18:54 cbradney Duplicate ID 0 => 393
2006-04-30 18:54 cbradney Status feedback => resolved
2006-04-30 18:54 cbradney Resolution open => duplicate
2006-04-30 18:54 cbradney Assigned To => cbradney
2006-05-01 21:45 jo-hannes Status resolved => closed
2006-05-17 18:36 christoph_s Relationship added child of 0002931
2006-05-28 21:31 mhanski Relationship added related to 0003863
2015-09-17 20:10 Kunda Category Graphics / Image Frames => Graphics/Img Frames
2015-09-17 20:11 Kunda Category Graphics/Img Frames => Graphics / Image Frames