View Issue Details

IDProjectCategoryView StatusLast Update
0000360ScribusStory Editor / Text Framespublic2004-04-08 23:45
Reporterpsychonaut Assigned Tocbradney  
Status closedResolutionfixed 
PlatformKDE 3.1.2OSSuSEOS Version9.0
Product Version1.1.5 
Summary0000360: Can't insert page number
DescriptionI can't insert page numbers into a text box in a template. According to the online help, the procedure is as follows: "Go to Edit > Templates, then create a text frame where you want the page number to appear. Then, in edit mode, enter Alt+#." However, when I press Alt+#, nothing happens. I've tried this both with a US layout (where # is Shift+3) and a UK layout (where # is its own key). I also tried changing the keyboard shortcut in the Preferences dialog to some other key or key combination, and still nothing seems to be inserted.
Steps To Reproduce1. Right click on a text box in a template.
2. Select "Edit Text..."
3. Press the key or key combination registered in the Preferences which should produce an automatic page number marker.
4. Nothing happens.
TagsNo tags attached.


related to 0003837 acknowledged Metabug: Master pages/Page templates 



2004-03-26 20:48

viewer   ~0000788

On a US keyboard - I change the keyboard shortcut to something like F8.


Edit template

Draw a text frame.

Press the shortcut key while in edit mode in the text frame.

Exit the Edit Template mode..

Page number should show up.

The auto page numbering will not show in the template itself.. only the # symbol. For page numbers above 10 ## above 100 ###

Tested here and works - as it always has on SuSE 9.0, Qt 3.3.1/KDE 3.2.1


2004-03-27 14:00

reporter   ~0000803

Hey, it's rather presumptuous to close this bug as resolved just because it works for you. I've tried exactly the same procedure you wrote, and it doesn't work for me. I change the shortcut key to Ctrl+# or F7 or F8 or whatever, press said key when editing a text box in a template, and nothing happens. If I exit the edit window and save changes, the text box remains empty.

Since we're using the same environment (SuSE 9.0, Qt 3.3.1/KDE 3.2.1) there must be some other variable causing this bug. As I mentioned, I tried various keyboard layouts (Dvorak, US-International, UK). Can you think of anything else I should test to isolate the cause?


2004-03-27 14:28

administrator   ~0000804

It was marked as resolved due to the fact that there is a fix in the internal CVS. It was not marked Closed. When the main CVS is back you will be able ot update to it, or when we release 1.1.6 you will have the fix there.


2004-04-08 23:45

administrator   ~0000984

This IS fixed. Please update if you havent already.


2004-04-08 23:45

administrator   ~0000985

Tested and it works fine here. Closed.

Issue History

Date Modified Username Field Change
2004-03-24 14:07 psychonaut New Issue
2004-03-26 20:48 plinnell Note Added: 0000788
2004-03-26 20:48 plinnell Severity major => minor
2004-03-26 20:48 plinnell Status new => feedback
2004-03-26 20:48 plinnell Resolution open => unable to reproduce
2004-03-27 09:54 fschmid Status feedback => resolved
2004-03-27 09:54 fschmid Resolution unable to reproduce => fixed
2004-03-27 09:54 fschmid Assigned To => fschmid
2004-03-27 14:00 psychonaut Status resolved => feedback
2004-03-27 14:00 psychonaut Resolution fixed => reopened
2004-03-27 14:00 psychonaut Note Added: 0000803
2004-03-27 14:28 cbradney Note Added: 0000804
2004-04-08 23:45 cbradney Status feedback => resolved
2004-04-08 23:45 cbradney Resolution reopened => fixed
2004-04-08 23:45 cbradney Assigned To fschmid => cbradney
2004-04-08 23:45 cbradney Note Added: 0000984
2004-04-08 23:45 cbradney Status resolved => closed
2004-04-08 23:45 cbradney Note Added: 0000985
2006-05-18 19:48 christoph_s Relationship added related to 0003837
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames