View Issue Details

IDProjectCategoryView StatusLast Update
0003967ScribusUser Interfacepublic2006-09-20 23:26
Reportermhanski Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
PlatformPentium(R) M processor 1.50GHzOSKubuntuOS VersionDapper Drake
Product Version1.3.4cvs 
Target VersionFixed in Version 
Summary0003967: Preferences/General: Font size setting for Palette titles needed
DescriptionAdditional font size setting for palette titles.

Changing font size for menus and palettes has no influence on palette titles, which display much to small and, therefore, ugly (see the attached screenshot)
TagsNo tags attached.
Patch

Relationships

related to 0003816 closedcbradney Preferences/Tools: Add appriopriate titles for subsections 
related to 0002464 acknowledged Metabug: GUI appearance 
related to 0003291 closedplinnell Preferences>General: Font face setting needed 
related to 0003980 closedcbradney Palettes: Inconsistent font size of palette titles 
related to 0003983 closedjghali scribus does not respect the windows ui font but uses its own 
child of 0003821 acknowledged Metabug: Usability 

Activities

2006-07-03 19:28

 

fschmid

2006-08-25 13:36

administrator   ~0012304

Sorry we can't fix that, the font size of the Palettes titels is a Window manager setting. So you must use the relevant Controlpanel of you OS to set the size.

mhanski

2006-09-20 15:10

developer   ~0012582

<quote>Sorry we can't fix that, the font size of the Palettes titels is a Window manager setting.</qoute>

In fact, there is only the "Window title" setting in KDE settings, and no "Palette titles" setting. Scribus just takes this "Window title" font size and arbitrarily decreases (about 1 pt?) it for "Palette titles" in Scribus. This is, plainly speaking, a very ugly solution -- the user has to change the "Window titles" size of his whole desktop environment just to change the "Palette titles" size in one of his programs...

<quote> So you must use the relevant Controlpanel of you OS to set the size.</qoute>

I did change the "Window titles" setting, because I like Scribus. But, as stated above, this solution is ugly and could be too much asked for other Scribus users. Please reconsider.

fschmid

2006-09-20 19:12

administrator   ~0012585

Looked again into the Qt doucmentation, there is no function for setting the font size of window titles. You can only set the text, everything else is done by the window manager. So we really can't fix that.

Issue History

Date Modified Username Field Change
2006-07-03 19:28 mhanski New Issue
2006-07-03 19:28 mhanski File Added: palette_headers_too_small.png
2006-07-03 19:29 mhanski Summary Preferencec/General: Font size setting for Palette titles needed => Preferences/General: Font size setting for Palette titles needed
2006-07-03 19:30 mhanski Relationship added related to 0003291
2006-07-03 19:31 mhanski Relationship added child of 0003821
2006-07-04 22:06 mhanski Relationship added related to 0003816
2006-07-04 22:44 mhanski Relationship added related to 0003980
2006-07-05 10:35 mhanski Relationship added related to 0003983
2006-07-20 08:53 mhanski Relationship added related to 0002464
2006-08-25 13:36 fschmid Status new => resolved
2006-08-25 13:36 fschmid Resolution open => not fixable
2006-08-25 13:36 fschmid Assigned To => fschmid
2006-08-25 13:36 fschmid Note Added: 0012304
2006-08-25 13:59 jo-hannes Status resolved => closed
2006-09-20 15:10 mhanski Status closed => feedback
2006-09-20 15:10 mhanski Resolution not fixable => reopened
2006-09-20 15:10 mhanski Note Added: 0012582
2006-09-20 19:12 fschmid Note Added: 0012585
2006-09-20 19:12 fschmid Status feedback => resolved
2006-09-20 19:12 fschmid Resolution reopened => not fixable
2006-09-20 23:25 mhanski Status resolved => closed