View Issue Details

IDProjectCategoryView StatusLast Update
0004273ScribusPDFpublic2007-11-22 23:37
Reporterarguile Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformAMD OpteronOSLinuxOS VersionKernel 2.6.12
Product Version1.3.3.4cvs 
Target VersionFixed in Version 
Summary0004273: PDF Forms: Manual tracking in text fields isn't respected.
DescriptionBug 3282 is probably closely related.

Adding manual tracking in PDF form fields does not get exported.

I believe the proper way to do this is a 'n Tc' operator -- where n is a number and Tc is the postscript character spacing operator -- to DA (default appearance) key of the field.

PDF Reference 1.6 Page 368 (I checked back as far as PDF 1.4)
Steps To Reproduce1. Use the supplied file (it has tracking set to 20% on the field)
2. Export to PDF 1.4+

The value of the field DA is:

  '/Helv 18.00000 Tf 0.00000 0.00000 0.00000 rg',

No mention of any form of character spacing changes.
TagsNo tags attached.
Patch

Relationships

duplicate of 0005444 closedjghali PDF forms: broken kerning in text fields, list boxes, buttons, etc. 
child of 0003831 acknowledged Metabug: PDF Forms 

Activities

2006-09-20 21:03

 

tracking_test.sla (43,576 bytes)

fschmid

2006-09-21 06:40

administrator   ~0012586

Last edited: 2006-09-21 06:41

In theory this could work, only problem is that the /DA entry of a text field
is applied to the whole string defined be the /V key. So if you write the /DA
entry this way /DA ( 0 0 1 rg 0.25 Tc 12 Tf ) it would apply the spacing to
the whole string. And i guess you want to have that kerning adjustment only
for specific glyph pairs.

arguile

2006-10-02 16:04

reporter   ~0012760

In my case no, I believe it should apply to the entire field (value of V key).

As AcroFrom strings are being supplied by the user, applying custom kerning or tracking adjustments to specific glyph pairs doesn't seem realistic (outside of embedding the font again with a custom metrics file).


Related to that though, I can see how it might be nice to have the exact text/styling shown in Scribus field -- things like bolded or different colour words in the string -- to be preserved in the PDF. All annotations (Acroform widgets are considered annotations) can have an appearance dictionary (AP key) associated with then (since PDF 1.2). By converting the field appearance to a Form XObject stream the exact styling could be preserved until the field was edited: At which point the DA key would rule and be used to style the entire string of new input (except when the RV key is present and CSS attributes override it).

Issue History

Date Modified Username Field Change
2006-09-20 21:03 arguile New Issue
2006-09-20 21:03 arguile File Added: tracking_test.sla
2006-09-20 23:28 mhanski Relationship added child of 0003831
2006-09-21 06:40 fschmid Note Added: 0012586
2006-09-21 06:41 fschmid Note Edited: 0012586
2006-10-02 16:04 arguile Note Added: 0012760
2007-11-22 23:36 christoph_s Relationship added duplicate of 0005444
2007-11-22 23:37 christoph_s Status new => closed
2007-11-22 23:37 christoph_s Resolution open => duplicate