View Issue Details

IDProjectCategoryView StatusLast Update
0004360ScribusScripterpublic2019-06-04 20:56
Reportermixi Assigned Tojghali  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
PlatformanyOSanyOS Versionany
Product Version1.3.3.4 
Target VersionFixed in Version1.5.4.svn 
Summary0004360: Access attributes via Python/Scripter
DescriptionATM it's not possible to access an item's user-defined attributes. That would be a great thing, if there's a way to do so.
TagsNo tags attached.
Patch

Activities

ringerc

2006-10-05 02:05

reporter   ~0012796

That was actually the original purpose of the user defined attributes. I just never got around to writing the functions to access them, since I discovered that most of the things I wanted to do with the scripter were impractical because of other reasons as well.

The current scripter will be scrapped and replaced entirely in or after 1.4 (at least, that's the plan) but it's probably not too hard to add this even if the code does just get chucked out.

I'll try to find some time to do it.

cdancette

2018-11-15 22:26

reporter   ~0045620

Hi !
Is there any update on this issue ? I didn't see anything in 1.4 scribus documentation about this

ale

2018-11-16 17:46

manager   ~0045628

if i understand the ticket correctly, the feature has been implemented in 1.5.

cdancette

2018-11-17 16:24

reporter   ~0045632

Yes, It works on 1.5.4 with getObjectAttributes and setObjectAttributes functions.

They are not in the documentation though

jghali

2018-11-17 18:04

administrator   ~0045633

Documentation has now been added too.

Issue History

Date Modified Username Field Change
2006-10-04 22:15 mixi New Issue
2006-10-05 02:05 ringerc Note Added: 0012796
2006-10-05 02:05 ringerc Status new => confirmed
2018-11-15 22:26 cdancette Note Added: 0045620
2018-11-16 17:46 ale Note Added: 0045628
2018-11-17 16:24 cdancette Note Added: 0045632
2018-11-17 18:04 jghali Assigned To => jghali
2018-11-17 18:04 jghali Status confirmed => resolved
2018-11-17 18:04 jghali Resolution open => fixed
2018-11-17 18:04 jghali Fixed in Version => 1.5.4.svn
2018-11-17 18:04 jghali Note Added: 0045633
2019-06-04 20:56 cbradney Status resolved => closed