View Issue Details

IDProjectCategoryView StatusLast Update
0004857ScribusStory Editor / Text Framespublic2007-01-06 00:13
Reporterchristoph_s Assigned Toavox  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSLinuxOS VersionSuSE 10.1
Product Version1.3.4cvs 
Target VersionFixed in Version1.3.4cvs 
Summary0004857: Bad cursor placement in text frames
DescriptionIn text frames the cursor is placed exactly _in_ the frame border in a new line (see screenie). This makes the cursor almost invisible, unless the view is enlarged. Proposed solution: Place the cursor beside the text frame (inside) or make it "fatter".
If I may add a suggestion in this context: Cursor placement in text frames is still a torture in Scribus, and the issues cost a lot of time. If this could be seriously improved before 1.3.6, I'm sure almost all users would celebrate ;)
TagsNo tags attached.
Patch

Relationships

child of 0003157 acknowledged Metabug: Cursor placement fixes 

Activities

2006-12-18 13:33

 

bad_cursor_placement.png (2,513 bytes)
bad_cursor_placement.png (2,513 bytes)

jo-hannes

2007-01-05 00:03

developer   ~0014532

there seems to be no cursor at all at the first position of a text frame (before the first character)

plinnell

2007-01-05 00:20

viewer   ~0014535

works fine except as johannes mentioned no cursor in the first line first char of a text frame

avox

2007-01-05 01:59

administrator   ~0014548

cursor is now shown at begin of frame. can we keep this closed, now? ;-)

jo-hannes

2007-01-05 12:36

developer   ~0014562

there is still no cursor at the beginning in an empty textframe.

cbradney

2007-01-05 12:43

administrator   ~0014563

Update your cvs

jo-hannes

2007-01-05 13:05

developer   ~0014564

i have uptodate cvs. but there is no cursor if you create a textframe and double click it. see screenshot.

2007-01-05 13:06

 

no cursor.png (283 bytes)
no cursor.png (283 bytes)

christoph_s

2007-01-05 15:46

administrator   ~0014569

Another point is the behaviour of the cursor wrt control characters. If placed before such a character the display is correct, i.e. Io, but behind a cc it doesn't look like oI, but the cursor covers a part of the control character (see screenshot).

2007-01-05 15:47

 

cursor-after-cc.png (1,048 bytes)
cursor-after-cc.png (1,048 bytes)

avox

2007-01-05 23:32

administrator   ~0014595

That's because control characters are no properly designed chars but just some outlines which are drawn instead of a char. For ex. the o for blanks has always the same size, but the cursor is placed at the real advance width of the blank. That might be inside the o for some fonts, sorry. Controlchars can even bump into the chars around it, you may have noticed already. Since the layout of the other chars must not change when controlchars are displayed, the only alternative would be to adjust the size of the controlchars to the available space. But what if there just isn't enough space?
IMO the current solution is good enough. We might implement some fancier scheme when we have some more time at our hands, but not before 1.3.6.

Issue History

Date Modified Username Field Change
2006-12-18 13:33 christoph_s New Issue
2006-12-18 13:33 christoph_s File Added: bad_cursor_placement.png
2006-12-18 16:07 avox Status new => assigned
2006-12-18 16:07 avox Assigned To => avox
2007-01-02 09:47 avox Status assigned => resolved
2007-01-02 09:47 avox Fixed in Version => 1.3.4cvs
2007-01-02 09:47 avox Resolution open => fixed
2007-01-05 00:03 jo-hannes Status resolved => feedback
2007-01-05 00:03 jo-hannes Resolution fixed => reopened
2007-01-05 00:03 jo-hannes Note Added: 0014532
2007-01-05 00:20 plinnell Note Added: 0014535
2007-01-05 01:59 avox Status feedback => resolved
2007-01-05 01:59 avox Resolution reopened => fixed
2007-01-05 01:59 avox Note Added: 0014548
2007-01-05 09:27 cbradney Status resolved => closed
2007-01-05 12:36 jo-hannes Status closed => feedback
2007-01-05 12:36 jo-hannes Resolution fixed => reopened
2007-01-05 12:36 jo-hannes Note Added: 0014562
2007-01-05 12:43 cbradney Note Added: 0014563
2007-01-05 13:05 jo-hannes Note Added: 0014564
2007-01-05 13:06 jo-hannes File Added: no cursor.png
2007-01-05 15:46 christoph_s Note Added: 0014569
2007-01-05 15:47 christoph_s File Added: cursor-after-cc.png
2007-01-05 23:32 avox Note Added: 0014595
2007-01-05 23:35 cbradney Status feedback => resolved
2007-01-05 23:35 cbradney Resolution reopened => fixed
2007-01-06 00:12 plinnell Status resolved => closed
2007-05-23 21:11 christoph_s Relationship added child of 0003157
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames