View Issue Details

IDProjectCategoryView StatusLast Update
0005372ScribusImport / Exportpublic2019-05-31 22:33
Reporterpeterh Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
PlatformLinuxOSGentoo LinuxOS Version
Product Version1.3.3.3 
Target VersionFixed in Version 
Summary0005372: tri-fold templates will print to three seperate pages
DescriptionProjects using a template that involves multiple pages printing to one concrete page export to several different pages, despite the appearance as one joined page in the editor. Working around this is unintuitive at best (resizing the pages, but not moving the content and then deleting the extra pages).
Steps To ReproduceCreate a tri-fold or four-fold document, and attempt to either print it or export it to PDF. In both cases, it is outputted as seperate pages, when they should be merged into one.
Tags#tobeclosed, discussion
Patch

Activities

louisdesjardins

2008-02-23 10:10

developer   ~0019051

I think it would be worth considering to simply let this feature as is in the development series 1.3.5 and remove it from the stable series 1.3.3.x. until we have the ability to print spreads. One goes with the other and having only half of the feature leads to confusion.

cbradney

2008-02-23 10:39

administrator   ~0019052

Stable is stable, it doesn't get removed from there.

louisdesjardins

2008-02-23 13:38

developer   ~0019054

Could we then consider to put a tooltip explaining what to expect and what not?

For instance, the naming itself, 3-fold, lead the users to think this is the way to lay out a pamphlet, while it isn't.

Ever since this feature is there I keep looking at it with some envy: it would be so great if it worked the way it is intended to work. But it is not and I have to learn to keep away from it because down the road it's going to be deceptive.

Don't get me wrong, and we discussed that on IRC, the feature itself is in its infancy. It is not yet ready for work because we miss the output possibilities, as I mentionned. But the idea itself is great. We mentionned the cover of a book, spine and back cover as a great example where this feature could shine.

louisdesjardins

2008-02-26 16:23

developer   ~0019095

Putting here some idea that arised from ML discussions.

I suggest we concentrate on the formulation of a tooltip that will make Scribus more usable and less frustrating when used to accomplish, like in this instance, a simple leaflet, which, after all, is a pretty common piece of work.

My first draft is as follow:

"Warning: Scribus cannot yet print pages side-by-side, also known as "spreads". Scribus prints/export only single pages, which is ok in most cases. If your layout needs to be printed/exported as a larger, single, page, made of 2, 3 or 4 pages put side by side, please use the Single page option instead to create your document (use the guides to help you in your design) or be prepared to use another software to assemble your pages downstream. A good example for which we suggest to use the Single page option is the very common letter-size (or A3) 3-fold leaflet."

It might be too verbose (in fact, it sure is). There are good souls around that could probably gather the spirit of this and put it in a shorter way.

I also question the naming of the options. I find that "3-fold" and "4-fold" too strongly and too clearly lead people to think that these are the options they should pick to layout a 3-panel leaflet, pamphlet, 3-fold... Z or U fold... which is not the case.

I suggest "Display 3-page spread" and "Display 4-page spread" better express, in my view, what the feature is or allows to do.

Any better suggestions?

louisdesjardins

2011-07-21 14:18

developer   ~0026624

Unless one of the following happens, it should be removed. It has no other usage than misleading people.

a) Change the label to reflect the reality and the expected behavior.
b) Enable 'Print as spread'

One of the first remarks we make in Scribus workshops while going through the 'New Document' menu is "don't use this feature". Then goes the long explanation.

ale

2011-07-21 21:13

manager   ~0026630

... and the next remark is: don't print, create first a pdf and then print it...

louisdesjardins

2011-07-21 21:32

developer   ~0026631

This bug was filed 07-Feb-20 (more than 4 years ago).

The status is "Acknowledged" meaning someone from the team went over it and decided that it was something worth considering to do. I support that.

It would be useful to have a (rough) estimate of what would be needed in terms of coding time to add this long-awaited feature to Scribus.

ale

2016-04-21 07:24

manager   ~0040360

this ticket can be probably closed, since threefold has been removed from 1.5.

in the future we might add again a multiple fold... but i think that indeed the three one is of little interest...

ale

2019-03-21 08:38

manager   ~0046029

three years later, i still think that this ticket should be closed...

Issue History

Date Modified Username Field Change
2007-02-20 06:03 peterh New Issue
2008-02-06 01:35 christoph_s Status new => acknowledged
2008-02-23 10:10 louisdesjardins Note Added: 0019051
2008-02-23 10:39 cbradney Note Added: 0019052
2008-02-23 13:38 louisdesjardins Note Added: 0019054
2008-02-26 16:23 louisdesjardins Note Added: 0019095
2011-07-21 14:18 louisdesjardins Note Added: 0026624
2011-07-21 21:13 ale Note Added: 0026630
2011-07-21 21:32 louisdesjardins Note Added: 0026631
2016-04-21 02:49 Kunda Tag Attached: discussion
2016-04-21 07:24 ale Note Added: 0040360
2016-04-21 07:25 ale Tag Attached: #tobeclosed
2019-03-21 08:38 ale Note Added: 0046029
2019-05-31 22:33 cbradney Assigned To => cbradney
2019-05-31 22:33 cbradney Status acknowledged => closed
2019-05-31 22:33 cbradney Resolution open => won't fix