View Issue Details

IDProjectCategoryView StatusLast Update
0005397ScribusPDFpublic2007-11-28 20:05
ReporterDalford Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformamd x86OSWindowsOS VersionWindows XP SP2
Product Version1.3.3.8 
Target VersionFixed in Version1.3.3.9cvs 
Summary0005397: data disappears in form field when tabbed to next field
Descriptionthe last time i reported this issue i was using windows 2000 and the pdf crashed the program. i noticed this event at that time on windows xp. one of the developers noticed that the pdf i sent in (ver 1.3.3.7) opened in acrobat 8, but would not allow you to type in text. i was told the issue was resolved.

the problem i had, before going back to version 1.3.3.5-1, was i could enter data into the form field, but when i tabbed to the next field, the data disappeared. if i clicked on that field again, the data was there, but when i tabbed to the next field again, the data would disappear.

i am using the full version of acrobat 5.0.5. i cannot afford to up grade, but i have no problem with version 1.3.3.5-1 of scribus.

what happened? everything changed in version 1.3.3.6 and i haven't been able to use any version higher than 1.3.3.5-1 with acrobat 5.

if you are not going to support acrobat 5, i accept your decision and will stay with 1.3.3.5-1; but i kinda feel cheated not being able to have the improvements.

i'm sorry to keep bringing this issue up, but i like scribus and would like the full experience, if you know what i mean.
Steps To Reproduceexport .sla file to pdf in screen/web, compression:zip, color profile:srgb iec61966-2.1.

open pdf and type in field then tab.
Additional Informationthis file crashed acrobat 5.0.5 in windows 2000. if you want the .sla let me know.
TagsNo tags attached.
Patch

Relationships

child of 0003831 acknowledged Metabug: PDF Forms 

Activities

2007-02-27 07:06

 

adg-receipt.pdf (90,935 bytes)

fschmid

2007-02-27 08:43

administrator   ~0015405

Have just tested your PDF in Acrobat Reader 7 + 5
Acrobat 7 works perfectly.
Acrobat 5 behaves weired, text field contents are disappearing after hitting Tab.
When i open the pdf with an hex editor and wipe out the (required) DA tag of the
textfield it works as expected ????

mhanski

2007-02-27 18:14

developer   ~0015412

Last edited: 2007-02-27 18:31

Dwain, don't feel cheated:) Judging by your related email, you're tied to Acrobat 5 (full version) solely due to it's capability of saving forms with form data. If yes, there is possibly a cure for you, namely Cabaret Stage 2.1 (commercial, free for personal usage). It's a Java application which allows to save PDF forms with included data. It's finally usable with Scribus forms after some initial teething problems, but thanks to fschmid and the cabaret guys they are over now, as far as I can tell. And surprise, your PDF form adg_receipt.pdf works very well with Cabaret, meaning I was able to fill and save it with data in Cabaret, and reopen it with data in Acrobat Reader 7.08.

I'd suggest, just give it a go: http://www.cabaret-solutions.com/en/products/stage/download

Just in case: if cabaret suits your taste and you encounter any troubles with
Scribus pdf forms, just report them to their bug tracker: http://www.cabaret-solutions.com/bugtracker/login_page.php -- the cabaret devs are highly responsive and removed 2 scribus forms's related bugs I'd reported to them very quickly. Don't forget to drop them a line they should go GPL:)

2007-02-27 18:23

 

adg-receipt_with_data_saved_with_cabaret.pdf (88,966 bytes)

2007-02-27 18:26

 

mhanski

2007-02-27 18:29

developer   ~0015413

Dwain: see also 2 files I've just attached

Issue History

Date Modified Username Field Change
2007-02-27 07:06 Dalford New Issue
2007-02-27 07:06 Dalford File Added: adg-receipt.pdf
2007-02-27 08:43 fschmid Note Added: 0015405
2007-02-27 09:53 mhanski Relationship added child of 0003831
2007-02-27 18:14 mhanski Note Added: 0015412
2007-02-27 18:23 mhanski File Added: adg-receipt_with_data_saved_with_cabaret.pdf
2007-02-27 18:26 mhanski File Added: dwains_form_with_data_in_cabaret.png
2007-02-27 18:29 mhanski Note Added: 0015413
2007-02-27 18:31 mhanski Note Edited: 0015412
2007-02-28 13:07 fschmid Status new => resolved
2007-02-28 13:07 fschmid Fixed in Version => 1.3.3.9cvs
2007-02-28 13:07 fschmid Resolution open => fixed
2007-02-28 13:07 fschmid Assigned To => fschmid
2007-11-28 20:05 mhanski Status resolved => closed