View Issue Details

IDProjectCategoryView StatusLast Update
0005530ScribusStylespublic2019-08-20 12:03
Reportermkoren Assigned Toale  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx86OSDebian LinuxOS VersionSarge/Etch
Product Version1.3.3.8 
Target Version1.6 milestoneFixed in Version1.5.5.svn 
Summary0005530: a style named "No Style" behaves wrong
DescriptionA style can be named "No Style", and then in the PP style list (for text), you see "No Style" listed twice, once for the real no style option and once for the style.

But if you apply the style to a frame, it works, but when you select it later the top "No Style" is highlighted in the list, not the proper entry for the style.

That might be all, or there could be deeper ramifications, its hard to tell for sure. I'd suggest in the future having a stronger difference between reserved options and user-created names than just an unlikely choice of name....
Steps To Reproduce1) Open Styles Menu
2) Create a new Paragraph Style called 'No Style' and save
3) Open a new text box on canvas
4) Go to PP > Text > Paragraph Style
Result: Duplicated 'No Styles'
TagsNo tags attached.
PatchNo

Activities

Kunda

2016-01-31 00:02

manager  

no-style.jpg (95,844 bytes)
no-style.jpg (95,844 bytes)

Kunda

2016-01-31 00:07

manager   ~0038498

Can reproduce on 1.5.1svn r20768 (OSX 10.10.5)

Suggest to disallow certain reserved style names like 'No Style'

ale

2019-08-20 12:03

manager   ~0046498

since avox removed the "no style", it's not possible anymore to have two times "No Style".

i've tried to cereate a "No Style" style and i did not see any glitch.

Issue History

Date Modified Username Field Change
2007-04-05 03:56 mkoren New Issue
2016-01-31 00:02 Kunda File Added: no-style.jpg
2016-01-31 00:05 Kunda Patch => No
2016-01-31 00:05 Kunda Steps to Reproduce Updated View Revisions
2016-01-31 00:07 Kunda Note Added: 0038498
2016-01-31 00:07 Kunda Status new => confirmed
2016-01-31 00:07 Kunda Target Version => 1.6 milestone
2016-01-31 00:08 Kunda Category General => Styles
2019-08-20 12:03 ale Assigned To => ale
2019-08-20 12:03 ale Status confirmed => closed
2019-08-20 12:03 ale Resolution open => no change required
2019-08-20 12:03 ale Fixed in Version => 1.5.5.svn
2019-08-20 12:03 ale Note Added: 0046498