View Issue Details

IDProjectCategoryView StatusLast Update
0005806ScribusPDFpublic2016-03-30 22:34
Reporteraceflinger Assigned To 
Status newResolutionopen 
Platformx86 IntelOSWindows 2000OS VersionProfessional
Product Version1.3.3.9cvs 
Target Version1.6 milestone 
Summary0005806: PDFs generated using export aren't always reliably searchable in Acrobat reader in certain conditions
DescriptionTitle was:
PDF's generated using export are not searchable in Acrobat reader
Unable to search text in pdf's generated by Scribus pdf export.

Tags#please_test, acrobat


has duplicate 0007820 closedjghali Cannot suppose the document of Chinese Characters export to PDF 
has duplicate 0010612 closedjghali Cannot select text in exported pdf file 



2008-02-06 00:20

administrator   ~0018839

Can you try again with Please also look in the font tab of the PDF export dialog: If you use OTF fonts, they will be converted to outlines.


2010-06-29 21:44

reporter   ~0024270

I am having the same problem in 1.3.6

I am trying some work-arounds and will report my findings


2010-06-30 00:07

reporter   ~0024272

OK, I tried my work arounds, even loaded 1.3.7 and tried. NO searchable PDF's. I DID download the sample chapter of the manual (assuming it was generated with Scribus) and Acrobat 6.0 and 9.3 readers will NOT find a single word in the sample.

This is not good for me. I mistakenly assumed the PDF's I was generating were going to be searchable. I may have to go back and try to bookmark key points to allow my readers to use the search feature of their readers. I hope this issue is solved soon. The key point (to me) of PDF's is their "searchability", the ability to find the textual needle in the haystack of the document.


2010-06-30 00:37

reporter   ~0024273

OK, I am eating a little crow right now. Reader 9.3 will find TEXT, just not NUMERALS. I deal with alot of numbers, as in part numbers and that was the basis of my test searches. Scribus ,1.3.7 exported to PDF will now find text strings, just not numerals nor alphanumeric strings.


2012-02-28 17:36

reporter   ~0027766

I kind'a get a different result, I cannot outline the fonts (TTF & OTF) onto the PDF output: the "Embed All" and "Outline All" produce the same embedded-font results, but on the window "Save as PDF -> Fonts" it is impossible to place fonts into the "Fonts to embed:" pane, they always jump to the other pane below (Fonts to outline:).

If not embedding nor outlining is selected, the resulting PDF uses whatever font my PDFX reader supplies: just the way it should be.

In all cases, all PDF's are fully searchable.

Scribus Version 1.4.1svn
23 January 2012
Build ID: C-*-T-*-C1.8.6-Windows
Using Ghostscript version 9.00


2012-02-29 02:29

reporter   ~0027768

I've had similar issues with Scribus v1.4 for Windows. I find that I am unable to fill out forms or select text when using Adobe Reader. However the same document works ok in Nuance PDF Reader. Nuance PDF Reader appears to over-ride some PDF restrictions that Adobe impose. Adobe appears to treat the document as read-only with no option to select text either. If I try printing the document, it causes Adobe Reader 10.1.2 to crash. There is apparently a known issue and a patch for Adobe to prevent the crash, but I've never had this issue before until I created a PDF file from Scribus.


2014-03-06 15:58

reporter   ~0031466

I could not embed Arial under Windows 8 x64 and Windows 7 x64 with Scribus 1.4.3 each, too. It's reproducable in a fresh document. In Windows XP I never got problems with an old document I perfectly used in 2011, 2012 and 2013. Now I can even reproduce this under Windows XP x32. So it must be Scribus 1.4.? I guess.

I can embed Arial in PDF export settings each while deactivating "Subset" in Font Preferences but the PDF is actually produced with outlines (no fonts at all listed in two PDF readers). For eg. Myriad Pro it works. Really a total show stopper for web documents. PDF printer driver didn't work either. Giving up.

Here's a forum thread regarding Windows 8: Seems that it works in Windows 7 and 1.4.3 for some people.

I hope I'm on the correct issue.


2016-03-30 22:31

updater   ~0039596

This needs to be tested again.

Issue History

Date Modified Username Field Change
2007-06-01 12:09 aceflinger New Issue
2008-02-06 00:20 christoph_s Note Added: 0018839
2009-02-23 15:12 jghali Relationship added has duplicate 0007820
2010-06-29 21:44 sfureman Note Added: 0024270
2010-06-30 00:07 sfureman Note Added: 0024272
2010-06-30 00:37 sfureman Note Added: 0024273
2012-02-28 13:27 jghali Relationship added has duplicate 0010612
2012-02-28 17:36 Thaddeus Note Added: 0027766
2012-02-29 02:29 harris_da Note Added: 0027768
2014-03-06 15:58 frankbi Note Added: 0031466
2015-05-25 03:40 Kunda Patch => No
2015-05-25 03:40 Kunda Target Version => 1.6 milestone
2016-03-30 22:25 Kunda Tag Attached: acrobat
2016-03-30 22:30 Kunda Summary PDF's generated using export are not searchable in Acrobat reader => PDFs generated using export aren't always reliably searchable in Acrobat reader in certain conditions
2016-03-30 22:30 Kunda Description Updated
2016-03-30 22:31 Kunda Note Added: 0039596
2016-03-30 22:34 Kunda Tag Attached: #please_test