View Issue Details

IDProjectCategoryView StatusLast Update
0006205ScribusGraphics / Image Framespublic2017-01-20 22:10
Reportermarkus_meier Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacBook ProOSGentoo LinuxOS Versionx86/2006.1
Product Version1.3.3.9cvs 
Target VersionFixed in Version1.5.3.svn 
Summary0006205: Update Image ignores change of resolution in image
DescriptionIf I import a picture into an image frame and later change the resolution of the picture in an external program (e.g. The GIMP), the "Update Image" command in the picture frame context menu ignores the change.
Steps To Reproduce1) Start Scribus
2) Draw an image frame and import a picture (I am using pictures in PNG format)
3) Do not close Scribus
4) Open the picture in The GIMP, select Image->Scale Image and change the resolution of the picture and save.
4) Switch to Scribus, right click on the image frame and select "Update Image".

The size of the image does not change...
Additional InformationScribus reports version 1.3.3.9 not 1.3.3.9cvs, but I can't select this version in the combobox above.
TagsNo tags attached.
Patch

Relationships

has duplicate 0006426 closed Image resolution not updated when reloading image 

Activities

christoph_s

2007-09-07 21:38

administrator   ~0017275

What are the settings you use for images in the properties palette?

markus_meier

2007-09-07 22:28

reporter   ~0017276

Image properties:
Free Scaling on
X-Pos 0.0 cm
Y-Pos 0.0 cm
X-Scale 100.0%
Y-Scale: 100.0%
Actual X-DPI: 350.0
Actual Y-DPI: 350.0
(DPI setting is set when I import the image with "Get Image")
X-Scale and Y-Scale linked
Scale to Frame Size: off
Proportional: on (greyed, cannot be changed)

christoph_s

2007-09-07 22:31

administrator   ~0017277

>>Free Scaling on

This means you set the scaling. Why do you expect Scribus to update if the external image has been rescaled? It makes no sense.

markus_meier

2007-09-07 22:47

reporter   ~0017278

Because the scale does change when I import another image with a different scaling into that frame. So I was not aware of that option.

Anyway, I am trying to uncheck the "Free Scaling" check box as you suggest, however it remains on, whatever I do.

christoph_s

2007-09-07 23:51

administrator   ~0017279

If you want to rescale the image to the new dimensions, right click and use "Scale frame to image".

markus_meier

2007-09-07 23:55

reporter   ~0017280

I guess, some more explanation is required. I can set two modes in the image properties palette:
1) "Free Scaling" - according to the on-screen help "Allow the image to be a different size to the frame"
or
2) "Scale to Frame Size"

I don't want 2); I want 1) i.e. to allow the image to be different size to the frame, but I do not want to set a scale different from the one stored in the image.

A reasonable behaviour for the "Update Image" function would be to reset the scale the image has in scribus to the scale stored in the image, but only in the case when the size or the DPI setting stored in the image was changed compared to the scale it had when it was originally imported. This would, however, require to store the original scale and size somewhere in the scribus document.

Kunda

2016-05-28 05:37

updater   ~0041493

guys, what's the verdict on this?

Kunda

2016-12-16 21:22

updater   ~0043071

fixed in 1.5.3svn thanks to william in 0008753
Resolving

Issue History

Date Modified Username Field Change
2007-09-07 21:30 markus_meier New Issue
2007-09-07 21:38 christoph_s Note Added: 0017275
2007-09-07 22:28 markus_meier Note Added: 0017276
2007-09-07 22:31 christoph_s Note Added: 0017277
2007-09-07 22:47 markus_meier Note Added: 0017278
2007-09-07 23:51 christoph_s Note Added: 0017279
2007-09-07 23:55 markus_meier Note Added: 0017280
2007-10-28 17:35 christoph_s Relationship added has duplicate 0006426
2015-09-17 20:10 Kunda Category Graphics / Image Frames => Graphics/Img Frames
2015-09-17 20:11 Kunda Category Graphics/Img Frames => Graphics / Image Frames
2016-05-28 05:36 Kunda Tag Attached: discussion
2016-05-28 05:37 Kunda Note Added: 0041493
2016-12-16 21:22 Kunda Status new => resolved
2016-12-16 21:22 Kunda Resolution open => fixed
2016-12-16 21:22 Kunda Fixed in Version => 1.5.3.svn
2016-12-16 21:22 Kunda Note Added: 0043071
2016-12-16 21:22 Kunda Tag Detached: discussion
2017-01-20 22:10 cbradney Status resolved => closed