View Issue Details

IDProjectCategoryView StatusLast Update
0006573ScribusImport / Exportpublic2016-04-24 12:52
Reporterblazej_new Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
PlatformLinuxOSUbuntuOS Version7.10
Product Version1.3.3.10svn 
Target VersionFixed in Version 
Summary0006573: Some styles imported from OpenOffice loose their names
DescriptionWhen I import text documents from OpenOffice 2.3.0, in most cases at least one name of a style (sometimes - two) gets replaced in Scribus with something generic like "Footnote". All the other style names are imported properly.
TagsODF
Patch

Relationships

related to 0013766 new ODT Importer creates extraneous styles 
related to 0013772 new ODT Document importer doesn't understand all styles 
related to 0011157 closedfschmid Import of ODT should use "display name" of style 
child of 0012496 acknowledged Metabug: Marks & Footnotes & Weld (1.5.0.svn) 

Activities

cbradney

2007-12-10 07:49

administrator   ~0018241

Please upload a sample OO.org and Scribus document showing this behaviour

cbradney

2007-12-12 20:36

administrator   ~0018266

I will resolve this as unable to reproduce if a sample document is not uploaded within a few days, so please upload one.

2007-12-13 17:05

 

styles-test.odt (7,191 bytes)

2007-12-13 17:05

 

styles-test.sla (46,582 bytes)

blazej_new

2007-12-13 17:07

reporter   ~0018280

The ODT file has three custom named styles. After importing into Scribus, the document has only two, and one of them is named "default".

OpenDocument Importer Options:
Overwrite Paragraph Styles: ON
Merge Paragraph Styles: ON
the other two: OFF

Kunda

2016-01-14 16:36

manager   ~0038158

I uploaded what 10.10.5 1.5.1svn r20681 shows. Not sure if this issue is still happening or I may be misunderstanding the ticket.

Kunda

2016-01-14 16:38

manager  

Kunda

2016-04-23 12:52

manager   ~0040403

@Ben can you test and review this ticket. It may be a duplicate.

Ben

2016-04-24 05:03

reporter   ~0040426

The problems in the original report no longer occur in the way reported. It was not a frivolous report, but the importer used by blazej_new has been replaced and this ticket is no longer the best description available of the new importer's shortcomings.

Specifically, (1) All three of the reporter's custom styles are imported by modern Scribus, so that part is fixed. (2)The problem with unexpected style names being imported is better described in its current form by 0013766, so that part can be considered a duplicate.

The OpenOffice input file supplied by blazej_new should probably be retained for testing any fixes to 0013766 and 0013772. It was produced by a truly ancient version of OO and I saw some things within its XML that could cause trouble for an unwary importer. I'm not sure how to replicate them if I were creating a new testing file.

My advice would be to close this ticket with apologies for the 8 year wait and the fervent hope that the new importer will be perfected soon.

Hope this helps.

Kunda

2016-04-24 12:52

manager   ~0040436

Thanks @Ben for the elaborate and thoughtful assessment.
Closing this ticket due to issues have either been fixed or duplicated in other tickets (0013766 and 0013772)

hat tip to blazej_new for filing ticket and thanks for your understanding about open source timelines. We're working on it, slow and steady.

Thanks again @Ben

Issue History

Date Modified Username Field Change
2007-12-10 04:06 blazej_new New Issue
2007-12-10 07:49 cbradney Note Added: 0018241
2007-12-12 20:36 cbradney Note Added: 0018266
2007-12-13 17:05 blazej_new File Added: styles-test.odt
2007-12-13 17:05 blazej_new File Added: styles-test.sla
2007-12-13 17:07 blazej_new Note Added: 0018280
2007-12-13 19:46 christoph_s Status new => confirmed
2015-11-13 01:43 Kunda Relationship added child of 0012496
2015-11-25 05:08 Kunda Relationship added related to 0011157
2016-01-14 16:36 Kunda Note Added: 0038158
2016-01-14 16:38 Kunda File Added: Screen Shot 2016-01-14 at 10.35.08 AM.png
2016-02-23 12:42 Kunda Relationship added related to 0013766
2016-02-23 12:43 Kunda Tag Attached: ODF
2016-04-23 12:52 Kunda Note Added: 0040403
2016-04-24 05:03 Ben Note Added: 0040426
2016-04-24 12:46 Kunda Relationship added related to 0013772
2016-04-24 12:52 Kunda Note Added: 0040436
2016-04-24 12:52 Kunda Status confirmed => closed
2016-04-24 12:52 Kunda Resolution open => not fixable