View Issue Details

IDProjectCategoryView StatusLast Update
0006877ScribusScripterpublic2009-03-29 21:01
Reportergpittman Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.3.3.12svn 
Target Version1.3.3.13Fixed in Version1.3.3.13svn 
Summary0006877: trying to clean up and standardize the DocInfo in scripts
Descriptionhave developed a pattern to use for scripts for author(s), licensing, synopsis, requirements, usage.
Additional InformationWill gradually try to get all scripts that need this uploaded as they are completed. No changes in script behavior are being made here.
TagsNo tags attached.
Patch

Activities

2008-03-22 01:42

 

ExtractText.py (2,449 bytes)

2008-03-22 01:43

 

UnflipContent.py (1,714 bytes)

2008-03-22 02:33

 

DrawGrid.py (5,542 bytes)

gpittman

2008-03-22 02:34

developer   ~0019258

for DrawGrid.py added a new category: LIMITATIONS

gpittman

2008-03-22 14:27

developer   ~0019260

Will add DirectImageImport.py
This one also needed some fixes for 1.3.3.x -- file dialog did not appear.
Also changed "from scribus import *" to "import scribus"

2008-03-22 14:28

 

DirectImageImport.py (3,028 bytes)

gpittman

2008-03-22 14:38

developer   ~0019261

Someone please delete InfoBox.py so I can change to the file dialog to select more image types.
Also, would it be useful to adopt Konrad Stania's work around for Adjust Frame to Image using image scaling? I think that's pretty clever.

gpittman

2008-03-22 19:10

developer   ~0019265

Ok, I've modified the script to automatically adjust infobox height for images. Waiting for InfoBox.py to be deleted so I can upload the new version.

2008-03-22 23:08

 

InfoBox.py (8,499 bytes)

gpittman

2008-03-22 23:09

developer   ~0019269

New InfoBox.py uploaded

cbradney

2009-02-22 23:08

administrator   ~0021197

[00:07] <MrB> FeistyDragoon, can u please check 0006877 and the included scripts in 1.3.3.x svn? the bug has been resolved however I dont believe the files were ever updated from the bug into svn
[00:07] <FeistyDragoon> k
[00:07] <MrB> FeistyDragoon, and if u have 1.3.5svn compatible versions, add those too?

gpittman

2009-02-23 00:08

developer   ~0021199

Yes, you are right, MrB.
Either these weren't updated or were reverted. The exception is InfoBox.py, which is the correct one in both 1.3.3.xsvn and 1.3.5svn.

I think we may have decided to delete DrawGrid.py, since it was not felt to be such an especially useful script.

I will have to check to see if the others work in 1.3.5svn.

gpittman

2009-02-23 00:26

developer   ~0021201

ExtractText.py seems to work Ok in 1.3.5svn.

UnFlipContent.py does not work in 1.3.5svn -- will see if I can figure out why.

gpittman

2009-02-23 00:50

developer   ~0021202

DirectImageImport.py does indeed work in 1.3.5.py, and curiously when the image is imported, Proportional is set, while it isn't in 1.3.3.xsvn (maybe different default behavior).

This having been said, the script is a bit clumsy in the way it adjusts the size of the frame to the image. It would be better, I think, to use the PIL method I used in InfoBox.py. This way, you can center every picture. Right now, they don't get centered when the picture is taller than it is wide.

Will work on this.

gpittman

2009-03-28 14:29

developer   ~0021432

I have reworked DirectImageImport.py (DirectImageImport_mod.py).
1. Use PIL to get image size
2. Fix a problem with frames when image taller than wide
3. Got rid of readjustment of frame size - no longer needed
4. Made Doc Info more informative

This also works in 1.3.5svn

2009-03-28 14:29

 

DirectImageImport_mod.py (3,075 bytes)

gpittman

2009-03-28 15:45

developer   ~0021433

I cannot seem to get UnFlipContent.py to work in 1.3.5svn.

I think the problem is with setProperty, which seems to be nonfunctional in 1.3.5svn.

gpittman

2009-03-28 15:55

developer   ~0021434

Summary:

1. Except for InfoBox.py, the above scripts have not been added to current svn of 1.3.3.x and 1.3.5
2. DrawGrid.py is not felt to be needed in either version
3. ExtractText.py needs to be replaced by above version in both versions
3. DirectImageImport.py should be replaced by DirectImageImport_mod.py in both versions
4. UnFlipContent.py does not work in 1.3.5svn, so should not be included in that version at this time, but can replace it in 1.3.3.x

Issue History

Date Modified Username Field Change
2008-03-22 01:42 gpittman New Issue
2008-03-22 01:42 gpittman File Added: ExtractText.py
2008-03-22 01:43 gpittman File Added: InfoBox.py
2008-03-22 01:43 gpittman File Added: UnflipContent.py
2008-03-22 01:45 christoph_s Status new => assigned
2008-03-22 01:45 christoph_s Assigned To => plinnell
2008-03-22 02:33 gpittman File Added: DrawGrid.py
2008-03-22 02:34 gpittman Note Added: 0019258
2008-03-22 14:27 gpittman Note Added: 0019260
2008-03-22 14:28 gpittman File Added: DirectImageImport.py
2008-03-22 14:38 gpittman Note Added: 0019261
2008-03-22 19:10 gpittman Note Added: 0019265
2008-03-22 20:23 plinnell File Deleted: InfoBox.py
2008-03-22 23:08 gpittman File Added: InfoBox.py
2008-03-22 23:09 gpittman Note Added: 0019269
2009-01-01 21:58 plinnell Status assigned => resolved
2009-01-01 21:58 plinnell Fixed in Version => 1.3.3.13svn
2009-01-01 21:58 plinnell Resolution open => fixed
2009-02-22 23:08 cbradney Assigned To plinnell =>
2009-02-22 23:08 cbradney Note Added: 0021197
2009-02-22 23:08 cbradney Status resolved => feedback
2009-02-22 23:08 cbradney Resolution fixed => reopened
2009-02-23 00:08 gpittman Note Added: 0021199
2009-02-23 00:26 gpittman Note Added: 0021201
2009-02-23 00:50 gpittman Note Added: 0021202
2009-03-15 01:36 christoph_s Target Version => 1.3.3.13
2009-03-28 14:29 gpittman Note Added: 0021432
2009-03-28 14:29 gpittman File Added: DirectImageImport_mod.py
2009-03-28 15:45 gpittman Note Added: 0021433
2009-03-28 15:55 gpittman Note Added: 0021434
2009-03-29 20:22 cbradney Status feedback => assigned
2009-03-29 20:22 cbradney Assigned To => cbradney
2009-03-29 20:59 cbradney Status assigned => resolved
2009-03-29 20:59 cbradney Resolution reopened => fixed
2009-03-29 21:01 cbradney Status resolved => closed