View Issue Details

IDProjectCategoryView StatusLast Update
0007351ScribusPDFpublic2015-07-26 05:52
ReporterPancho Assigned Toavox  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSKubuntuOS VersionHardy Heron
Product Version1.3.5svn 
Target VersionFixed in Version1.5.1svn 
Summary0007351: PDF export: : fonts cannot be outlined anymore
DescriptionThis bug may sound similar to the "font subsetting doesn't work, so the font is outlined" issues, but rather it is the opposite, and it's new in the 1.3.5 branch:

When exporting a document to PDF for pre-press, I want all fonts to be outlined rather than embedded. While the dialog box allows me to do so, the newly created PDF file in fact has all fonts embedded (tested in acroread: File > Properties > Fonts).
In 1.3.3 versions this worked well. I reproduced it with new files as well as converted 1.3.3 files, with both TTF and Type1 fonts and with PDF 1.3 - 1.5 and PDF/X3 settings. The File > Document Setup > Fonts settings don't help either.
Steps To ReproduceCreate a simple document with some text.
Go to File -> Export -> Save as PDF and switch to the Fonts tab.
Click on the "Outline all" button. Now all fonts are to be outlined and none to be embedded.
"Save" this.

Now open the newly created PDF file in the Acrobat Reader, and go to File > Properties.
In the "Fonts" tab, the embedded fonts are listed where there should be none.
Also, in the PDF file the text can be marked with the text tool.
Additional InformationThis is a major problem for generating PDFs for Printshops that don't accept PDFs with embedded fonts.
TagsNo tags attached.
PatchNo

Relationships

has duplicate 0007637 closedjghali PDF Export: font outlining doesn't work 

Activities

BAlpha

2008-09-03 11:57

reporter   ~0020197

Newer Scribus versions (starting with 1.3.4 or 1.3.5, I don't know for sure) do the "outlining" by converting the font to a PS Type 3 font, unlike the 1.3.3.x branch that (afaik) used XObjects. This is probably a good optimization; and I can't imagine a print shop that does not accept embedded Type 3 fonts (which have been around long before anybody even imagined TrueType).

ale

2010-04-28 10:32

manager   ~0023845

Last edited: 2010-04-29 13:55

View 2 revisions

two questions:

- is there really no reason for scribus being able to really outline fonts on pdf export?
- afaik, all the technology for doing it, is already in scribus (or was in the codebase): is it that hard to bring it back?

i fear that there are enough print shops around who will do everything to screw the fonts in your pdf and there are people who don't have a chance to switch print shop...

being able to outline fonts export may simplify the communication with crappy print shops (the ones who will open your pdfs with photoshop and print from there...)


conclusion:
can we get that feature back or see this bug close as meaningless (with an explanation on why it's meaningless)?

XmainframeX

2010-10-27 11:12

reporter   ~0024745

Question 1: I also know a print shop which doesn't allow any pdf which shows any kind of embedded fonts.

The only workaround to achieve "real" outlining I found is to convert text to outlines manually. Beside the fact that selecting all text fields for this and moving all dynamic text (page numbers) from master pages to the actual document is quite uncomfortable, this does not work because hidden characters like automatic hyphens are not converted using this method.

So in fact there is no workaround for this and scribus is unfortunately not usable with such print shops at the moment - so not being able to do real outlining is critical for some users...


Question 2: No idea... - hopefully...


Conclusion: This feature is definitely not meaningless... - there should at least be a usable workaround!

aliB

2010-10-28 08:12

reporter   ~0024749

One possible solution could be to add the outline function to the scripter api.
It would be very easy to write a script which converts every text to outlines.

XmainframeX

2010-10-29 16:40

reporter   ~0024759

If this would be solved with the scripter api, I have two more questions:

1. What would happen to text on master pages?
2. Is the problem with the dropped automatic hyphens during the text-to-outline conversion already fixed (up to 1.3.9 it was not)? Is the text-to-outline-conversion probably even intended to drop hidden characters?

Tino Schwarze

2012-08-29 10:27

reporter   ~0028885

I've just had a online printing shop reject a PDF because of the embedded Type3 outlined fonts (and I found it very counter-intutitive to select "outline" and get a PDF with fonts in it).

An option to get real font outlining would be great! Or at least do not call it "outlining" if it's actually "converting to Type3".

lvlinux

2012-10-02 20:18

reporter   ~0029009

Me too - in fact it was LSI (Lightning Source) - one of the bigger printers in the US. I have a TTF font that I need outlined, and LSI rejected my PDF/X-1a file because they said that the Type 3 "outlined" font in my PDF was causing a problem with their system.

I would like a selector (maybe in the Document properties' Fonts area) to choose between true outlining of fonts and the Type 3 conversion that is currently being done.

rbckman

2012-11-22 15:07

reporter   ~0029254

My PDF also rejected by the print shop because of Type 3 font. Would be great to have a real convert to vectors option!

jghali

2015-05-24 17:05

administrator   ~0035213

In 1.5.1.svn the font options in PDF export dialog have been modified and it's now possible to explicitly outline fonts.

Kunda

2015-07-26 05:52

manager   ~0035902

closing and assigned to avox since, and correct me if I'm wrong, he coded the changes to the PDF Export Menu, right?

Issue History

Date Modified Username Field Change
2008-09-01 20:48 Pancho New Issue
2008-09-03 11:57 BAlpha Note Added: 0020197
2008-11-29 19:51 jghali Relationship added has duplicate 0007637
2010-04-28 10:32 ale Note Added: 0023845
2010-04-29 13:55 ale Note Edited: 0023845 View Revisions
2010-10-27 11:12 XmainframeX Note Added: 0024745
2010-10-28 08:12 aliB Note Added: 0024749
2010-10-29 16:40 XmainframeX Note Added: 0024759
2012-08-29 10:27 Tino Schwarze Note Added: 0028885
2012-10-02 20:18 lvlinux Note Added: 0029009
2012-11-22 15:07 rbckman Note Added: 0029254
2015-05-24 17:05 jghali Note Added: 0035213
2015-05-24 17:05 jghali Status new => resolved
2015-05-24 17:05 jghali Fixed in Version => 1.5.1svn
2015-05-24 17:05 jghali Resolution open => fixed
2015-05-24 17:05 jghali Assigned To => jghali
2015-05-24 17:06 jghali Patch => No
2015-05-24 17:06 jghali Summary PDF export: fonts are always embedded => PDF export: : fonts cannot be outlined anymore
2015-07-26 05:52 Kunda Note Added: 0035902
2015-07-26 05:52 Kunda Status resolved => closed
2015-07-26 05:52 Kunda Assigned To jghali => avox