View Issue Details

IDProjectCategoryView StatusLast Update
0007741ScribusScripterpublic2016-05-15 22:53
ReporterPander Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Product Version1.3.5svn 
Target VersionFixed in Version 
Summary0007741: Provide a way to run Scribus script from PyDev in Eclipse
DescriptionProvide a way to run Scribus script from PyDev in Eclipse
Steps To Reproduce1) sudo aptget install eclipse-pydev
2) load a (working) Scribus script like FontSample.py
3) run or debug the script

Result is:

This Python script is written for the Scribus scripting interface.
It can only be run from within Scribus.

Scribus should allow running the script in run or debug mode via PyDev in Eclipse.
Additional InformationPerhaps a special PyDev project needs to be created that can hook into Scribus, or only a special Python script that can load the Scribus script can do the job and run of debug that inside PyDev.
TagsNo tags attached.
Patch

Relationships

related to 0012572 closedcbradney [patch] Add a --python-script command line option to run a script and exit 

Activities

Pander

2009-01-21 13:35

reporter   ~0020949

Good news, code completion already works in PyDev.

Pander

2009-01-21 14:06

reporter   ~0020952

See also https://sourceforge.net/tracker/index.php?func=detail&aid=2526239&group_id=85796&atid=577332

Pander

2009-01-21 15:30

reporter   ~0020955

Starting Scribus via command line and have it automatically run a specified Scribus script will be a nice intermediate solution.

Kunda

2014-09-13 15:18

manager   ~0033667

See 0012572

ale

2014-09-15 09:38

manager   ~0033700

i have a workaround for this:

https://github.com/aoloe/scribus-script-repository/blob/master/typographic-grid/typographic-grid.py

if the "scribus" api, just load a fake api that does nothing. that way you can test the algorithms in your script from the command line.

if there is interest, i can publish a more general python library for it.

Pander

2014-09-15 09:44

reporter   ~0033701

Personally I have moved away from Eclipse and Scribus for the moment.

Kunda

2016-05-01 00:51

manager   ~0040661

Resolving due to lack of interest.

Issue History

Date Modified Username Field Change
2009-01-21 13:34 Pander New Issue
2009-01-21 13:35 Pander Note Added: 0020949
2009-01-21 14:06 Pander Note Added: 0020952
2009-01-21 15:30 Pander Note Added: 0020955
2009-01-21 16:25 jghali Severity major => feature
2014-09-13 15:17 Kunda Relationship added related to 0012572
2014-09-13 15:18 Kunda Note Added: 0033667
2014-09-15 09:38 ale Note Added: 0033700
2014-09-15 09:44 Pander Note Added: 0033701
2016-05-01 00:51 Kunda Note Added: 0040661
2016-05-01 00:51 Kunda Status new => resolved
2016-05-01 00:51 Kunda Resolution open => no change required
2016-05-01 00:51 Kunda Assigned To => Kunda
2016-05-01 00:51 Kunda Assigned To Kunda =>
2016-05-15 22:53 cbradney Status resolved => closed