View Issue Details

IDProjectCategoryView StatusLast Update
0007787ScribusColor Managementpublic2014-07-14 17:04
Reporterfaceman Assigned To 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformPCOSubuntuOS Version8.10
Product Version1.3.5svn 
Target VersionFixed in Version 
Summary0007787: Hang on startup when sshfs connection open in home dir
DescriptionWhen I have an sshfs connection open in a directory in my home dir, Scribus "hangs" while looking for color profiles (I assume it's actually searching the sshfs dir, as the readout on the terminal shows multiple files from the share having been checked as profiles).
Steps To ReproduceConnect a directory in your home dir to an ssh account using sshfs, start Scribus. (It may only happen if the ssh account has lots of files/directories).
TagsNo tags attached.
Patch

Activities

subik

2009-02-11 14:02

manager   ~0021106

where exactly did you mount your sshfs dir? Does it freeze with any sshfs mounted?

cbradney

2009-02-11 23:28

administrator   ~0021107

I dont think we have any way of checking if a dir is local or remote once it is mounted.

faceman

2009-02-12 01:03

reporter   ~0021108

It was mounted at /home/<home>/sshfs/

Does lcms poll every directory in <home> for possible profiles? That seems a bit extreme if it is true. If it is not, I'd say this is a bug.

I tried today from a different box and it didn't do the same thing, but it was also with a different mount.

jghali

2009-02-12 07:54

administrator   ~0021109

On Linux, scribus search for icc profiles in following directories :
home_path/color/icc
home_path/.color/icc
/usr/share/color/icc
/usr/local/share/color/icc
That's all

subik

2009-02-12 08:14

manager   ~0021110

Last edited: 2009-02-12 08:14

facema, can you try to run scribus under strace in terminal, please? It could help a bit (let's hope).

strace path/to/scribusexecutable/.../scribus

Then look into its output and/or send it here.

Kunda

2014-07-08 03:39

updater   ~0032570

faceman, please follow-up. Can you still reproduce this?

Issue History

Date Modified Username Field Change
2009-02-11 12:40 faceman New Issue
2009-02-11 14:02 subik Note Added: 0021106
2009-02-11 23:28 cbradney Note Added: 0021107
2009-02-12 01:03 faceman Note Added: 0021108
2009-02-12 07:54 jghali Note Added: 0021109
2009-02-12 08:14 subik Note Added: 0021110
2009-02-12 08:14 subik Note Edited: 0021110
2014-07-08 03:39 Kunda Note Added: 0032570
2014-07-08 03:39 Kunda Status new => feedback
2014-07-08 03:51 Kunda Priority normal => low
2014-07-08 03:51 Kunda Severity major => minor
2014-07-14 17:04 FirasH Status feedback => closed
2014-07-14 17:04 FirasH Resolution open => unable to reproduce