View Issue Details

IDProjectCategoryView StatusLast Update
0008018ScribusStory Editor / Text Framespublic2009-05-08 04:23
ReporterJohn Jason Jordan Assigned Tojghali  
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS VersionJaunty x86_64
Product Version1.3.5svn 
Target VersionFixed in Version 
Summary0008018: Right justify leaves a space in frame on master page
DescriptionI have a left and a right master page. On each is a frame for the page number. The one on the right master page has the page number # character at the right margin of the frame. It looks fine in Master Pages view, but on right side pages the number appears about five or six points to the left of the right margin.
Steps To Reproduce1) Create a document with left and right facing pages.
2) Set up a master page for each.
3) On each master page place a text frame the width of the margins. Leave the one on the left master page at left justified, and right justify the frame on the right master page. Insert the page number # character in each frame.
Alternative: Instead of right justifying the frame on the right side master page, go into Story Editor and right justify the text.
4) Go back to normal view and look at some right side pages to which the right side master page has been applied. The number will not appear all the way to the right. It will appear as though there was a space between the number and the right edge of the frame on the master page.
Additional InformationIn Story Editor with the text from the right side master page frame open, note that there is a blinking cursor underneath the page number # character at the right of the window. You can backspace from in front of it so the cursor is on the line containing the page number. But if you update the text frame and exit Story Editor, when you relaunch Story Editor the cursor is back on the line below the line with the page number on it.

It is as though there is a phantom space at the end of the line that the user cannot delete.
TagsNo tags attached.
Patch

Activities

jghali

2009-05-08 02:04

administrator   ~0021692

Please upload sample document. Unable to reproduce

John Jason Jordan

2009-05-08 02:25

reporter   ~0021693

Uploading Workbook4.sla. It may gripe about missing a couple of linked graphics. Also it needs Junicode and Freeserif Medium fonts. The problem master page is Normal Right. The other master pages either have no page number or the number is centered.

John Jason Jordan

2009-05-08 02:29

reporter   ~0021694

Sorry, after 15 minutes I cannot get a response from bugs.scribus.net. Will try to upload the file later.

John Jason Jordan

2009-05-08 03:10

reporter   ~0021696

All right, I found the source of the problem.

I had created the frame containing the page number on the left side master page first. Then I copied and pasted it to the right side master page, and set it to right justified. No matter what I did with that frame, including clearing all text and reentering the page number, I could not get rid of the space on the right side. The other issues that I reported above were always reproducible.

Since jghali and someone else on the e-list could not reproduce the problem, I started a new document. I was also not able to reproduce the problem in the new document.

Therefore, clearly there was something in my document that was causing the problem. I went back to the document and deleted the frame on the right side master page. Then I created a new one to replace it. This one is now working fine.

This led me to conclude that there may be an obscure bug related to copying and pasting frames from one master page to another, since that is how I created the evil right-side frame in the first place. But the docment was started a couple months ago when I was using an earlier svn version. That it works now with the beta leads me to believe that whatever caused the problem has been fixed.

Please mark this issue as resolved.

Issue History

Date Modified Username Field Change
2009-05-08 00:18 John Jason Jordan New Issue
2009-05-08 02:04 jghali Note Added: 0021692
2009-05-08 02:25 John Jason Jordan Note Added: 0021693
2009-05-08 02:29 John Jason Jordan Note Added: 0021694
2009-05-08 03:10 John Jason Jordan Note Added: 0021696
2009-05-08 04:23 jghali Status new => resolved
2009-05-08 04:23 jghali Resolution open => no change required
2009-05-08 04:23 jghali Assigned To => jghali
2009-05-08 04:23 jghali Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames