View Issue Details

IDProjectCategoryView StatusLast Update
0008926ScribusGeneralpublic2014-07-03 15:34
Reporterdavenz Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionopen 
Platformx64OSOpenSolarisOS Versionsnv_133
Product Version1.3.6svn 
Target VersionFixed in Version 
Summary0008926: Cannot save .sla files in newly-created projects on OpenSolaris
DescriptionUsing Scribus 1.3.6.svn as built from the OpenSolaris build notes here:

http://bugs.scribus.net/view.php?id=8714#bugnotes

I am unable to save files to my home folder nor any other folder from Scribus. The error reads:

Cannot write the file:
/export/home/user/Document.sla

I've attached a screen grab for reference too.


Steps To ReproduceLaunch Scribus.

Create a new single paged A4 document.

Goto File -> Save As

Select the home directory of the user account Scribus was launched from, then click OK.
Additional InformationScribus build information:
9 January 2010
Build ID: C-C-T-F-C1.8.8

I have created a folder with full permissions (777), Scribus will not save into this.

I can see no errors echoed to the console when Scribus is launched from a terminal.

Generally the behaviour seems 100 percent consistent.

TagsNo tags attached.
Patch

Activities

davenz

2010-03-12 21:48

reporter  

cannotwritefile.png (7,290 bytes)
cannotwritefile.png (7,290 bytes)

gpittman

2010-03-14 16:22

developer   ~0023508

I'm in the process of trying to compile Scribus on OSOL also -- stuck at the running cmake ATM.

There is an odd peculiarity with the permissions in OSOL. It took me a bit to figure out that my home directory is in /export/home...

I tried to run cmake as myself rather than root, specifying a path in my home directory, but it wasn't allowed, whereas running as root is Ok.
So my hunch is that your saving problem relates to that. Have you tried running chown on /export?

cbradney

2010-03-14 17:26

administrator   ~0023509

Greg, CMake runs fine without breaking your permissions setup on those directories...

gpittman

2010-03-20 18:34

developer   ~0023574

Last edited: 2010-03-20 18:39

View 2 revisions

I was able to start up another OSOL VM using davenz's instructions. Generally speaking, everything went according to plan. (Qt build time = about 2.5 hours)

One minor hitch was that in spite of setting -DCMAKE_INSTALL_PREFIX:PATH with cmake, and despite the lack of any error messages with 'pfexec make install' (or 'pfexec gmake install') afaict it didn't install anywhere.

I managed it manually by creating a directory, then 'cp -R sfw_stage/*' to that directory.

I have _not_ seen the problem of not being able to save Scribus documents. I can save them, create PDFs without problems.

Based on my experiences, I would advise trying to strictly adhere to davenz's instructions. With my prior effort, ie, starting with a stable OSOL, then trying to update to the dev image, there were many issues with finding necessary development packages, aside from the horrendous amount of time it took to do this switch from stable to dev.

davenz

2010-03-21 23:11

reporter   ~0023592

Last edited: 2010-03-21 23:54

View 2 revisions

It seems that Cmake is ignoring the installation directory specified by -DCMAKE_INSTALL_PREFIX:PATH=/export/home/someuser

I can confirm that after copying the contents of the sfw_stage directory as noted by gpittman above to the directory specified by -DCMAKE_INSTALL_PREFIX:PATH=/export/home/someuser I can then save .sla files. Without performing this step, I can confirm I am unable to save .sla files to directories where I have permission to do so.

Running cmake version 2.6-patch 2.

FirasH

2014-07-03 15:34

developer   ~0032441

OpenSolaris has been discontinued. Closing.

Issue History

Date Modified Username Field Change
2010-03-12 21:48 davenz New Issue
2010-03-12 21:48 davenz File Added: cannotwritefile.png
2010-03-14 16:22 gpittman Note Added: 0023508
2010-03-14 17:26 cbradney Note Added: 0023509
2010-03-20 18:34 gpittman Note Added: 0023574
2010-03-20 18:39 gpittman Note Edited: 0023574 View Revisions
2010-03-21 23:11 davenz Note Added: 0023592
2010-03-21 23:54 davenz Note Edited: 0023592 View Revisions
2014-07-03 15:34 FirasH Note Added: 0032441
2014-07-03 15:34 FirasH Status new => closed