View Issue Details

IDProjectCategoryView StatusLast Update
0008997ScribusUsabilitypublic2016-05-15 22:53
Reporterzoffix Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
PlatformPCOSUbuntuOS Version9.10
Product Version 
Target VersionFixed in Version 
Summary0008997: Copy Page dialog should remember last used values
DescriptionFirst of all, I understand that Scribus is used for many different projects and perhaps someone would wish to have the defaults that the "Copy Page" dialog current has.

Personally, work with 40-100 paged catalogs and I often create a "skeleton" of the catalog - chapter cover pages and catalog's cover page. Then I build a "template" for products and then I copy those pages over where I need them.

Problem is that every time I run Copy Page, the default in the dialog for destination is "At the end".

----
Ideally, I believe the interface should remember the last value use here. If not, I think the "After page" option should be the default.
----

I think an arbitrary page would rarely be copied to the end of the document. A more probable would be a scenario of the last page of the document to be copied at the end, in which case, the "After page" would function exactly as "At the end".

Tagscopy page, workflow
PatchNo

Relationships

duplicate of 0006506 acknowledged Dialog boxes should remember their settings 
related to 0004751 new Some file dialogs use unreasonable default directories 
related to 0012493 confirmed "Export to Image" dialog proposes bad prefix, folder and image type 

Activities

ale

2010-04-08 07:23

manager   ~0023652

- in my eyes, "at the end" is a sensible is a sensible default

- remembering the last choice may be a good idea

- instead of copying pages you should try to use a mixture of master pages and scrapbook elements

- import the page from an external file may also be a better choice

zoffix

2010-04-08 12:03

reporter   ~0023654

Thanks for your suggestions, I'll try them out to see if they will server better than copying pages.

As far as this report goes, can we perhaps change it into feature request for the dialog to remember last used values?

Kunda

2016-04-13 02:30

manager   ~0040108

This looks like a dupe of 0006506

Kunda

2016-04-13 02:39

manager   ~0040109

Resolving as duplicate.

Issue History

Date Modified Username Field Change
2010-04-07 19:55 zoffix New Issue
2010-04-07 19:57 zoffix Tag Attached: interface
2010-04-07 19:57 zoffix Tag Attached: copy page
2010-04-07 19:57 zoffix Tag Attached: default
2010-04-08 07:23 ale Note Added: 0023652
2010-04-08 12:03 zoffix Note Added: 0023654
2010-04-08 13:45 ale Severity tweak => feature
2010-04-08 13:45 ale Summary Default values in Copy Page dialog are not reasonable => Copy Page dialog should remember last used values
2014-10-07 23:24 Kunda Tag Detached: default
2014-10-24 09:55 Kunda Relationship added related to 0012493
2015-07-10 04:14 Kunda Relationship added related to 0004751
2015-10-05 02:31 Kunda Target Version => 1.5.2
2015-11-11 00:18 Kunda Tag Attached: workflow
2016-01-23 17:15 cbradney Target Version 1.5.2 => 1.5.4.svn
2016-04-13 02:25 Kunda Relationship added related to 0006506
2016-04-13 02:30 Kunda Note Added: 0040108
2016-04-13 02:38 Kunda Relationship replaced duplicate of 0006506
2016-04-13 02:39 Kunda Status new => resolved
2016-04-13 02:39 Kunda Resolution open => duplicate
2016-04-13 02:39 Kunda Assigned To => Kunda
2016-04-13 02:39 Kunda Patch => No
2016-04-13 02:39 Kunda Note Added: 0040109
2016-04-13 02:39 Kunda Target Version 1.5.4.svn =>
2016-04-13 02:40 Kunda Assigned To Kunda =>
2016-04-13 03:01 Kunda Tag Detached: interface
2016-05-15 22:53 cbradney Status resolved => closed