View Issue Details

IDProjectCategoryView StatusLast Update
0009008ScribusBuild Systempublic2014-07-09 23:43
Reportermdriftmeyer Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformDebian SidOSLinuxOS Version2.6.x
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0009008: Building without GraphicksMagick++
Descriptioncmake modules configuration for FindGMAGICK.cmake is not finding pkgconfig for GraphicsMagick++.pc under /usr/lib/pkgconfig/

I checked my configuration and this is my set up with GraphicsMagick 1.3.12 from Debian Sid.

GraphicsMagick++.pc

prefix=/usr
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include/GraphicsMagick


Name: GraphicsMagick++
Version: 1.3.12
Description: C++ API for GraphicsMagick image processing library
Requires: GraphicsMagick
Libs: -lGraphicsMagick++
Cflags:
Additional InformationAll necessary dev packages and libs are included except the dbg package:

http://packages.debian.org/source/sid/graphicsmagick

Even adding: http://packages.debian.org/sid/graphicsmagick-libmagick-dev-compat

which removes the following packages:

Removing libmagick++-dev ...
Removing libmagickwand-dev ...
Removing libmagickcore-dev

doesn't enable me to graphicsmagick via FindGMAGICK.cmake

# - Try to find GraphicsMagick++
# Once done, this will define
#
# GMAGICK_FOUND - system has zziplib
# GMAGICK_INCLUDE_DIRS - the zziplib include directories
# GMAGICK_LIBRARIES - link these to use zziplib

include(FindPkgConfig)

# Use pkg-config to get hints about paths
pkg_check_modules(GMAGICK_PKGCONF GraphicsMagick++)

# Include dir
find_path(GMAGICK_INCLUDE_DIR
  NAMES Magick++.h
  PATHS ${GMAGICK_PKGCONF_INCLUDE_DIRS}
)

# Finally the library itself
find_library(GMAGICK_LIBRARY
  NAMES GraphicsMagick++
  PATHS ${GMAGICK_PKGCONF_LIBRARY_DIRS}
)

INCLUDE(FindPackageHandleStandardArgs)
FIND_PACKAGE_HANDLE_STANDARD_ARGS(GMAGICK DEFAULT_MSG GMAGICK_LIBRARY GMAGICK_INCLUDE_DIR)
IF(GMAGICK_FOUND)
    set(GMAGICK_INCLUDES ${GMAGICK_INCLUDE_DIR})
    set(GMAGICK_LIBRARIES ${GMAGICK_LIBRARY})
ELSE()
    set(GMAGICK_INCLUDES)
    set(GMAGICK_LIBRARIES)
ENDIF()


NOTE:

Magick++.h is under /usr/include/GraphicsMagick

for GraphicsMagick 1.3.12 in Debian.
TagsNo tags attached.
Patch

Activities

cbradney

2010-04-12 19:40

administrator   ~0023669

What version of CMake are you using?

perosredo

2014-02-04 06:50

reporter   ~0031267

Could not reproduce with Debian testing.

Kunda

2014-07-08 03:37

updater   ~0032569

mdriftmeyer, please check back in about this bug.
Can you reproduce this with current stable/dev versions?
What version of Cmake are you using?

FirasH

2014-07-09 23:43

developer   ~0032645

Closing, very old report.

Issue History

Date Modified Username Field Change
2010-04-12 06:37 mdriftmeyer New Issue
2010-04-12 19:40 cbradney Note Added: 0023669
2014-02-04 06:50 perosredo Note Added: 0031267
2014-07-08 03:37 Kunda Note Added: 0032569
2014-07-08 03:37 Kunda Status new => feedback
2014-07-09 23:43 FirasH Note Added: 0032645
2014-07-09 23:43 FirasH Status feedback => closed
2014-07-09 23:43 FirasH Resolution open => unable to reproduce