View Issue Details

IDProjectCategoryView StatusLast Update
0000948ScribusStory Editor / Text Framespublic2008-02-08 16:16
Reporterlkaratzas Assigned Tochristoph_s  
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionno change required 
PlatformPCOSSuseOS Version9.0
Product Version1.2CVS 
Target VersionFixed in Version 
Summary0000948: Various text frame bugs
DescriptionText related bugs
1. When I load a 20 page Greek unicode chapter (included as an attachment) and try to go straight to a page other than page one, the frames look empty and remain empty no matter how long I wait. In order to see the text, I have to go to page one and navigate one page at a time to get where I want.
2. A drop cap that is supposed to cover two lines covers four.
3. If I add a page based on a new template I made, which essentially consists of just one text box smaller than the margins, what I get is my text continued into a text box of the size of the margins and a dotted line outline of the box it should ideally have poured into.
4. In order to persuade the text to flow into a box of the right size, I tried to change the margin guides through the Preferences-Document-Margin Guides bringing them exactly where I want my box to be, but although I filled in the new measurements, the guides refused to budge. The file-document setup dialogue, however, did the job.
5. I took a look at the .sla file of my chapter written in Greek unicode and I realized that my sentences are broken up into very small parts, sometimes consisting of only one letter. This shouldn't be happening and is probably the reason why selecting a word with the mouse or the keyboard within a box is so sluggish.

Story Editor Bug
As soon as you try to copy and paste in the SE, the text goes haywire.
TagsNo tags attached.
Patch

Relationships

related to 0003828 acknowledged Metabug: Hyphenation 

Activities

2004-08-08 15:42

 

WorkingFirstChapter.sla.gz (55,112 bytes)

cbradney

2004-08-08 15:57

administrator   ~0002144

1. Duplicate of bug 547
2. Is a duplicate of 633
3. Dont quite understand. Frames on template pages arent possible to put text into from the normal page, if thats what you are trying to do.
4. Thats normal. Preferences, Document is the default for all documents. File Document Setup is for the current one.
5. The are broken up due to hyphenation. This is how its supposed to be, for now.

cbradney

2004-08-09 14:16

administrator   ~0002150

> Dont quite understand. Frames on template pages arent
> possible to put
> text into from the normal page, if thats what you are
> trying to do.
No. As I add pages in order to get my text to flow into
their text boxes, I make a new template with a narrower
text box in its page. I now add a page based on the new
template and expect my text to flow into it. Instead of
this, I see my text flowing into the old box which is
delineated by the margins and my new box is just an
inaccessible shadow outlined by dotted lines.
> 5. The are broken up due to hyphenation. This is how its
> supposed to be,
> for now.
>
Yes, but the Story Editor copy/paste bug I mentioned is
probably related to this. When you copy something from the
SE and paste it somewhere else, the cursor jumps to the
beginning of the paragraph and traverses the whole text
syllable by syllable, probably re-hyphenating (???). For a
20 page document this can take half an hour or more and I
don't see why it should happen since the same operation
within the text box is carried out without a hitch.

cbradney

2004-08-09 14:17

administrator   ~0002151

Please post in here your replies.. not to the emails.

cbradney

2004-08-09 14:19

administrator   ~0002152

If you want to use varying text frame sizes, then you cant use automatic text frames which I assume you are by your description.

The only way we know to change properties of text in the SE is they way its doing it now. What you see has nothing to do with hyphenation.

lkaratzas

2004-09-09 15:23

reporter   ~0002347

The issues have either been answered or changed.

Issue History

Date Modified Username Field Change
2004-08-08 15:42 lkaratzas New Issue
2004-08-08 15:42 lkaratzas File Added: WorkingFirstChapter.sla.gz
2004-08-08 15:57 cbradney Note Added: 0002144
2004-08-09 14:16 cbradney Note Added: 0002150
2004-08-09 14:17 cbradney Note Added: 0002151
2004-08-09 14:19 cbradney Note Added: 0002152
2004-09-09 15:23 lkaratzas Status new => closed
2004-09-09 15:23 lkaratzas Note Added: 0002347
2006-05-16 22:22 christoph_s Relationship added related to 0003828
2008-02-08 16:16 christoph_s Status closed => resolved
2008-02-08 16:16 christoph_s Resolution open => no change required
2008-02-08 16:16 christoph_s Assigned To => christoph_s
2008-02-08 16:16 christoph_s Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames