View Issue Details

IDProjectCategoryView StatusLast Update
0009592ScribusStory Editor / Text Framespublic2011-01-03 14:28
Reportergpittman Assigned Tojghali  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx86 32bitOSWindowsOS VersionXP
Product Version1.3.9 
Target Version1.4.0Fixed in Version1.4.0svn 
Summary0009592: crash with sequential cutting of text
DescriptionScribus abruptly crashes in Story Editor after 2 sequential uses of Ctrl+X
Initially reported by Tom Connolly on mailing list using Vista, verified by me on XP
Steps To ReproduceFirst way :
make text frame
open SE
enter some text
highlight some text, cut with Ctrl+X
highlight more text, cut with Ctrl+X
Scribus immedately crashes with no warning dialog:

Second way:
create new doc with 2 pages and automatic frames
fill with sample text so you have text in both frame
scroll page so as you can view both pages
double click first frame to enter edit mode
select and Ctrl+X until you see that you have deleted enough text and second frame does not contain text anymore
click second frame and splat!
Additional Informationdoes not happen in Linux 1.4.0svn
TagsNo tags attached.
Patch

Activities

gpittman

2010-12-17 21:40

developer   ~0025151

Some further observations:
Not precisely reproducible in this specific way.
It seems to be most likely to occur when a subsequent highlighting is for all the remaining text in the frame, and may happen after more than the second time you use Ctrl+X in a row. Can occur with text entered from the keyboard or sample text.

jghali

2010-12-17 22:38

administrator   ~0025152

I've added a second way to reproduce the crash which works quite reliably. Not even using Story Editor

gpittman

2010-12-18 02:33

developer   ~0025153

Last edited: 2010-12-18 02:33

View 2 revisions

It may be only intermittent, but I can sometimes reproduce this on my 64-bit Fedora 14 (1.4.0svn). Scribus gives a Signal#11 message as reported by Teodor.

There is also a slight variant in Linux, not in Windows:
Go to Story Editor
highlight text with mouse
Ctrl+X
highlight more text with mouse (doesn't have to be all of it)
When you let up on mouse button - Signal#11

plinnell

2011-01-03 14:28

viewer   ~0025260

resolved

Issue History

Date Modified Username Field Change
2010-12-17 21:32 gpittman New Issue
2010-12-17 21:40 gpittman Note Added: 0025151
2010-12-17 22:38 jghali Note Added: 0025152
2010-12-17 22:38 jghali Target Version => 1.4.0
2010-12-17 22:38 jghali Steps to Reproduce Updated View Revisions
2010-12-18 02:33 gpittman Note Added: 0025153
2010-12-18 02:33 gpittman Note Edited: 0025153 View Revisions
2010-12-18 22:35 jghali Status new => resolved
2010-12-18 22:35 jghali Fixed in Version => 1.4.0svn
2010-12-18 22:35 jghali Resolution open => fixed
2010-12-18 22:35 jghali Assigned To => jghali
2011-01-03 14:28 plinnell Note Added: 0025260
2011-01-03 14:28 plinnell Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames